Subject: RFC 4193

From: "Prabhu Harihar" <[email-masked]>
Date: Tue, 8 Jan 2008 16:43:56 +0530

Hi,

Is there any implementation available for RFC 4193 (Unique Local IPv6
Unicast Address) on a "host machine"?

Since the "Global ID" in these address are to be randomly generated, there
is no way to manual assign a local ipv6 address to an interface?

Regards,
Prabhu H
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Mark Andrews <[email-masked]>
Date: Tue, 08 Jan 2008 22:59:36 +1100

> Unicast Address) on a "host machine"?

	Yes.  ALL EXISTING IPV6 IMPLEMENTATIONS SUPPORT THIS.

	Find a ethernet card.  Push the address through a cryptographic
	hash.  Select a group of octets.

	Mark

% ifconfig bge0
bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=1b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
        inet6 fe80::214:22ff:fed9:fbdc%bge0 prefixlen 64 scopeid 0x1 
        inet 192.168.191.236 netmask 0xffffff00 broadcast 192.168.191.255
        inet6 fd92:7065:b8e:0:214:22ff:fed9:fbdc prefixlen 64 autoconf 
        inet6 2001:470:1f00:820:214:22ff:fed9:fbdc prefixlen 64 autoconf 
        ether 00:14:22:d9:fb:dc
        media: Ethernet autoselect (10baseT/UTP <half-duplex>)
        status: active
% echo 00:14:22:d9:fb:dc | md5
6fb5ee6273a57a2d597e62bbc84e1a13
% 

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: <[email-masked]>
Date: Tue, 8 Jan 2008 13:04:30 -0000

> Is there any implementation available for RFC 4193 (Unique 
> Local IPv6 Unicast Address) on a "host machine"?  
> 
> Since the "Global ID" in these address are to be randomly 
> generated, there is no way to manual assign a local ipv6 
> address to an interface?  

You should only generate the Global ID once, for your entire
site. Then use this Global ID in the same way that you use
the /48 assigned by your ISP, except that you tell all your
Internet gateway devices to block fc00::/7 traffic and
announcements.

This should not affect the way in which interface addresses
are assigned and you could certainly use the same interface
address with both the ULA prefix and the ISP-assigned prefix.

--Michael Dillon

---

From: "Prabhu Harihar" <[email-masked]>
Date: Tue, 8 Jan 2008 18:41:34 +0530

Thanks for the reply Mark!

The "local ipv6 address" output line contains "autoconf" flag, so I believe
this has been configured after reception of RA packet with prefix
"fd92:7065:b8e:0"

If this is the case, then I assume all the nodes in the site will have the
same prefix (includes global id).  So from the host point of view, this
local ipv6 address will behave like yet another global address and doesn't
need any implementation for generating random global id.

Regards,
Prabhu H

---

From: Mark Andrews <[email-masked]>
Date: Wed, 09 Jan 2008 10:08:08 +1100

> need any implementation for generating random global id.

	Yep.  It's a site prefix.

	Your border routers should, by default, be configured to
	block traffic to and from ULA in addition to the usual
	spoofed traffic suppression.

	e.g.
	01600 unreach admin ipv6 from any to fc00::/7 via gif0
	01700 unreach admin ipv6 from fc00::/7 to any via gif0

	Note: this sends back ICMPv6 messages.  You really do want
	your border routers to tell the applications/kernel that
	they have choosen the wrong IPv6 source address.

	Mark
 
> ------=_Part_27878_32489016.1199797894384
> Content-Type: text/html; charset=ISO-8859-1
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
> 
> Thanks for the reply Mark!<br><br>The &quot;local ipv6 address&quot; output l
> ine contains &quot;autoconf&quot; flag, so I believe this has been configured
>  after reception of RA packet with prefix &quot;fd92:7065:b8e:0&quot;
> <br><br>inet6 fd92:7065:b8e:0:214:22ff:fed9:fbdc prefixlen 64 autoconf<br><br
> >If this is the case, then I assume all the nodes in the site will have the s
> ame prefix (includes global id).&nbsp; So from the host point of view, this l
> ocal ipv6 address will behave like yet another global address and doesn&#39;t
> <br><br>Regards,<br>Prabhu H<br><br><br><div class="gmail_quote">On Jan 8, 20
> 08 5:29 PM, Mark Andrews &lt;<a href="mailto:[email-masked]">Mark_Andre
> [email-masked]</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-le
> ft: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1e
> x;">
> <div class="Ih2E3d"><br>&gt; Hi,<br>&gt;<br>&gt; Is there any implementation 
> available for RFC 4193 (Unique Local IPv6<br>&gt; Unicast Address) on a &quot
> ;host machine&quot;?<br><br></div> &nbsp; &nbsp; &nbsp; &nbsp;Yes. &nbsp;ALL 
> EXISTING IPV6 IMPLEMENTATIONS SUPPORT THIS.
> <br><br> &nbsp; &nbsp; &nbsp; &nbsp;Find a ethernet card. &nbsp;Push the addr
> ess through a cryptographic<br> &nbsp; &nbsp; &nbsp; &nbsp;hash. &nbsp;Select
>  a group of octets.<br><br> &nbsp; &nbsp; &nbsp; &nbsp;Mark<br><br>% ifconfig
>  bge0<br>bge0: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; mtu 1
> 500
> <br> &nbsp; &nbsp; &nbsp; &nbsp;options=1b&lt;RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWT
> AGGING&gt;<br> &nbsp; &nbsp; &nbsp; &nbsp;inet6 fe80::214:22ff:fed9:fbdc%bge0
>  prefixlen 64 scopeid 0x1<br> &nbsp; &nbsp; &nbsp; &nbsp;inet <a href="http:/
> /192.168.191.236" target="_blank">192.168.191.236</a>
>  netmask 0xffffff00 broadcast <a href="http://192.168.191.255" target="_blank
> ">192.168.191.255</a><br> &nbsp; &nbsp; &nbsp; &nbsp;inet6 fd92:7065:b8e:0:21
> 4:22ff:fed9:fbdc prefixlen 64 autoconf<br> &nbsp; &nbsp; &nbsp; &nbsp;inet6 2
> 001:470:1f00:820:214:22ff:fed9:fbdc prefixlen 64 autoconf
> <br> &nbsp; &nbsp; &nbsp; &nbsp;ether 00:14:22:d9:fb:dc<br> &nbsp; &nbsp; &nb
> sp; &nbsp;media: Ethernet autoselect (10baseT/UTP &lt;half-duplex&gt;)<br> &n
> bsp; &nbsp; &nbsp; &nbsp;status: active<br>% echo 00:14:22:d9:fb:dc | md5<br>
> 6fb5ee6273a57a2d597e62bbc84e1a13<br>%<br><div><div>
> </div><div class="Wj3C7c"><br>&gt; Since the &quot;Global ID&quot; in these a
> ddress are to be randomly generated, there<br>&gt; is no way to manual assign
>  a local ipv6 address to an interface?<br>&gt;<br>&gt; Regards,<br>
> &gt; Prabhu H<br><br></div></div><font color="#888888">--<br>Mark Andrews, IS
> C<br>1 Seymour St., Dundas Valley, NSW 2117, Australia<br>PHONE: +61 2 9871 4
> 742 &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; INTERNET: <a href
> ="mailto:[email-masked]">
> [email-masked]</a><br></font></blockquote></div><br>
> 
> ------=_Part_27878_32489016.1199797894384--
> 
> 
> --===============0892793651==
> Content-Type: text/plain; charset="us-ascii"
> MIME-Version: 1.0
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
> 
> --===============0892793651==--
>