Subject: RFC 5453 Reserved Interface Identifiers

From: Chad Kissinger <[email-masked]>
Date: Fri, 17 Dec 2010 14:02:59 -0600

Hello,

We are deploying IPV6 to our customers and are carefully planning the architecture of how we are going to deploy prefixes, assign customer gateways and how we are going to number our own infrastructure in a meaningful way.  Although I think Stateless Autoconfiguration will be used quite a deal for nodes that are "clients", most of my customers have large server farms and our infrastructure, of course, has many routers.  I would think it would be preferable to be able to either use a DHCPV6 pool or to use manual configuration so that the resulting Interface Identifier is either bounded within a known range (tighter than 64 bits wide) or is a specific predictable address (like ::ABC/128 for all customer Gateways, etc.) or to have patterns like :AAAA: within an Identifier for all Edge Routers for easier "on sight" identification by SysAdmins...

However, after many days of reading, I cannot find any place that specifically details the method one would use to identify suitable ranges to choose from for a manually configured Interface ID or a pool of such IDs.  Is it as simple as setting the 71st and 72nd bit and avoiding Anycast addresses?

RFC 5453 seems to be written to address this, but seems to have all the relevant detail missing...

What am I missing?  Isn't this a concern for everyone?

chad kissinger  |  founder-vp  |  onramp access, llc
p: 512.322.9200  |  f: 512.476.2878  |  www.onr.com<http://www.onr.com/>
your internet operations  |  built  |  deployed  |  managed

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 18 Dec 2010 14:03:15 +1300

Chad,

Why would you want a specific range? To reduce the (small)
risk from scanning attacks, a unique pseudo-random choice would be
better, IMHO, as long as it conforms to RFC 4291 and 5453.

BTW this question might fit better on the v6ops list or even
on [email-masked] where there are lots of operational
people.

Regards
   Brian Carpenter

On 2010-12-18 09:02, Chad Kissinger wrote:
> ------------------------------------------------------------------------
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 20 Dec 2010 19:55:39 -0500

Hi Chad,

On 10-12-17 03:02 PM, Chad Kissinger wrote:
>  
> 
> Hello,
> 
>  
> 
> We are deploying IPV6 to our customers and are carefully planning the 
> architecture of how we are going to deploy prefixes, assign customer 
> gateways and how we are going to number our own infrastructure in a 
> meaningful way.  Although I think Stateless Autoconfiguration will be 
> used quite a deal for nodes that are “clients”, most of my customers 
> have large server farms and our infrastructure, of course, has many 
> routers.  I would think it would be preferable to be able to either use 
> a DHCPV6 pool or to use manual configuration so that the resulting 
> Interface Identifier is either bounded within a known range (tighter 
> than 64 bits wide) or is a specific predictable address (like ::ABC/128 
> for all customer Gateways, etc.) or to have patterns like :AAAA: within 
> an Identifier for all Edge Routers for easier “on sight” identification 
> by SysAdmins…
> 
>  
> 
> However, after many days of reading, I cannot find any place that 
> specifically details the method one would use to identify suitable 
> ranges to choose from for a manually configured Interface ID or a pool 
> of such IDs.  Is it as simple as setting the 71^st and 72^nd bit and 
> avoiding Anycast addresses? 
> 
>  
> 
> RFC 5453 seems to be written to address this, but seems to have all the 
> relevant detail missing…

The goal of RFC5453 was to list the addresses not suitable for stateless 
auto-configuration, and not exactly to list those that are suitable for 
manual configuration. I think you have the right idea though. As long as 
the bits 6 and 7 (counting from 0) of the interface identifier are set 
to 0 in your manually configured address, you should have no issues.

Cheers
Suresh