Subject: [Technical Errata Reported] RFC6874 (3631)

From: RFC Errata System <[email-masked]>
Date: Wed, 22 May 2013 20:59:36 -0700 (PDT)

The following errata report has been submitted for RFC6874,
"Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource Identifiers".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6874&eid=3631

--------------------------------------
Type: Technical
Reported by: Michael Sweet <[email-masked]>

Section: 4

Original Text
-------------
   An HTTP client, proxy, or other intermediary MUST remove any ZoneID
   attached to an outgoing URI, as it has only local significance at the
   sending host.

Corrected Text
--------------
   An HTTP client, proxy, or other intermediary MUST retain any ZoneID
   attached to an outgoing URI, as it will be the only way for an HTTP server
   to return a URI containing a link-local address that can subsequently be
   used by the HTTP client.

Notes
-----
The original advice ignores a very real issue: HTTP Servers that generate URIs from the client's Host: need to include the Client's zoneid in order for the link local address to be usable/routable.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6874 (draft-ietf-6man-uri-zoneid-06)
--------------------------------------
Title               : Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource Identifiers
Publication Date    : February 2013
Author(s)           : B. Carpenter, S. Cheshire, R. Hinden
Category            : PROPOSED STANDARD
Source              : IPv6 Maintenance
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 23 May 2013 17:27:56 +1200

Again, completely wrong for the same reason that Erratum 3630 is wrong.

Regards
   Brian Carpenter

---

From: Michael Sweet <[email-masked]>
Date: Thu, 23 May 2013 02:10:25 -0400

See my previous response.

Sent from my iPad