Subject: New draft - draft-lepape-6man-prefix-metadata-00

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Mon, 22 Jul 2013 09:01:34 +0000

Hello,

A new draft draft-lepape-6man-prefix-metadata-00<http://tools.ietf.org/html/draft-lepape-6man-prefix-metadata-00>  describing a method for applications to learn and influence source address selection by associating IPv6 prefixes with meta-data when configured by the network is submitted. Motivation to do this and details of a prototype that has been developed are included. Related drafts that define DHCPv6 and ND options to realize conveying of meta-data associated with a prefix are draft-bhandari-dhc-class-based-prefix<http://tools.ietf.org/html/draft-bhandari-dhc-class-based-prefix-05> <http://tools.ietf.org/html/draft-bhandari-dhc-class-based-prefix-05> and <http://tools.ietf.org/html/draft-korhonen-6man-prefix-properties-02> draft-korhonen-6man-prefix-properti<http://tools.ietf.org/html/draft-korhonen-6man-prefix-properties-02>es<http://tools.ietf.org/html/draft-korhonen-6man-prefix-properties-02>. Motivation for doing this work is relevant to homenet hence adding homenet wg.

Appreciate review of the draft and comments.

Thanks,
Shwetha

On 7/15/13 8:52 PM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

A new version of I-D, draft-lepape-6man-prefix-metadata-00.txt
has been successfully submitted by Maico Le Pape and posted to the
IETF repository.

Filename:     draft-lepape-6man-prefix-metadata
Revision:     00
Title:         IPv6 Prefix Meta-data and Usage
Creation date:     2013-07-15
Group:         Individual Submission
Number of pages: 16
URL:             http://www.ietf.org/internet-drafts/draft-lepape-6man-prefix-metadata-00.txt
Status:          http://datatracker.ietf.org/doc/draft-lepape-6man-prefix-metadata
Htmlized:        http://tools.ietf.org/html/draft-lepape-6man-prefix-metadata-00

Abstract:
   This document presents a method for applications to influence the
   IPv6 source selection algorithm used by the IP stack in a host.  To
   do so, IPv6 prefixes are associated with meta-data when configured by
   the network.  This meta-data allows the network to describe the
   purpose and properties of the prefix enabling applications to make
   intelligent decision when selecting a prefix.

The IETF Secretariat

---

From: Tim Chown <[email-masked]>
Date: Wed, 24 Jul 2013 18:29:04 +0100

On 22 Jul 2013, at 10:01, Shwetha Bhandari (shwethab) <[email-masked]> wrote:

> Hello,
> 
> A new draft draft-lepape-6man-prefix-metadata-00  describing 
> a method for applications to learn and influence source address selection by associating
> IPv6 prefixes with meta-data when configured by
> the network is submitted. Motivation to do this and details of a prototype that has been developed are included. Related drafts that define DHCPv6 and ND options to realize
>  conveying of meta-data associated with a prefix are draft-bhandari-dhc-class-based-prefix
> and 
> draft-korhonen-6man-prefix-properties.
> Motivation for doing this work is relevant to homenet hence adding homenet wg.

Hi Swetha,

You may want to have a look at draft-anipko-mif-mpvd-arch-00, if you ahven't already, which is work from a design team in the mif WG. Section 4.2.2 is very relevant.  The "metadata" could also be provisioning domain information, perhaps.

Tim

> 
> On 7/15/13 8:52 PM, "[email-masked]" <[email-masked]> wrote:
> 
>> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------