Subject: 6MAN WG Last Call: <draft-ietf-6man-resilient-rs-01>

From: Ole Troan <[email-masked]>
Date: Fri, 23 Aug 2013 09:53:30 +0200

All,

This message starts the second two week 6MAN Working Group on advancing:

	Title           : Packet loss resiliency for Router Solicitations
	Author(s)    : S. Krishnan, D. Anipko, D. Thaler
	Filename    : draft-ietf-6man-resilient-rs-01
	Pages        : 6
	Date          : 2013-05-06

     http://tools.ietf.org/html/draft-ietf-6man-resilient-rs-01

as a Proposed Standard.  Substantive comments and statements of support for advancing this document should be directed to the mailing list. Editorial suggestions can be sent to the authors.  This last call will end on September 6, 2013.

The chairs would like to solicit one or two people in the working group to do a detailed review of the document. We would also encourage volunteers to act as document shepherds. Please contact the chairs directly.

Regards,

Bob Hinden & Ole Trøan

---

From: Ole Troan <[email-masked]>
Date: Fri, 23 Aug 2013 10:14:58 +0200

all,

short and sweet document; a few comments if I may.

- this new behaviour is supposed to be implemented by all hosts, right? shouldn't this document then update rfc4861?
- "AP" isn't defined section 1.
- section 1 bullet b. couldn't you argue that turning off periodic RAs is a configuration error?
- section 1 bullet c. If a link isn't multicast capable, you couldn't send RS in the general case either.
                             ISATAP has special provisions for that. could you make c) more general?

- section 2.1. "…results in a default route". is awkward. this is the function we call "router discovery" in rfc4861,
                     where the host discovers a "default router". perhaps just copy or reference rfc4861 verbatim:
   "Once the host sends a Router Solicitation, and receives a valid
   Router Advertisement with a non-zero Router Lifetime, the host MUST
   desist from sending additional solicitations on that interface, until
   the next time one of the above events occurs.  Moreover, a host
   SHOULD send at least one solicitation in the case where an
   advertisement is received prior to having sent a solicitation.
   Responses to solicited advertisements may contain more information
   than unsolicited advertisements."

Best regards,
Ole