Subject: Question about ug bits

From: "Hosnieh Rafiee" <[email-masked]>
Date: Fri, 2 Aug 2013 23:18:19 +0200

Hello,

have a question. Is it possible to use bits u and g (reserved bits) as part
of the IID interface when using any IID generation approach? For instance,
using it for SSAS.

Thanks,
Best,
Hosnieh

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 03 Aug 2013 10:44:28 +1200

Hosnieh,

Please see http://tools.ietf.org/html/draft-ietf-6man-ug-01
whose WG Last Call just ended, with a few comments to
be incorporated.

IMHO, since we seem to agree that these bits have no defined
semantics in an IID, you can specify them as you want in a
new IID format. I would only suggest paying attention to the
last paragraph of section 3:

"To the extent that each method of IID creation specifies the values
 of the "u" and "g" bits, and that each new method is carefully
 designed in the light of its predecessors, these bits tend to reduce
 the chances of duplicate IIDs."

Regards
   Brian Carpenter

On 03/08/2013 09:18, Hosnieh Rafiee wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: "Hosnieh Rafiee" <[email-masked]>
Date: Sat, 3 Aug 2013 09:26:06 +0200

Hi Brian,
Yes, I followed the discussion about your draft. This is why I asked to be sure about my assumption.

Thank you for clarifications.

Best,
Hosnieh
> whose WG Last Call just ended, with a few comments to be incorporated.
> 
> IMHO, since we seem to agree that these bits have no defined semantics in an
> IID, you can specify them as you want in a new IID format. I would only suggest
> paying attention to the last paragraph of section 3:
> 
> "To the extent that each method of IID creation specifies the values  of the "u"
> and "g" bits, and that each new method is carefully  designed in the light of its
> predecessors, these bits tend to reduce  the chances of duplicate IIDs."
> 
> Regards
>    Brian Carpenter
> 
> > have a question. Is it possible to use bits u and g (reserved bits) as
> > part of the IID interface when using any IID generation approach? For
> > instance, using it for SSAS.
> >
> > Thanks,
> > Best,
> > Hosnieh
> >