Subject: FW: Adoption call of draft-halpern-6man-nd-pre-resolve-addr for 6MAN

From: Hosnieh Rafiee <[email-masked]>
Date: Wed, 24 Sep 2014 14:26:43 +0000

Hi,

I reviewed this draft and I got confused. If my memory help me...this is what I can remember from DAD process.... 

During DAD process, usually node A who joined to the network, generates its IP address, generates a NS message by setting the source address either to one of reserved address (something like fe80::x) or set it to its temporary generated address (usually the former point happens), set the target address to the address that it generated and sends an unsolicited NS message to a multicast group (not set the solicit bit) and ask other nodes whether anybody has this address. If any nodes receives this message, it checks whether the target is the same as its own address, if it is then it answers with a solicited NS message and tells this node that it has this address and node A needs to repeat its process. But this is actually a solicited NS message only to node A and not multicast message. Until this point no node caches the IP address of this new node.  Now if node A doesn't receive any answer to its NS message, it sends a NA message by setting the bit to tells the node to override their cache to multicast group and advertise its IP address.

At this point when any routers or other nodes in the network receive this message, they cache the IP address of the node. 

" In IPv6, when a device initializes an interface, a special Neighbor
   Solicitation (NS) message is sent to perform Duplicate Address
   Detection (DAD) [RFC4862] to determine whether a particular address
   is already assigned to a different interface on the same multi-access
   link.  This special message, referred to as DAD-NS in the rest of
   this draft, is an NS message with an unspecified source address.  The
   target address of this DAD-NS is the IPv6 unicast address that is
   intended for new interface."

So according to this scenario, DAD-NS message doesn't have any unicast source address and it is only a reserved source address and at this point no node cache any IP address of other nodes. This is the same as a router.

So probably you are talking about NA message with bit sets to override the cache? 

Now another scenario is that when two nodes wants to check their cache or find out whether or not their value in cache is up-to-date. This is of course not DAD process...

This is NS/NS messages exchanged between nodes. In this case the source address is unicast and destination address is unicast as well. So no routers in this case receive this message if it is not explicitly put in the destination address.
In other word, for cache reachability no node sends a multicast message, it is only unicast NS messages to a single destination and they never send it as a broadcast.
So, it appears that this is not the case that this draft talks about but, in my opinion, for other case, NS message is not what the draft needs to talk about, and it is NA message.

Thanks,
Best,
Hosnieh

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Ole Troan
Sent: Wednesday, September 24, 2014 9:25 AM
To: 6man WG
Subject: Adoption call of draft-halpern-6man-nd-pre-resolve-addr for 6MAN

All,

The authors have requested an adoption call for this document as an informational document.

Please provide a view with reasons as to whether the WG should adopt this or not.

This message starts a one week 6MAN Working Group call on adopting:

	Title           : Triggering ND Address Resolution on Receiving DAD-NS
	Author(s)    : I. Chen, J. Halpern
	Filename    : draft-halpern-6man-nd-pre-resolve-addr-00
	Pages        : 7
	Date          : 2014-01-10

http://tools.ietf.org/html/draft-halpern-6man-nd-pre-resolve-addr-00

The call ends on October 1st, 2014.

Regards,

Bob Hinden & Ole Trøan

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Hosnieh Rafiee <[email-masked]>
Date: Wed, 24 Sep 2014 14:30:56 +0000

Hi,

I reviewed this draft. It is good to mitigate DoS attack however I got confused about the content. If my memory help me...this is what I can remember from DAD process.... 

Thanks,
Best,
Hosnieh

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Ole Troan
Sent: Wednesday, September 24, 2014 9:25 AM
To: 6man WG
Subject: Adoption call of draft-halpern-6man-nd-pre-resolve-addr for 6MAN

All,

Regards,

Bob Hinden & Ole Trøan