Subject: <draft-hinden-6man-rfc2460bis-07.txt>

From: Bob Hinden <[email-masked]>
Date: Mon, 28 Sep 2015 14:50:20 -0700

Hi,

I published the -07 version of the RFC2460bis draft.  See links below.

The purpose of this draft is to update references to current versions and assign references to normative and informative.  There are also a few editorial changes.

You can see the diff from the previous version at:

https://tools.ietf.org/rfcdiff?url2=draft-hinden-6man-rfc2460bis-07.txt

Please review this draft to verify that the changes are appropriate.

This is part of the project to move the core IPv6 specifications to Internet Standard.

With this draft, all of the errata and changes from updating RFCs have been incorporated, as well updating the references and assigned them to informative and normative.

In my role as editor for this draft, I believe it is ready for Ole Troan to consider an adoption call to be an 6man w.g. document.

Regards,
Bob

p.s. I will start working on updates to the IPv6 Addressing Architecture.

> On Sep 28, 2015, at 2:38 PM, [email-masked] wrote:
> 
> 
> A new version of I-D, draft-hinden-6man-rfc2460bis-07.txt
> has been successfully submitted by Robert M. Hinden and posted to the
> IETF repository.
> 
> Name:		draft-hinden-6man-rfc2460bis
> Revision:	07
> Title:		Internet Protocol, Version 6 (IPv6) Specification
> Document date:	2015-09-28
> Group:		Individual Submission
> Pages:		36
> URL:            https://www.ietf.org/internet-drafts/draft-hinden-6man-rfc2460bis-07.txt
> Status:         https://datatracker.ietf.org/doc/draft-hinden-6man-rfc2460bis/
> Htmlized:       https://tools.ietf.org/html/draft-hinden-6man-rfc2460bis-07
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-hinden-6man-rfc2460bis-07
> 
> Abstract:
>   This document specifies version 6 of the Internet Protocol (IPv6),
>   also sometimes referred to as IP Next Generation or IPng.  It
>   obsoletes RFC2460
>

---

From: t.petch <[email-masked]>
Date: Tue, 29 Sep 2015 10:40:35 +0100

I am struck by the absence of any IANA Considerations.

IANA Registries currently point to RFC2460 in three places.  With that
RFC being obsoleted, I would have thought that those references should
be updated to point to this RFC-to-be.

Tom Petch

----- Original Message -----
From: "Bob Hinden" <[email-masked]>
To: "IPv6 List" <[email-masked]>
Cc: "Bob Hinden" <[email-masked]>
Sent: Monday, September 28, 2015 10:50 PM

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 29 Sep 2015 09:24:31 -0700

Tom,

> On Sep 29, 2015, at 2:40 AM, t.petch <[email-masked]> wrote:
> 

Good comment.  I was thinking that when this is published and because it obsoletes RFC2460, those pointers would get updated.  It would be straight forward to add text to the IANA considerations instructing the IANA to make those changes.  I will also look at the updating RFCs and see if there any similar changes.

Thanks,
Bob

---

From: David Farmer <[email-masked]>
Date: Wed, 30 Sep 2015 16:28:17 -0500

I'd like to suggest updating the Security Considerations section, I have 
two items, but maybe others have some additional suggestions too;

1. Privacy has become a much more important issue since RFC2460 was 
originally published.  Minimally, I'd suggest adding IPSec's roll in 
privacy in addition to it roll in security.

2. Beyond IPSec, I like to suggest the Operational Security 
Considerations for IPv6 Networks draft (draft-ietf-opsec-v6-07) get 
mentioned.

Thanks

-- 
================================================
David Farmer               Email: [email-masked]
Office of Information Technology
University of Minnesota
2218 University Ave SE     Phone: 1-612-626-0815
Minneapolis, MN 55414-3029  Cell: 1-612-812-9952
================================================

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 1 Oct 2015 11:22:09 +1300

On 01/10/2015 10:28, David Farmer wrote:
> I'd like to suggest updating the Security Considerations section, I have two items, but maybe others have some additional
> suggestions too;
> 
> 1. Privacy has become a much more important issue since RFC2460 was originally published.  Minimally, I'd suggest adding IPSec's
> roll in privacy in addition to it roll in security.
> 
> 2. Beyond IPSec, I like to suggest the Operational Security Considerations for IPv6 Networks draft (draft-ietf-opsec-v6-07) get
> mentioned.

Hmm. While those are both worthy topics, I am a bit against extending the scope
of RFC2460, since the objective here is to satisfy the criteria for full Standard
status. Anything we add makes it harder to meet the first criterion in BCP9:

>> (1) There are at least two independent interoperating implementations
>> with widespread deployment and successful operational experience.

The current Security Considerations section is weak, of course. But we can't
fix that without opening Pandora's Box.

    Brian

>> With this draft, all of the errata and changes from updating RFCs have been incorporated, as well updating the references and
>> assigned them to informative and normative.
>>