Subject: DHCPv6 PD and IPv6 ND unification ((RE: L=0 [was draft-pioxfolks-6man-pio-exclusive-bit-02.txt])

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 1 Feb 2018 19:39:08 +0000

> -----Original Message-----
> From: Mikael Abrahamsson [mailto:[email-masked]]
> Sent: Thursday, February 01, 2018 11:07 AM
> To: Templin, Fred L <[email-masked]>
> Cc: 6man WG <[email-masked]>
> Subject: RE: L=0 [was draft-pioxfolks-6man-pio-exclusive-bit-02.txt]
> 
> On Thu, 1 Feb 2018, Templin, Fred L wrote:
> 
> > I get your frustration, but I believe DHCPv6PD works if the implementer
> > simply follows the specs.
> 
> Didn't we just agree that DHCPv6-PD and relays was blatantly obvious and
> didn't need spec:s?

I mean the specs that tell how the client and server regard lease lifetimes
for IA_PDs, and how messages like Rebind, Renew, Release and Reconfigure
affect them. All the Relay has to do is understand how the lease lifetimes
are handled at the end systems so it can do the right thing as a man in the
middle.

> >> So your proposal of tunneling DHCPv6 inside RS/RA and if that means we get
> >> operational guidance such as "zero lifetime in the RA means deprecate all
> >> DHCPv6 resources you have" and similar, would help a long way.
> >
> > Do we want to put some energy behind this?
> 
> I'd prefer if we took some of DHCPv6 option space, some of the state
> machines, and ditched the rest, and explained how this was done using
> something else, for instance ND.
> 
> But short of that yes, there should be operational documents (in v6ops
> perhaps) that tells implementors how SLAAC and DHCPv6 works together, and
> what certain SLAAC messages means for DHCPv6 based resources.

Let's start with embedding DHCPv6 PD messages in IPv6 ND RS/RA options
and see where that takes us.

Thanks - Fred

> --
> Mikael Abrahamsson    email: [email-masked]

---

From: Ole Troan <[email-masked]>
Date: Fri, 2 Feb 2018 09:05:28 +0100

> and see where that takes us.

If you were going to design a new configuration protocol in 2018, is that really where you would start?

Ole

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 2 Feb 2018 15:47:32 +0000

> From: Ole Troan [mailto:[email-masked]]
> Sent: Friday, February 02, 2018 12:05 AM
> Cc: Mikael Abrahamsson <[email-masked]>; 6man WG <[email-masked]>
> Subject: Re: DHCPv6 PD and IPv6 ND unification ((RE: L=0 [was draft-pioxfolks-6man-pio-exclusive-bit-02.txt])
> 
> >

Because why not start with a mature standard that is already known to work and
is widely deployed? And, can be harmonized with the also mature IPv6 ND standard
to create a single unified service?

Fred

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 5 Feb 2018 21:11:26 +0100

> If you were going to design a new configuration protocol in 2018, is that really where you would start?

Err, yes.

Like the new transport protocol QUIC is transported in the old transport 
protocol UDP, or so I am told.

Alex

> 
> Ole
> 
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Ole Troan <[email-masked]>
Date: Wed, 7 Feb 2018 15:23:15 +0100

> Like the new transport protocol QUIC is transported in the old transport protocol UDP, or so I am told.

And just like QUIC this would be a new protocol.

Ole

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 7 Feb 2018 15:42:18 +0000

Hi Ole,

> From: ipv6 [mailto:[email-masked]] On Behalf Of Ole Troan
> Sent: Wednesday, February 07, 2018 6:23 AM
> To: Alexandre Petrescu <[email-masked]>

I think a better analogy might be the long-term bedrock standards looked
at from today's perspective. For example, IPv6 is over 20yrs old and if we
were to redesign it today there would doubtless be any number of things
we would do differently. Same with BGP, OSPF, DNS, etc.

The only critique I have heard about DHCPv6 concerns its aesthetics. There
is nothing broken that I am aware of that needs fixed. The standard has
been out for a long time and the (bis) is in late stages of publication. If we
think there is something wrong, we need to speak up now. But, throwing
it out and doing a redesign just because some people don't like the way
it looks just seems wrong. Beauty is in the eye of the beholder.

Fred