Subject: computable function - RFC 7217 'Stable and Opaque IIDs' with SLAAC

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 20 Sep 2018 11:34:38 +0200

Reading through RFC 7217 'Stable and Opaque IIDs' with SLAAC

It says:

>    A pseudorandom function (PRF) that MUST NOT be computable from
>            the outside (without knowledge of the secret key).

A 'computable' function is a function that can be computed by a 
computer, otherwise it's worthless.

E.g. f(x)=ax+b is computable, but f(x)=predict_weather_100%certain is 
not computable.

I am not sure what the text was meant to say.

I guess some explanation is in the 'from the outside'.

This may mean the function must be secret?  We dont want the function to 
be secret in an open document like RFC.

May mean - from the result back to algorithm?

This involves some mathematics notions that are clear enough elsewhere.

It deserves Errata.

Alex

---

From: Christian Huitema <[email-masked]>
Date: Thu, 20 Sep 2018 08:08:38 -0400

> On Sep 20, 2018, at 5:34 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> A 'computable' function is a function that can be computed by a computer, otherwise it's worthless.
> 
> E.g. f(x)=ax+b is computable, but f(x)=predict_weather_100%certain is not computable.
> 
> This may mean the function must be secret?  We dont want the function to be secret in an open document like RFC.
> 
The text is not ambiguous. It starts by "pseudo random function", and then specifies that the output shall depend on a locally held secret, so outside parties cannot predict the outcome, and also cannot invert the function and retrieve its arguments.

Yes it is a long winded manner to describe a cryptographic one way function. But it is not worth an errata.

-- Christian Huitema

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 20 Sep 2018 14:49:50 +0200

Le 20/09/2018 à 14:08, Christian Huitema a écrit :
> 
> On Sep 20, 2018, at 5:34 AM, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> This may mean the function must be secret?  We dont want the function 
>> to be secret in an open document like RFC.
>>
> The text is not ambiguous. It starts by "pseudo random function", and 
> then specifies that the output shall depend on a locally held secret, so 
> outside parties cannot predict the outcome, and also cannot invert the 
> function and retrieve its arguments.
> 

Have you read 'PRF MUST NOT be computable from the outside'?

Alex

> 
> -- Christian Huitema
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>