Subject: I-D Action: draft-ietf-6man-segment-routing-header-15.txt

From: [email-masked]
Date: Mon, 22 Oct 2018 13:13:46 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Maintenance WG of the IETF.

        Title           : IPv6 Segment Routing Header (SRH)
        Authors         : Clarence Filsfils
                          Stefano Previdi
                          John Leddy
                          Satoru Matsushima
                          Daniel Voyer
	Filename        : draft-ietf-6man-segment-routing-header-15.txt
	Pages           : 28
	Date            : 2018-10-22

Abstract:
   Segment Routing can be applied to the IPv6 data plane using a new
   type of Routing Extension Header.  This document describes the
   Segment Routing Extension Header and how it is used by Segment
   Routing capable nodes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6man-segment-routing-header/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-15
https://datatracker.ietf.org/doc/html/draft-ietf-6man-segment-routing-header-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-segment-routing-header-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 22 Oct 2018 20:37:54 +0000

Hello 6man working group.  We’ve just uploaded revision 15 of the SRH draft.

The HMAC and security section of the SRH draft were the focus to resolve the open issues in those areas.  Major changes are as follows:

  *   Moved HMAC text to the TLV where it’s defined.
     *   Added Destination Address and Segments Left (Issue number 68)
  *   Added a request for new error code from IANA
     *   END SID processing specified an ICMP error but no code was mentioned (4.3.1.2)
  *   Moved Deployment Model above Security Section to introduce it first
     *   Added examples for nodes within a SR Domain
        *   Added Infrastructure ACLs and definition (issue number 25/26)
     *   Added example of nodes outside a SR Domain
  *   Rewrote the security section
     *   Based on SRH, HMAC, IACL and deployment models previously defined

Darren.

On Oct 22, 2018, at 4:13 PM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Tom Herbert <[email-masked]>
Date: Mon, 22 Oct 2018 13:54:33 -0700

> Hello 6man working group.  We’ve just uploaded revision 15 of the SRH draft.
Darren,

Is there a plan to address the concerns raised about the use of TLVs
in the routing header?

Tom

> The HMAC and security section of the SRH draft were the focus to resolve the
> open issues in those areas.  Major changes are as follows:
>
> Moved HMAC text to the TLV where it’s defined.
>
> Added Destination Address and Segments Left (Issue number 68)
>
> Added a request for new error code from IANA
>
> END SID processing specified an ICMP error but no code was mentioned
> (4.3.1.2)
>
> Moved Deployment Model above Security Section to introduce it first
>
> Added examples for nodes within a SR Domain
>
> Added Infrastructure ACLs and definition (issue number 25/26)
>
> Added example of nodes outside a SR Domain
>
> Rewrote the security section
>
> Based on SRH, HMAC, IACL and deployment models previously defined
>
>
> Darren.
>
> On Oct 22, 2018, at 4:13 PM, [email-masked] wrote:
>
>

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 22 Oct 2018 21:01:59 +0000

Yes Tom, TLV is the next highest priority and we’re working on completing that.

Darren

On Oct 22, 2018, at 4:54 PM, Tom Herbert <[email-masked]<mailto:[email-masked]>> wrote:

On Mon, Oct 22, 2018 at 1:37 PM, Darren Dukes (ddukes) <[email-masked]<mailto:[email-masked]>> wrote:
Hello 6man working group.  We’ve just uploaded revision 15 of the SRH draft.

Darren,

Tom

Darren.

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IPv6 Maintenance WG of the IETF.

Abstract:

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------