Subject: Re: I-D Action: draft-troan-6man-universal-ra-option-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Dec 2018 14:39:54 +1300

>   The IANA is requested to add the universal option to the "IPv6
>   Neighbor Discovery Option Formats" registry with the value of 42.

For some reason that makes me want to ask a question.

I think some security considerations are warranted. Certainly this
open-ended option seems to raise very open-ended security concerns.
Just like this does:

{ "ietf": { "noIPv4": { "state": true } } }

Does anything stop people adding unregistered proprietary or local-use
options under a key other than "ietf"? 

Regards
   Brian

---

From: Ole Troan <[email-masked]>
Date: Wed, 19 Dec 2018 14:23:39 +0100

Hi Brian,

> options under a key other than "ietf”? 

No. Although we could choose not to require all keys to be registered in the IANA registry, and not allow willy-nilly private / other organisation keys.

Your question is right at the heart of an interesting issue. How much control are we as the IETF willing to give up?
One one hand we can claim that we add value by providing security considerations, perhaps mainly by refusing to standardize things which are fundamentally flawed, on the other hand ND is fundamentally insecure. If you are willing to trust a device on the network that claims to be a default router…

Of course we should have security considerations. But can they be any more than “don’t trust anything you are told in an RA”?
Per-option security considerations might have a higher granularity, but I’m not sure if I can think of many new attack vectors. An RA can be used to intercept all traffic from a host. The DNS option can be used for the same… But interesting question. ;-)

Cheers,
Ole