Subject: draft-ali-6man-spring-srv6-oam

From: Ron Bonica <[email-masked]>
Date: Tue, 27 Aug 2019 15:51:09 +0000

Zafar,

In draft-ali-6man-spring-srv6-oam, it appears that the SRH O-flag is processed even when Segments Left is equal to zero.

Do you see that as being in conflict with the Section 4.3.1.1 of draft-ietf-6man-segment-routing-header, lines S02 through S04?

                                                                                                                       Ron

Juniper Business Use Only

---

From: li zhenqiang <[email-masked]>
Date: Wed, 28 Aug 2019 00:52:59 +0000

Agree. I also commented this point in the list.

2. Section 4.1.2.2, the last bullet.
Since Flags.O=1 is used in this case, N4 should execute the local SID B:4:C52 after the execution of the pseudo-code specified in section 3.1.1. What is the proper behavior of N4 here?  Generate an ICMP parameter problem message to the Source with Error code "SR Upper-layer Header Error" according to section 4.3.1.2 of draft-ietf-6man-segment-routing-header-22?

4. Section 4.2.2.2, the last bullet.
Since Flags.O=1 is used in this case, N4 should execute the local SID B:4:C52 after the execution of the pseudo-code specified in section 3.1.1. What is the proper behavior of N4 here?  Generate an ICMP parameter problem message to the Source with Error code "SR Upper-layer Header Error" according to section 4.3.1.2 of draft-ietf-6man-segment-routing-header-22?

Zhenqiang Li
________________________________
[email-masked]

From: Ron Bonica<mailto:rbonica=[email-masked]>
Date: 2019-08-27 23:51
To: SPRING WG<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: draft-ali-6man-spring-srv6-oam
Zafar,

                                                                                                                       Ron