Subject: Fwd: IP Traffic Engineering

From: Gyan Mishra <[email-masked]>
Date: Thu, 26 Sep 2019 20:06:57 -0400

6man

I just saw this submitted by Robert Raszuk.

Looks interesting and maybe an alternative to counter the issues we are running into with SRv6 with the Spring WG with eh insertion and encapsulation violation of RFC8200. 

Maybe this will help in that regards.

Gyan

Sent from my iPhone

Begin forwarded message:

> From: Robert Raszuk <[email-masked]>
> Date: September 26, 2019 at 7:06:44 PM EDT
> To: RTGWG <[email-masked]>
> Subject: IP Traffic Engineering
> 
> Dear RTGWG,
> 
> I just submitted a document where I present new perspective on traffic engineering for IP networks. As the scope of the new architecture and deployment target does not fit any other working group I decided to submit it to RTGWG. 
> 
> Comments, opinions, contribution - very welcome !
> 
> Kind regards,
> Robert. 
> 
> - - - 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : IP Traffic Engineering Architecture with Network Programming
>         Author          : Robert Raszuk
>         Filename        : draft-raszuk-rtgwg-ip-te-np-00.txt
>         Pages           : 22
>         Date            : 2019-09-26
> 
> Abstract:
>    This document describes a control plane based IP Traffic Engineering
>    Architecture where path information is kept in the control plane by
>    selected nodes instead of being inserted into each packet on ingress
>    of an administrative domain.  The described proposal is also fully
>    compatible with the concept of network programming.
> 
>    It is positioned as a complimentary technique to native SRv6 and can
>    be used when there are concerns with increased packet size due to
>    depth of SID stack, possible concerns regarding exceeding MTU or more
>    strict simplicity requirements typically seen in number of enterprise
>    networks.  The proposed solution is applicable to both IPv4 or IPv6
>    based networks.
> 
>    As an additional added value, detection of end to end path liveness
>    as well as dynamic path selection based on real time path quality is
>    integrated from day one in the design.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-raszuk-rtgwg-ip-te-np/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-raszuk-rtgwg-ip-te-np-00
> https://datatracker.ietf.org/doc/html/draft-raszuk-rtgwg-ip-te-np-00
> 
> 
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 27 Sep 2019 12:28:33 +0200

Hey Gyan,

Thank you for extended the reach :) I was planning to share it with 6man
distinguished IPv6 experts but a bit later when it would pass some routing
and TE people reviews. But oh well you were faster !

With that if anyone has time and willingness to take a look at the below
proposal especially in the light of IPv6 protocol I would highly appreciate
it.

Especially finding anything there which could require *any* changes to IPv6
would be really good to know now.  Maybe some architecture adjustments
could be easily made at this very early stage if either recommended or
necessary.

Kind regards,
Robert.

On Fri, Sep 27, 2019 at 2:07 AM Gyan Mishra <[email-masked]> wrote:

> Looks interesting and maybe an alternative to counter the issues we are
> running into with SRv6 with the Spring WG with eh insertion and
> encapsulation violation of RFC8200.
>
> *From:* Robert Raszuk <[email-masked]>
> *Date:* September 26, 2019 at 7:06:44 PM EDT
> *To:* RTGWG <[email-masked]>
> *Subject:* *IP Traffic Engineering*
>
> Dear RTGWG,
>
> I just submitted a document where I present new perspective on traffic
> engineering for IP networks. As the scope of the new architecture and
> deployment target does not fit any other working group I decided to submit
> it to RTGWG.
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>