Subject: draft-dong-6man-enhanced-vpn-vtn-id-01

From: Ron Bonica <[email-masked]>
Date: Tue, 28 Jul 2020 17:44:45 +0000

Co-authors,

In Section 4.2, you say:

"There can be different implementations of reserving local network
   resources to the VTNs.  On each interface, the resources allocated to
   a particular VTN can be seen as a virtual sub-interface with
   dedicated bandwidth and other associated resources.  In packet
   forwarding, the IPv6 destination address of the received packet is
   used to identify the next-hop and the outgoing interface, and the VTN
   ID is used to further identify the virtual sub-interface which is
   associated with the VTN on the outgoing interface."

I interpret this as meaning:

  *   The IPv6 destination address is solely responsible for identifying the IP next hop
  *   The VTNI, along with the DSCP bits, determine how the packet is forwarded to the next-hop

So, I can think of the VTNI as "more DSCP bits".

Do I have that right?

                                                                  Ron

Juniper Business Use Only

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 29 Jul 2020 07:43:13 +0000

Hi Ron,

Thanks for your review and comment.

Your interpretation is in the right direction, while the relationship between VTN-ID and DSCP could be considered as in a hierarchical manner, and each is for different purpose. VTN-ID is used to consistently identify a virtual network with a group of network resources allocated from the network, there is no priority difference between VTNs. DSCP is used to provide class (priority) based traffic differentiation, which can be used within VTN.

Hope this helps.

Best regards,
Jie

From: ipv6 [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Wednesday, July 29, 2020 1:45 AM
To: [email-masked]
Subject: draft-dong-6man-enhanced-vpn-vtn-id-01

Co-authors,

In Section 4.2, you say:

-          The IPv6 destination address is solely responsible for identifying the IP next hop
-          The VTNI, along with the DSCP bits, determine how the packet is forwarded to the next-hop

Do I have that right?

                                                                  Ron

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 29 Jul 2020 09:39:50 -0400

It is unclear to me whether you are asserting that DSCP is 
insufficiently granular to represent the desired treatment, or whether 
youa re asking for an in-packet identifier that does not affect packet 
queueing or forwarding?

Yours,
Joel

On 7/29/2020 3:43 AM, Dongjie (Jimmy) wrote:
> Your interpretation is in the right direction, while the relationship 
> between VTN-ID and DSCP could be considered as in a hierarchical manner, 
> and each is for different purpose. VTN-ID is used to consistently 
> identify a virtual network with a group of network resources allocated 
> from the network, there is no priority difference between VTNs. DSCP is 
> used to provide class (priority) based traffic differentiation, which 
> can be used within VTN.
> 
> Hope this helps.
> 
> Best regards,
> 
> Jie
> 
> *From:*ipv6 [mailto:[email-masked]] *On Behalf Of *Ron Bonica
> *Sent:* Wednesday, July 29, 2020 1:45 AM
> *To:* [email-masked]
> *Subject:* draft-dong-6man-enhanced-vpn-vtn-id-01
> 
> Co-authors,
> 
> In Section 4.2, you say:
> 
> “There can be different implementations of reserving local network
> 
>     associated with the VTN on the outgoing interface.”
> 
> -The IPv6 destination address is solely responsible for identifying the 
> IP next hop
> 
> -The VTNI, along with the DSCP bits, determine how the packet is 
> forwarded to the next-hop
> 
> So, I can think of the VTNI as “more DSCP bits”.
> 
> Do I have that right?
> 
>                                                                    Ron
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Ron Bonica <[email-masked]>
Date: Thu, 30 Jul 2020 17:11:34 +0000

Jimmy,

Please tell me if I am understanding this correctly.....

On each node, the IPv6 destination address identifies a set of virtual interfaces to the next hop. Each virtual interface:

  *   Originates on the same physical interface on the local node
  *   Terminates on the same physical interface on the next-hop node

The VTNI determines which virtual interface the packet traverses. The DSCP bits determine scheduling, queuing and drop profiles on each virtual interface.

Do I have this right?

Also, is there a bandwidth reservation associated with each virtual interface?

                                                            Ron

Juniper Business Use Only
From: Dongjie (Jimmy) <[email-masked]>
Sent: Wednesday, July 29, 2020 3:43 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: RE: draft-dong-6man-enhanced-vpn-vtn-id-01

[External Email. Be cautious of content]

Hi Ron,

Hope this helps.

Best regards,
Jie

From: ipv6 [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Wednesday, July 29, 2020 1:45 AM
To: [email-masked]<mailto:[email-masked]>
Subject: draft-dong-6man-enhanced-vpn-vtn-id-01

Co-authors,

In Section 4.2, you say:

Do I have that right?

                                                                  Ron

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 31 Jul 2020 08:47:07 +0000

Hi Joel, 

As explained in my previous mail, the role of DSCP and VTN-ID are different. VTN-ID can be used as a in packet identifier of the VTN, and it can be used in a hierarchical manner with DSCP and other fields for packet forwarding. Thus it is not to extend or replace DSCP.

Best regards,
Jie

> -----Original Message-----
> From: Joel M. Halpern [mailto:[email-masked]]
> Sent: Wednesday, July 29, 2020 9:40 PM
> To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
> Subject: Re: draft-dong-6man-enhanced-vpn-vtn-id-01
> 
> It is unclear to me whether you are asserting that DSCP is insufficiently
> granular to represent the desired treatment, or whether youa re asking for
> an in-packet identifier that does not affect packet queueing or forwarding?
> 
> Yours,
> Joel
> 
> > between VTN-ID and DSCP could be considered as in a hierarchical
> > manner, and each is for different purpose. VTN-ID is used to
> > consistently identify a virtual network with a group of network
> > resources allocated from the network, there is no priority difference
> > between VTNs. DSCP is used to provide class (priority) based traffic
> > differentiation, which can be used within VTN.
> >
> > Hope this helps.
> >
> > Best regards,
> >
> > Jie
> >
> > -The IPv6 destination address is solely responsible for identifying
> > the IP next hop
> >

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 31 Jul 2020 09:00:12 +0000

Hi Ron,

What you described (identify a virtual interface which can have bandwidth reserved) is one usage of VTN-ID. As it provides an identifier of a virtual network in packet, it may also be associated with other attributes and behaviors of the virtual network.

Best regards,
Jie

From: Ron Bonica [mailto:[email-masked]]
Sent: Friday, July 31, 2020 1:12 AM
To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
Subject: RE: draft-dong-6man-enhanced-vpn-vtn-id-01

Jimmy,

-          Originates on the same physical interface on the local node
-          Terminates on the same physical interface on the next-hop node

Do I have this right?

                                                            Ron

Juniper Business Use Only
From: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, July 29, 2020 3:43 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-dong-6man-enhanced-vpn-vtn-id-01

Hi Ron,

Hope this helps.

Best regards,
Jie

Co-authors,

In Section 4.2, you say:

Do I have that right?

                                                                  Ron

---

From: Joel Halpern Direct <[email-masked]>
Date: Fri, 31 Jul 2020 07:07:54 -0400

Looking at the draft, and reading your note, you seem to be asking for a 
hop-by-hop option header which is to be modify the forwarding selection 
in some unspecified fashion.

This kind of open-ended modification of core 6man IPv6 behavior seems a 
bad idea.
Having a modification to the forwarding behavior that may not be noticed 
or acted on by all routers in the path seems a recipe for forwarding loops.

And it is not at all clear that there is any need for this given MPLS, 
SRH, CRH.

Yours,
Joel

---

From: Ron Bonica <[email-masked]>
Date: Fri, 31 Jul 2020 14:49:22 +0000

Hi Jimmie,

My main concern is routing loops. If the destination address determines the next hop and the VTNI determines forwarding behavior on the interface to the next-hop, routing loops are not a problem.

However, if the VTNI has a part in determining the next hop,  routing loops become an concern.

                                                     Ron

Sent: Friday, July 31, 2020 5:00 AM

Hi Ron,

Best regards,
Jie

From: Ron Bonica [mailto:[email-masked]]
Sent: Friday, July 31, 2020 1:12 AM
To: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-dong-6man-enhanced-vpn-vtn-id-01

Jimmy,

Do I have this right?

                                                            Ron

Hi Ron,

Hope this helps.

Best regards,
Jie

Co-authors,

In Section 4.2, you say:

Do I have that right?

                                                                  Ron

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 31 Jul 2020 15:08:39 +0000

Hi Ron,

Thanks for your comment.

We understand that the routing needs to be consistent in the network, thus as described in the current draft, the destination IP is used to determine the next hop, VTN-ID is for forwarding behaviors associated with this next hop.

Hope this helps.

Best regards,
Jie

From: Ron Bonica [mailto:[email-masked]]
Sent: Friday, July 31, 2020 10:49 PM
To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
Subject: RE: draft-dong-6man-enhanced-vpn-vtn-id-01

Hi Jimmie,

                                                     Ron

Hi Ron,

Best regards,
Jie

Jimmy,

Do I have this right?

                                                            Ron

Hi Ron,

Hope this helps.

Best regards,
Jie

Co-authors,

In Section 4.2, you say:

Do I have that right?

                                                                  Ron

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 31 Jul 2020 16:32:01 +0000

Hi Joel, 

Thanks for your comment, I missed this before the meeting. 

We understand forwarding loops must be avoided. As mentioned in the draft and my presentation, the next hop is determined using the destination IP field, and the VTN-ID is used to determine the set of network resources associated with the VTN for packet processing and forwarding to the determined next hop. 

Hope this helps. 

Best regards,
Jie

> From: Joel Halpern Direct [mailto:[email-masked]]
> Sent: Friday, July 31, 2020 7:08 PM
> hop-by-hop option header which is to be modify the forwarding selection in
> some unspecified fashion.
> 
> This kind of open-ended modification of core 6man IPv6 behavior seems a bad
> idea.
> Having a modification to the forwarding behavior that may not be noticed or
> acted on by all routers in the path seems a recipe for forwarding loops.
> 
> And it is not at all clear that there is any need for this given MPLS, SRH, CRH.
> 
> Yours,
> Joel
> 
> > As explained in my previous mail, the role of DSCP and VTN-ID are different.
> VTN-ID can be used as a in packet identifier of the VTN, and it can be used in a
> hierarchical manner with DSCP and other fields for packet forwarding. Thus it
> is not to extend or replace DSCP.
> >
> > Best regards,
> > Jie
> >
> >> insufficiently granular to represent the desired treatment, or
> >> whether youa re asking for an in-packet identifier that does not affect
> packet queueing or forwarding?
> >>
> >> Yours,
> >> Joel
> >>
> >>> Your interpretation is in the right direction, while the
> >>> relationship between VTN-ID and DSCP could be considered as in a
> >>> hierarchical manner, and each is for different purpose. VTN-ID is
> >>> used to consistently identify a virtual network with a group of
> >>> network resources allocated from the network, there is no priority
> >>> difference between VTNs. DSCP is used to provide class (priority)
> >>> based traffic differentiation, which can be used within VTN.
> >>>
> >>> Hope this helps.
> >>>
> >>> Best regards,
> >>>
> >>> Jie
> >>>
> >>> IETF IPv6 working group mailing list [email-masked] Administrative
> >>> Requests: https://www.ietf.org/mailman/listinfo/ipv6

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 31 Jul 2020 12:44:01 -0400

If you coupled this with SR, you would get most of what you want.
And for those cases where you needed more, you could use a destination 
option.

Otherwise, you are going to have some other hard to guess dependencies 
to make this work meaningfully.

Yours,
Joel