Subject: draft-li-6man-6hosts-detection-00

From: 李江 <[email-masked]>
Date: Fri, 17 Jul 2020 16:58:47 +0800 (CST)

Hi all,

  We uploaded draft-li-6man-6hosts-detection-00, see https://datatracker.ietf.org/doc/draft-li-6man-6hosts-detection/.

  This document proposes a solution for IPv6 hosts detection and management by:

set a collection point

announce the address of collection point by using Router Advertisement

each host in the network who know the address of collection point report its own IPv6 information to collection point

  Your review comments on this document are important and appreciated. Thank you in advance.

Best regards,

Li Jiang

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 17 Jul 2020 13:28:28 -0400

I am mildly confused by one aspect of this document.  It may be that I 
simply missed it in my reading.

The problem space seems to be that of determining what devices are on a 
network.  The usual cases I know of for wanting to do this are to detect 
unintended or hostile devices.
Is that the goal of this work?
If so, it seems that hostile devices could simply choose not to report 
themselves?

Yours,
Joel

On 7/17/2020 4:58 AM, 李江 wrote:
> Hi all,
> 
>    We uploaded draft-li-6man-6hosts-detection-00, see 
> https://datatracker.ietf.org/doc/draft-li-6man-6hosts-detection/..
> 
>  1.
>  2.
>  3.
>     each host in the network who know the address of collection point
>     report its own IPv6 information to collection point
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Erik Kline <[email-masked]>
Date: Fri, 17 Jul 2020 10:43:59 -0700

<no hats>

I think the better approach is for all routers and switches to report
their view of neighbor state to a logger.  RFC 7951 and 8344 have the
YANG modules necessary to do that.

I'll defer to Jen, but Google implemented the equivalent of this
network infrastructure reporting back around 2012 (?), in part because
it was better for tracking SLAAC behaviour.

---

From: Bob Hinden <[email-masked]>
Date: Fri, 17 Jul 2020 14:48:50 -0700

> On Jul 17, 2020, at 10:43 AM, Erik Kline <[email-masked]> wrote:
> 
> <no hats>
> 

I agree, it’s have the routers and switches to report on what they know about nodes on the link.

Also there are mechanisms defined in RFC 4620 "IPv6 Node Information Queries” that can be used to query to all nodes on a link.

I think both of these approaches are preferable than what is proposed in this document.

Bob

---

From: 李江 <[email-masked]>
Date: Mon, 20 Jul 2020 15:35:04 +0800 (CST)

Hi Joel,

 Suppose that in a well managed network, all alive hosts can be listed very clearly. In fact, network administrators are responsible for a large number of hosts, the list may not updated so well. 

  The goal of this work is to do double-check or audit of IPv6 hosts. Also get alive hosts list without information collection from network administrators. It do detect unintended devices, based on the premise that no intended devices are defined.

Best Regards,

Li Jiang

 ----邮件原文----发件人："Joel M. Halpern" <[email-masked]>收件人："李江" <[email-masked]>,ipv6  <[email-masked]>抄　送: (无)发送时间：2020-07-18 01:28:28主题：Re: draft-li-6man-6hosts-detection-00I am mildly confused by one aspect of this document. It may be that I simply missed it in my reading.The problem space seems to be that of determining what devices are on a network. The usual cases I know of for wanting to do this are to detect unintended or hostile devices.Is that the goal of this work?If so, it seems that hostile devices could simply choose not to report themselves?Yours,JoelOn 7/17/2020 4:58 AM, 李江 wrote:> Hi all,> >   We uploaded draft-li-6man-6hosts-detection-00, see > https://datatracker.ietf.org/doc/draft-li-6man-6hosts-detection/..> >   This document proposes a solution for IPv6 hosts detection and > management by:> > 1.> > set a collection point> > 2.> > announce the address of collection point by using Router Advertisement> > 3.> > each host in the network who know the address of collection point> report its own IPv6 information to collection point> >   Your review comments on this document are important and appreciated. > Thank you in advance.> > > Best regards,> > Li Jiang> > > > --------------------------------------------------------------------> IETF IPv6 working group mailing list> [email-masked]> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6> --------------------------------------------------------------------> Subject：Re: draft-li-6man-6hosts-detection-00I am mildly confused by one aspect of this document. It may be that I simply missed it in my reading.The problem space seems to be that of determining what devices are on a network. The usual cases I know of for wanting to do this are to detect unintended or hostile devices.Is that the goal of this work?If so, it seems that hostile devices could simply choose not to report themselves?Yours,JoelOn 7/17/2020 4:58 AM, 李江 wrote:> Hi all,> >   We uploaded draft-li-6man-6hosts-detection-00, see > https://datatracker.ietf.org/doc/draft-li-6man-6hosts-detection/..> >   This document proposes a solution for IPv6 hosts detection and > management by:> > 1.> > set a collection point> > 2.> > announce the address of collection point by using Router Advertisement> > 3.> > each host in the network who know the address of collection point> report its own IPv6 information to collection point> >   Your review comments on this document are important and appreciated. > Thank you in advance.> > > Best regards,> > Li Jiang> > > > --------------------------------------------------------------------> IETF IPv6 working group mailing list> [email-masked]> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6> -------------------------------------------------------------------->

---

From: 李江 <[email-masked]>
Date: Mon, 20 Jul 2020 18:56:22 +0800 (CST)

Thank you for your review and comments. YANG module can solve the problem of reporting data, protocols like NETCONF can do configuration to designated and known IPv6 hosts. But I think these mechanisms are not enough to solve the problem in an unknown network. Sometimes, actually most times, we don39t know which IPv6 addresses are being used. 

  So maybe the first thing is to get an accurate list of IPv6 addresses. Before this, an IPv6 address which do collection work should be flooded to network nodes including routers switches and hosts. And I think one way is to extend network protocol(the document chooseses Router Advertisement) to do information notification.

 ----邮件原文----发件人：Bob Hinden  <[email-masked]>收件人：Erik Kline  <[email-masked]>抄　送: IPv6 List  <[email-masked]>,Bob Hinden  <[email-masked]>发送时间：2020-07-18 05:48:50主题：Re: draft-li-6man-6hosts-detection-00> On Jul 17, 2020, at 10:43 AM, Erik Kline  wrote:> > > > I think the better approach is for all routers and switches to report> their view of neighbor state to a logger.  RFC 7951 and 8344 have the> YANG modules necessary to do that.> > I39ll defer to Jen, but Google implemented the equivalent of this> network infrastructure reporting back around 2012 (?), in part because> it was better for tracking SLAAC behaviour.I agree, it’s have the routers and switches to report on what they know about nodes on the link.Also there are mechanisms defined in RFC 4620 "IPv6 Node Information Queries” that can be used to query to all nodes on a link.I think both of these approaches are preferable than what is proposed in this document.Bob> > On Fri, Jul 17, 2020 at 10:28 AM Joel M. Halpern  wrote:>> >> I am mildly confused by one aspect of this document.  It may be that I>> simply missed it in my reading.>> >> The problem space seems to be that of determining what devices are on a>> network.  The usual cases I know of for wanting to do this are to detect>> unintended or hostile devices.>> Is that the goal of this work?>> If so, it seems that hostile devices could simply choose not to report>> themselves?>> >> Yours,>> Joel>> >> On 7/17/2020 4:58 AM, 李江 wrote:>>> Hi all,>>> >>>   We uploaded draft-li-6man-6hosts-detection-00, see>>> https://datatracker.ietf.org/doc/draft-li-6man-6hosts-detection/..>>> >>>   This document proposes a solution for IPv6 hosts detection and>>> management by:>>> >>> 1.>>> >>>    set a collection point>>> >>> 2.>>> >>>    announce the address of collection point by using Router Advertisement>>> >>> 3.>>> >>>    each host in the network who know the address of collection point>>>    report its own IPv6 information to collection point>>> >>>   Your review comments on this document are important and appreciated.>>> Thank you in advance.>>> >>> >>> Best regards,>>> >>> Li Jiang>>> >>> >>> >>> -------------------------------------------------------------------->>> IETF IPv6 working group mailing list>>> [email-masked]>>> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6>>> -------------------------------------------------------------------->>> >> >> -------------------------------------------------------------------->> IETF IPv6 working group mailing list>> [email-masked]>> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6>> --------------------------------------------------------------------> > --------------------------------------------------------------------> IETF IPv6 working group mailing list> [email-masked]> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6> ----------------------------------------------------------------------------------------------------------------------------------------IETF IPv6 working group mailing [email-masked] Requests: https://www.ietf.org/mailman/listinfo/ipv6--------------------------------------------------------------------

---

From: 李江 <[email-masked]>
Date: Fri, 31 Jul 2020 22:13:00 +0800 (CST)

Hello everyone,

  For draft-li-6man-6hosts-detection-00, should I consider it from neighbor cache, a comment seems to suggest it. 

  Since IPv6 online hosts detection is tough for me, if you have any comments or suggestions, please let me know, thank you so much.

Best Regards,

Li Jiang

---

From: Ted Lemon <[email-masked]>
Date: Fri, 31 Jul 2020 10:25:59 -0400

>   For draft-li-6man-6hosts-detection-00, should I consider it from neighbor cache, a comment seems to suggest it. 
The big problem I have with this document is that I have no idea why you want to do this, and it seems like it’s a privacy violation.