Subject: draft-ietf-6man-ipv6-alt-mark-01

From: Ron Bonica <[email-masked]>
Date: Tue, 21 Jul 2020 20:51:18 +0000

Authors,

This draft is well-written and helpful. However, I have two small comments.

Section 4:
========
You say that the Altmark Option can be encoded in:

  *   An HBH Options header
  *   A Destination Options header that precedes the SRv6 SRH
  *   A Destination Options header that precedes the upper-layer header

You could have made a more general statement. The Altmark Option can be encoded in:

  *   An HBH Options header
  *   A Destination Options header that precedes *any Routing header*
  *   A Destination Options header that precedes the upper-layer header

Section 5:
========
This is more a question than a comment. But won't packet reordering interfere with packet loss measurement. I am thinking about the case when two packet with different L-values get swapped.

                                                                                        Ron

Juniper Business Use Only

---

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 22 Jul 2020 08:50:22 +0000

Dear Ron,
Thanks a lot for the feedback.

Regarding Section 4, it is our oversight. In the next version I will generalize it and state that it applies to any Routing Header and not only SRv6.

Regarding Section 5, packets with different L-values may get swapped at batch boundaries, and in this case, it is required that each marked packet can be assigned to the right batch by each router. There is a condition (explained in RFC8321) that must be satisfied and it takes into considerations the different aspects causing reordering such as clock error, network delay.
In a few words the length of the marking period must be large enough so that the counters can be taken in the middle of the marking period to be sure to take still counters.
I will add a new paragraph on this in the next version.

Regards,

Giuseppe

From: ipv6 [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Tuesday, July 21, 2020 10:51 PM
To: [email-masked]
Subject: draft-ietf-6man-ipv6-alt-mark-01

Authors,

Section 4:
========

-          An HBH Options header
-          A Destination Options header that precedes the SRv6 SRH
-          A Destination Options header that precedes the upper-layer header

-          An HBH Options header
-          A Destination Options header that precedes *any Routing header*
-          A Destination Options header that precedes the upper-layer header

Section 5:
========

                                                                                        Ron

---

From: Ron Bonica <[email-masked]>
Date: Wed, 22 Jul 2020 13:33:39 +0000

Giuseppe,

Perfect!

              Thanks,
                Ron

Juniper Business Use Only
From: Giuseppe Fioccola <[email-masked]>
Sent: Wednesday, July 22, 2020 4:50 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: RE: draft-ietf-6man-ipv6-alt-mark-01

[External Email. Be cautious of content]

Dear Ron,

Regarding Section 5, packets with different L-values may get swapped at batch boundaries, and in this case, it is required that each marked packet can be assigned to the right batch by each router. There is a condition (explained in RFC8321) that must be satisfied and it takes into considerations the different aspects causing reordering such as clock error, network delay.
In a few words the length of the marking period must be large enough so that the counters can be taken in the middle of the marking period to be sure to take still counters..
I will add a new paragraph on this in the next version.

Regards,

Giuseppe

From: ipv6 [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Tuesday, July 21, 2020 10:51 PM
To: [email-masked]<mailto:[email-masked]>
Subject: draft-ietf-6man-ipv6-alt-mark-01

Authors,

Section 4:
========

  *   An HBH Options header

  *   An HBH Options header

Section 5:
========

                                                                                        Ron