Subject: RE: Improving ND security

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 31 Jul 2020 17:35:31 +0000

On Jul 31, 2020, at 1:17 PM, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Ted, I think SEND would solve the neighbor cache resource exhaustion attack since a NCE is
only created on receipt of an authentic (SEND-protected) IPv6 ND message.

OK, but an attacker can just generate a bazillion key pairs, right? So it can still exhaust the cache, at the cost of some computation work.
[>]

I think as long as the network has a way of associating the key pair with another piece
of information that accompanies the IPv6 ND message then the network would be able
to know when the mobile node is using its (single) authorized key. So, for example, if
the IPv6 ND message included an identity for the MN (sort of like a DHCPv6 DUID), the
network would know when the MN is using the correct key pair – right? (BTW, I am
not saying to use DHCPv6 DUID – that is just one example of a MN identity…)

Thanks - Fred

---

From: Ted Lemon <[email-masked]>
Date: Fri, 31 Jul 2020 13:40:42 -0400

> not saying to use DHCPv6 DUID – that is just one example of a MN identity…)

By “NM” I think you mean “Mobile Node?” That’s not really one of the use cases we’re talking about here. Or am I missing something?

In any case, you’re presuming some kind of trust establishment for non-router nodes, right? SEND only talks about trust establishment for routers. And, let’s be frank, doesn’t actually give us enough operational guidance that we would expect what _is_ said to be generally practicable.

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 31 Jul 2020 17:49:21 +0000

Hi Ted,

By “NM” I think you mean “Mobile Node?” That’s not really one of the use cases we’re talking about here. Or am I missing something?
[>]
Or, just call it a (mobile) “Stub-Network” – I think we are talking about the same
thing here.

In any case, you’re presuming some kind of trust establishment for non-router nodes, right? SEND only talks about trust establishment for routers. And, let’s be frank, doesn’t actually give us enough operational guidance that we would expect what _is_ said to be generally practicable.
[>]
OK, the specs I have been working dip their toes into the SEND pool but maybe they
should be updated to dive in completely? With an adoption call in progress, I don’t
know if it would be a good idea to make changes right now but be assured that it
will be added to the TODO list – would that be acceptable for now?

Thanks - Fred

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 31 Jul 2020 21:47:13 +0000

Hello Fred

A major attack vector is an external attacker sending packets to the 2^64 or so possible addresses in the subnet. The attack causes a denial of service at the router that MUST store one packet for one second and multicast a NS lookup, which multiplies the effect. The attack is easy to perform from the outside and send offers no protection. The only clear protection is to know in advance all the addresses present in the network and drop the rest. GRAND offers a way to preset the ND cache which is better than nothing but it offers no guarantee that the router has the full set of addresses I. Cache. In fact the concept of a cache is dated from the days memory was scarce and expensive. This concept is not needed And rather harmful in modern networks.

Regards,

Pascal

Le 31 juil. 2020 à 19:49, Templin (US), Fred L <[email-masked]> a écrit :

Hi Ted,

Thanks - Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 31 Jul 2020 22:13:05 +0000

Hi Pascal, see below:

A major attack vector is an external attacker sending packets to the 2^64 or so possible addresses in the subnet.
[>] Subnet?? As in, an on-link IPv6 prefix? The large NBMA link that I want to use SEND
on will not have any of those – link-local only.

The attack causes a denial of service at the router that MUST store one packet for one second and multicast a NS lookup, which multiplies the effect.
[>] Again, we are talking about different kinds of links; there will not be any sort of
multicast explosion on the NBMA link based on a router receiving a SEND-protected
IPv6 ND message.

The attack is easy to perform from the outside and send offers no protection.
[>] For the OMNI NBMA link, the process is based on a Client sending a SEND-protected
RS message to exactly one router. The router authenticates the RS before processing it
further, which may include returning a unicasted RA. No NCEs are created until the RS
has been authenticated, and no multicast storms are initiated.

The only clear protection is to know in advance all the addresses present in the network and drop the rest. GRAND offers a way to preset the ND cache which is better than nothing but it offers no guarantee that the router has the full set of addresses I. Cache. In fact the concept of a cache is dated from the days memory was scarce and expensive. This concept is not needed And rather harmful in modern networks.
[>] The OMNI routers are not going to require any kind of ND cache presets; they
simply establish NCEs upon receipt *and* authentication of good RS messages.

Thanks - Fred

Regards,

Pascal

Le 31 juil. 2020 à 19:49, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> a écrit :

Hi Ted,

Thanks - Fred