Subject: Host support?

From: Fred Baker <[email-masked]>
Date: Tue, 9 Mar 2021 04:58:25 -0800

I'm in the IETF 110 6man meeting, and Fan Yang just said, in Q&A following her presentation, that there is no intention that ACH might be used between hosts. I'm not advocating that it should be, but the prohibition surprises me. What is the reason to restrict this to network nodes such as routers?

---

From: Ola Thoresen <[email-masked]>
Date: Tue, 9 Mar 2021 14:16:33 +0100

> I'm in the IETF 110 6man meeting, and Fan Yang just said, in Q&A following her presentation, that there is no intention that ACH might be used between hosts. I'm not advocating that it should be, b…

Why are some people still differentiating between a "host" and a "router"?

My mobile phone is a router, forwarding packets between the 4G/5G 
network and the connected "internet sharing" clients.

My laptop is a router, forwarding packets between VMs, containers, the 
host OS, internet and peripherals connected over e.g. USB.

Even some of the VMs running on the laptop are actually routers, 
forwarding packets from and to other virtual instances...

And all of these changes their role dynamically, based on what 
application is used, and whenever clients are connected or disconnected, 
VMs and containers are created and destroyed...  You can't know in 
advance if something is a "host" or a "router", and whatever it is right 
now, might not be what it is in 5 minutes.

To restrict anything to either a "host" or a "router" in this day and 
age does not make any sense.

/Ola (T)

---

From: Bob Hinden <[email-masked]>
Date: Tue, 9 Mar 2021 06:06:20 -0800

Ola,

In RFC8200 this is defined as:

2.  Terminology

   node         a device that implements IPv6.

   router       a node that forwards IPv6 packets not explicitly
                addressed to itself.  (See Note below.)

   host         any node that is not a router.  (See Note below.)

   …...

   Note: it is possible for a device with multiple interfaces to be
   configured to forward non-self-destined packets arriving from some
   set (fewer than all) of its interfaces and to discard non-self-
   destined packets arriving from its other interfaces.  Such a device
   must obey the protocol requirements for routers when receiving
   packets from, and interacting with neighbors over, the former
   (forwarding) interfaces.  It must obey the protocol requirements for
   hosts when receiving packets from, and interacting with neighbors
   over, the latter (non-forwarding) interfaces.

There is a lot of overlap, but it sometimes useful to describe the functions separately.

Bob

> On Mar 9, 2021, at 5:16 AM, Ola Thoresen <[email-masked]> wrote:
> 
> My mobile phone is a router, forwarding packets between the 4G/5G network and the connected "internet sharing" clients.
> 
> My laptop is a router, forwarding packets between VMs, containers, the host OS, internet and peripherals connected over e.g. USB.
> 
> Even some of the VMs running on the laptop are actually routers, forwarding packets from and to other virtual instances...
> 
> And all of these changes their role dynamically, based on what application is used, and whenever clients are connected or disconnected, VMs and containers are created and destroyed...  You can't know in advance if something is a "host" or a "router", and whatever it is right now, might not be what it is in 5 minutes.
> 
> To restrict anything to either a "host" or a "router" in this day and age does not make any sense.
> 
> 
> /Ola (T)
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Yangfan (IP Standard)" <[email-masked]>
Date: Wed, 10 Mar 2021 10:17:12 +0000

All, 
There is no intention to divide an IP connection into pieces, no matter the entity is a host or router (or called "network edge").
Based on the use cases we have recognized so far, they are applications taken from operator's perspective. Thus, we are focusing on the associated channel used between routers.
But you are right, ACH over IPv6 should not be limited between routers. If there is a need of control/mgmt messages transmitted on an IP path, ACH should fit. So the authors encourage people to provide more use cases, to utilize ACH thoroughly. Thanks in advance!

Cheers, 
Fan 

-----邮件原件-----
发件人: ipv6 [mailto:[email-masked]] 代表 Ola Thoresen
发送时间: 2021年3月9日 21:17
收件人: [email-masked]
主题: Re: Host support?

/Ola (T)