Subject: Questions about CRH

From: Huzhibo <[email-masked]>
Date: Thu, 11 Mar 2021 17:06:35 +0000

Hi Andrew:

Regarding the discussion in the 6man session, I have two questions, hope to have your reply.

1. The SRv6 compression design team has provided a template for comparing different compression solutions, and it will be finished at late MAY. As a network operator, will you try to compare different compression solutions based on the template before making the decision or using CRH no matter what results come out?

2. If I don't remember wrong, two years ago, you said you had implemented the POC of CRH, that is great. But I saw there have been many major changes to CRH. I would like to know whether you have considered the impact of these changes to CRH and whether it is stable so far?

Many thanks and looking forward to your reply.

Best regards,
Zhibo

---

From: Ron Bonica <[email-masked]>
Date: Mon, 15 Mar 2021 15:32:11 +0000

Zhibo,

I don't think that it is fair to say that there have been major changes to the CRH draft. The Routing header format has been unchanged since version 07 (August 2019).

A few optional fields have been added to the CRH-FIB in the last year, but otherwise, the draft has been stable for some time.

                                                                                                         Ron

Juniper Business Use Only

-----Original Message-----
From: ipv6 <[email-masked]> On Behalf Of Huzhibo
Sent: Thursday, March 11, 2021 12:07 PM
To: [email-masked] <[email-masked]>
Cc: [email-masked]
Subject: Questions about CRH

[External Email. Be cautious of content]

Hi Andrew:

Best regards,
Zhibo
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/ipv6__;!!NEt6yMaO-gk!T2Kko9epzr71mVHTrGsQRMvM0sJfD6UGiJOVT3hqBalVdFE4Gw-EDc1MF6wwQLS5$
--------------------------------------------------------------------

---

From: Huzhibo <[email-masked]>
Date: Tue, 16 Mar 2021 03:35:50 +0000

Hi Ron,

If I don't remember wrong, since last time you requested for WG Adaption, several new things have been added to CRH,
*	A topological function.
*	Arguments for the topological function (optional).
*	A service function (optional).
*	Flags.
*	Arguments for the service function (optional).
*	CRH SID mapping to SRv6 SID

https://www.ietf.org/rfcdiff?url1=draft-bonica-6man-comp-rtg-hdr-23&url2=draft-bonica-6man-comp-rtg-hdr-24

You also added a PSP flag to indicate the penultimate segment endpoint pop to the draft that you disagreed at the past.
In addition, an OAM flag indicating OAM processing.

IMHO, a set of new features are added to CRH. Though the format is unchanged, but the processing has been modified significantly.

Regards,
Zhibo

-----Original Message-----
From: Ron Bonica [mailto:[email-masked]] 
Sent: Monday, March 15, 2021 11:32 PM
To: Huzhibo <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked]
Subject: RE: Questions about CRH

Zhibo,

                                                                                                         Ron

-----Original Message-----
From: ipv6 <[email-masked]> On Behalf Of Huzhibo
Sent: Thursday, March 11, 2021 12:07 PM
To: [email-masked] <[email-masked]>
Cc: [email-masked]
Subject: Questions about CRH

Hi Andrew:

Best regards,
Zhibo

---

From: Ron Bonica <[email-masked]>
Date: Tue, 16 Mar 2021 18:38:16 +0000

Huzhibo,

The topological instruction and arguments to the topological instruction were present in version 07 (August 2019). In that version, they were called the segment type and topological instruction parameters, respectively.

The following *optional* items have been added to the CRH-FIB:

*       Flags (including PSP)

Because they are optional, they do not pose a backwards compatibility issue. It is assumed that many nodes will not support service functions, their arguments, or any of the flags.

All nodes will support CRH SID mapping to SRv6 SID since the node that does the mapping won't know if the mapped 128 bits is an RFC 4291 IPv6 address or an 8986 SID.

                                                                                               Ron

-----Original Message-----
From: Huzhibo <[email-masked]> 
Sent: Monday, March 15, 2021 11:36 PM
To: Ron Bonica <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked]
Subject: RE: Questions about CRH

Hi Ron,

https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url1=draft-bonica-6man-comp-rtg-hdr-23&url2=draft-bonica-6man-comp-rtg-hdr-24__;!!NEt6yMaO-gk!X7XIT7-l1Wjko32bviSMELIjl7SIAEmFiXLR8qZ457_8_VO2fEx-sHEtfw80lpd8$

Regards,
Zhibo

-----Original Message-----
From: Ron Bonica [mailto:[email-masked]]
Sent: Monday, March 15, 2021 11:32 PM
To: Huzhibo <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked]
Subject: RE: Questions about CRH

Zhibo,

                                                                                                         Ron

-----Original Message-----
From: ipv6 <[email-masked]> On Behalf Of Huzhibo
Sent: Thursday, March 11, 2021 12:07 PM
To: [email-masked] <[email-masked]>
Cc: [email-masked]
Subject: Questions about CRH

Hi Andrew:

Best regards,
Zhibo