Subject: questions about draft-dunbar-idr-5g-edge-compute-app-meta-data and draft-dunbar-6man-5g-edge-compute-sticky-service

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 25 Mar 2021 19:46:06 +0000

Hi Linda, John,

I have the following questions.

The two related drafts listed the following three problems respectively:

      1.3. Problem#1: ANYCAST in 5G EC Environment.............. 6
      1.4. Problem #2: Unbalanced Anycast Distribution due to UE Mobility.................................................. 7
      1.5. Problem 3: Application Server Relocation............. 7

      1.2. Problem #1: ANYCAST in 5G EC Environment.............. 4
      1.3. Problem #2: sticking to original App Server........... 5
      1.4. Problem #3: Application Server Relocation............. 5

Why is problem #2 different in the two drafts? Is it true that none of the two drafts address problem #3?
The idr draft talk about "soft anchoring" problem and solution - how is that different from the "sticky service"?

Thanks.
Jeffrey

Juniper Business Use Only

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 26 Mar 2021 01:42:58 +0000

Jeffrey, 

Very good observation! 

The "Sticky to the original server" is the main problem addressed by the draft-dunbar-6man-5g-edge-compute-sticky-service. 

The draft-dunbar-idr-5g-edge-compute-app-meta-data is about propagating the properties and the preferences about the site to address the "Unbalanced Anycast Distribution due to UE Mobility" and the "App Server Relocation". 

We are working on adding more to draft-dunbar-6man-5g-edge-compute-sticky-service to address the "App Server Relocation" issue. Your suggestions are greatly appreciated. 

Thanks, 

Linda

-----Original Message-----
From: Jeffrey (Zhaohui) Zhang <[email-masked]> 
Sent: Thursday, March 25, 2021 2:46 PM
To: Linda Dunbar <[email-masked]>; Kaippallimalil John <[email-masked]>; IPv6 List <[email-masked]>; idr@ietf. org <[email-masked]>
Subject: questions about draft-dunbar-idr-5g-edge-compute-app-meta-data and draft-dunbar-6man-5g-edge-compute-sticky-service

Hi Linda, John,

Thanks.
Jeffrey