Subject: OMNI/OAL

From: Vasilenko Eduard <[email-masked]>
Date: Fri, 26 Mar 2021 17:24:15 +0000

Hi Fred,
I will look at your drafts.
But even before I have looked – I am sure that it could not be the “general purpose tunneling solution”.
The problem is with the complexity of your scope.
As I understand, It is mandatory to have Mobility for your solution. Mobility should be a much bigger/complex problem compare to anything else in your draft.
There are many other use cases where tunneling does not need mobility (where infrastructure does not move). Then overlay/tunneling should be simpler.
Hence, at least 2 solutions are needed for overlay: with mobility and without.
In the ideal case, it is better if Mobility would be an additional functionality to the basic overlay (separate spec). I did not try to think about it – I am not sure that it is possible. Maybe only 2 separate solutions are possible because basic overlay should not become over-complicated.
Eduard
From: Templin (US), Fred L [mailto:[email-masked]]
Sent: Thursday, March 25, 2021 8:26 PM
To: Vasilenko Eduard <[email-masked]>; int-area <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: draft-ietf-intarea-tunnels concerns

Eduard, at this point I think you would need to gain a better understanding of the
OMNI/OAL proposal by reading the draft to understand what is being proposed.
You may also need to look at the AERO draft to understand how the AERO/OMNI
segment routing functions. The drafts will not be changing again unless the IETF
directs me to do so:

https://datatracker.ietf.org/doc/draft-templin-6man-aero/
https://datatracker.ietf.org/doc/draft-templin-6man-omni/

As can be seen in the drafts, only end systems or near-end systems need to fragment
or reassemble, and iperf3 shows that that can be done at the O(10Gbps) level or even
higher which is plenty good enough for leaf networks. The core only needs to forward
OAL carrier packets with sizes determined by the MPS and as such are guaranteed not
to trip over an MTU restriction, and with line rate forwarding enabled.

Please have  a look and let us know what you think.

Fred

---

Fred,
You could not considerably cut traffic by talking about core boxes.
The modern design (DC at any layers) may not have any core router for the country as big as 80M of population. I did careful calculations for many countries.
Because of Direct lambda from aggregation to the limited number of DC or peering points.
But you could say that only the downstream interface should do fragmentation/reassembly. Uplink could be cheaper.
Hence, /2 is a reasonable assumption.
It is still huge.

My personal estimation that FBB would go flat at 3Mbps, MBB at 1Mbps (5+ years) average per subs in the busy hour.
Let average household would be 2.6 persons (I know many countries, but I did never research for the world).
7.8B of MBB subscribers. 3B of FBB. Something like 17Pbps of real traffic.
/2 to see downlink only. But *4 for redundancy and reasonable port utilization.
Who would pay for the different hardware 34Ptbs?

The numbers above could be calculated more carefully. The model could be more accurate.
But No, massive fragmentation would never happen.
Eduard
From: Templin (US), Fred L [mailto:[email-masked]]
Sent: Thursday, March 25, 2021 7:34 PM
To: Vasilenko Eduard <[email-masked]<mailto:[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-ietf-intarea-tunnels concerns

Eduard, I am meaning to represent this as a general purpose solution. Performance
critical routers in the middle of the network will never be asked to reassemble – only
end systems or leaf network routers near the end systems will fragment, and only
end systems or routers near the end systems will need to reassemble.

You are right that OMNI/OAL are not meaning to invalidate all other tunneling
solutions, however they will improve the integrity of other tunneling solutions.
Remember that tunnels over IPv4 that set DF=0 and do not include an integrity
check are open to corruption. OMNI/OAL when used in the presence of those
other tunnel types closes the integrity gap.

Fred

---

Hi Fred,
As I remember, you do not try to invalidate all other tunneling solutions.
draft-ietf-intarea-tunnels is doing exactly this.

IMHO: If some hardware achievement would not give us reassembly almost for free
Then the general solution should not assume reassembly because it is still very expensive for hardware at tunnel end points.
Overlay/Underlay is very popular our days – we would see more and more tunneling. SRv6 is the best example based on RFC 2473.

But it could be fine for your environment because overall performance would not go many Tbps per 1 gateway.
It is still possible to rely on something like Network Processor.
You would do some tradeoff between cost and flexibility. A little more cost for your environment should not be the problem.
Eduard
From: Templin (US), Fred L [mailto:[email-masked]]
Sent: Thursday, March 25, 2021 6:12 PM
To: Vasilenko Eduard <[email-masked]<mailto:[email-masked]>>; int-area <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-ietf-intarea-tunnels concerns

Eduard, I did a quick pass through the intarea discussions and I see points raised that
have been repeated many times since Y2K and even since much longer before that.
Thankfully, there is now a solution called the “OMNI Adaptation Layer (OAL)”:

https://datatracker.ietf.org/doc/draft-templin-6man-omni/

Some might say that it is the “second-coming of AAL5”, and it is true there are
many similarities. Like IP over ATM, the OMNI interface has an MTU/MRU visible
to the IP layer and set to 9180 bytes since that is the maximum size that can be
well protected by CRC32. Like AAL5, within the OMNI interface the OAL has a
“cell size” that determines the size of each fragment that will be produced by
the adaptation layer below IP.

Unlike AAL5 where the cell size is fixed at 48 octets, however, the OAL sets
both a minimum cell size (termed “minimum Maximum Payload Size (MPS)”)
and a possibly larger per-path MPS discovered using probes if necessary. The
minimum/path MPS is the maximum-sized RFC2473 fragment that the OAL
can sneak through the path and be assured it won’t be dropped (silently or
otherwise) due to a size restriction. Without any probing, the minimum MPS
that can be assumed is 576 minus encapsulation overhead (i.e., the IPv4
minimum EMTU_R). But unlike AAL5, the OAL can always strive to find a
larger per-path MPS.

There is more to be said about the OAL, but I will leave it at that for now.
We can talk about PTB “hard” and “soft” errors later if there is interest.

Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 26 Mar 2021 18:58:06 +0000

Hi Eduard,

Thank you for your message. There are two specs to consider: 1) OMNI gives
the interface and OAL spec, and 2) AERO specifies the neighbor coordination
functions and segment routing details. Together, the specs provide the end
user with the “five M’s”: Mobility, Multilink, Multihop, Multicast and MTU.

In terms of dependencies, it is possible to use the OMNI spec for the interface
model for end systems and access routers while using something else besides
AERO in the core. Conversely, it is not possible to use AERO with any other
interface spec besides OMNI. So, that should give an idea of the dependencies.

Let me know as you come up with any questions or comments. Thanks again
for your consideration.

Fred

---

Hi Fred,

Fred

---

Fred,

Fred

---

Hi Fred,

Fred