Subject: 6man: duscuss/request for presentation slot - draft-xu-msr6-rbs/draft-chen-pim-mrh6

From: Toerless Eckert <[email-masked]>
Date: Wed, 9 Mar 2022 22:47:53 +0100

Dear 6man WG & chairs

In line with the reviving work in 6man for IPv6 hop-by-hop extension headers, we would
like to present and discuss the outline of two IPv6 HBH EH based drafts in support
of stateless p2mp replication for the native IPv6 based Segment Routing architecture:

https://datatracker.ietf.org/doc/draft-xu-msr6-rbs/
https://datatracker.ietf.org/doc/draft-chen-pim-mrh6/

One of the discussion points i would like to also raise with 6man (easier in a meeting
than only on email) about this type of drafts is how such work would be done administratively
across working groups given how something like P2MP functionality was moved from SPRING to
PIM (if i understand the process correctly) because of the deeper knowledge of Multicast
in that WG (with sync back to SPRING of course).

Likewise, followup work extending/modifying SRH/RFC8754 (which was done by 6MAN)
is now planned to be done in SPRING (draft-ietf-spring-srv6-srh-compression-00).

I think that outcome was not necessarily planned upfront, but instead figured out as the
work went along, but maybe for new work such as similar functionality for P2MP
Segment Routing EH, one could design upfront a clear line between what of such EH work would be
seen as 6man responsiblity, vs. what might be better done as followup work by
a more functional expert group such as PIM.

For example one might start with a
6man document only covering the structure up to the level of some multi-typed
p2mp representation, and that p2mp representation itself would be then subject to
work by e.g.: PIM. We have not yet structured our drafts this way yet, because we're
still trying to figure out our way through the djungle of WGs, so any
recommendations from 6man would be very hepful!

btw: we have asked to present the p2mp encoding/functionality details of the work in PIM, so given how
new this work is and how full maybe the 6man schedule is, we're perfectly fine to
concentrate on the EH specifics and comparison with SRH in 6man if time requires.

Cheers
    Toerless

---

From: Bob Hinden <[email-masked]>
Date: Wed, 9 Mar 2022 19:19:30 -0800

Toerless,

We were not able to accommodate this request in the first version of the agenda, but will discuss it tomorrow and see what we can do.

Bob

> On Mar 9, 2022, at 1:47 PM, Toerless Eckert <[email-masked]> wrote:
> 
> Dear 6man WG & chairs
>