Subject: [ire] The ICANN-IETF dynamic and escrow

From: Edward Lewis <[email-masked]>
Date: Fri, 23 Apr 2010 09:50:39 -0400

From reading the discussion on the list, in an effort to try and come 
to a consensus and not drag us into the epic battle of words over 
ICANN and anyone else...oh, if I have incorrectly stated anything 
here, please speak up.  The role of the chair is to try to capture 
what's being said, and not "make things up."  (I will note that not 
all of what I said here is strictly from the list, I added some 
background to the discussion to try to fill in the points made.)

In some sense, ICANN does look to the IETF as the protocol defining 
body[0].  This is not meant to be interpreted as the IETF is to build 
to what ICANN specifies, rather that ICANN sets up high-level 
requirements and seeks out the IETF to help fulfill the need.

Further, ICANN recognizes that it is not an all-encompassing body 
overseeing the business of registering identifiers on the Internet. 
The closest Internet organization that is all-encompassing - in the 
sense that anyone is accommodated regardless of any criteria - is the 
IETF.  So, ICANN turns to the IETF for solutions that will have 
impacts exceeding it's boundaries and to gain a wider review than it 
is capable of providing.

As a chair, I'd like to set side that this issue came from ICANN as a 
red herring (a distraction) from the matter at hand.  In this 
instance, ICANN has come forth with a general problem statement, a 
sample of what they came up with on their own, and with a "captive 
audience" that they will require to operate to what the IETF can 
generate.

It's important to note that this is not sufficient justify that the 
work is done in the IETF.  The IETF is not beholden to ICANN.  The 
IETF criteria for taking on work still apply.  And to me the number 
one criteria, summed up in one word is "interoperability."

References to previous ICANN-born work that came to the IETF are 
valid data points and valid for letting us learn what makes an effort 
successful or not.  With EPP one lesson was that wide review is good, 
but wider would be better.  IRIS saw that once the protocol was 
defined, it matters more if there is a real need for it.  But you can 
also find these same lessons in work born elsewhere.  E.g., DNSSEC 
didn't become popular with operations until Dan Kaminsky's research 
years after the protocol had gelled.  And we have many other 
protocols that haven't "caught fire."

[0] Historically, ICANN did envision IETF as the PSO (Protocol 
Supporting Organization), to go along with the ASO (Address) and NSO? 
(names?).  For the historical record - 
http://www.icann.org/pso/psonew.htm .  The ASO is alive and kicking 
(a whole'nuhter matter), I don't know what became of the name support 
organization because I don't normally hang around "ICANN."

The PSO, so far as I know, is an idea that expired a long time ago, 
put perhaps the proposal from 10+ years ago is what drives the 
thought that ICANN sees IETF as one of it's components.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis
NeuStar                    You can leave a voice message at +1-571-434-5468

Wouldn't it be nice if all of the definitions of equivalence were the same?

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 23 Apr 2010 07:43:17 -0700

At 9:50 AM -0400 4/23/10, Edward Lewis wrote:
>It's important to note that this is not sufficient justify that the work is done in the IETF.  The IETF is not beholden to ICANN.  The IETF criteria for taking on work still apply.  And to me the number one criteria, summed up in one word is "interoperability."

For me, the number two criterion  is "ability", as in "is the IETF able to do this work". If we were talking about a protocol, I would say "yes". But we are not talking about a protocol, it seems: we are talking about a data format and a set of semantics for the entries in that format.

The IETF has a long track record of wheel-spinning and rathole-finding we discuss formats. We do even worse when we try to specify semantics for things like people and businesses.

ICANN already has developed internally a data format and set of semantics that are adequate for their needs. If they want to improve them, they can probably do that internally as well, or they can use their normal practices to invite experts to help them.

What's left is whether an IETF-generated data format help other constituencies, such as for the address registries. It might, certainly, but it also might not, given our poor track record in the field. Anyone can write an XML or JSON or ASN.1 or CSV schema; anyone can specify their own semantics.

If the idea is to promote interoperability, publishing informational RFCs through the independent submissions stream is an excellent way to do that. A reasonable handful of those RFCs are, in fact, data schemas with semantics.

--Paul Hoffman, Director
--VPN Consortium