Subject: Re: [ire] Support for Launch Applications and Claims in draft-arias-noguchi-dnrd-objects-mapping

From: James Mitchell <[email-masked]>
Date: Wed, 14 May 2014 00:22:21 +0000

SMD and Claims information should not be included in the deposit as in most cases this is akin to the escrow of partial historical information not required to rebuild a working registry. However those registry operators that offer services that depend on, or require this information for the operation of the registry, should be escrowing this data already as prescribed in the Registry Agreement, Specification 2, Section 3.2, copied below for everyones reference.

3.2.            Extensions.  If a Registry Operator offers additional Registry Services that require submission of additional data, not included above, additional “extension schemas” shall be defined in a case by case basis to represent that data.  These “extension schemas” will be specified as described in Part A, Section 9, reference 2 of this Specification.  Data related to the “extensions schemas” will be included in the deposit file described in Part A, Section 3.1 of this Specification.  ICANN and the respective Registry Operator shall work together to agree on such new objects’ data escrow specifications.

I believe this is an ideal candidate to continue as a separate extension independent of the already unreadable escrow specification. Further, I don’t foresee any need to restore a failed registry into pending launch phase and would rather not see it in the specification. Again, I would consider it as an extension and treated as above.

Regards,
James Mitchell
Product Manager / ARI Registry Services

From: <Gould>, James <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 13 May 2014 10:34 pm
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [ire] Support for Launch Applications and Claims in draft-arias-noguchi-dnrd-objects-mapping

It was brought to my attention a little while back that a registry was having difficulty depositing launch applications using the CSV model of draft-arias-noguchi-dnrd-objects-mapping, since the primary key of the CSV files is the domain name (<csvDomain:fName>) and not the domain id (<csvDomain:fRoid>).  Additionally, the launch sunrise and claims attributes are not supported (phase, SMD identifier, mark, application status, claims notice identifier, claims validator identifier, claims accepted date, etc.).  I created a version of the draft that switched the domain CSV primary key to <csvDomain:fRoid> and added the CSV launch fields for sunrise and claims.   It is checked in at the GitHub project https://github.com/james-f-gould/draft-ryde.  I would like to hear whether such a change is needed.  Any feedback is welcome.

Thanks,

--

JG

James Gould
Principal Software Engineer
[email-masked]<mailto:[email-masked]>

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com
“This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”

---

From: "Gould, James" <[email-masked]>
Date: Wed, 14 May 2014 12:25:24 +0000

James,

Thanks for your feedback.  I do agree that the pending launch information is not necessary to rebuild a typical registry.  Are there any registries out there that have a need for escrowing the additional launch information (applications and additional sunrise and claims attributes) and if so whether it should be integrated into draft-arias-noguchi-dnrd-objects-mapping or created as an extension outside of draft-arias-noguchi-dnrd-objects-mapping?

Thanks,

--

JG

James Gould
[email-masked]

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: James Mitchell <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 13, 2014 at 8:22 PM
To: James Gould <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ire] Support for Launch Applications and Claims in draft-arias-noguchi-dnrd-objects-mapping

Regards,
James Mitchell

Thanks,

--

JG

James Gould

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com