Subject: [Isis-wg] New 10589 spec, PtoP and ISHs

From: Neal Castagnoli <[email-masked]>
Date: Tue, 21 Aug 2001 13:13:55 -0700

From the original 10589, routers might be able to get around sending ISHs on
ptop circuits.  The original states routers should transmit an IIH
immediately upon circuit startup, and so an implementation need not send an
ISH to get the peer IS to start IIH transmission.  New 10589, however,
removes this wording, and now it appears routers require receipt of an ISH
prior to sending the first IIH.

Yet if there are old implementations that don't send ISHs, ptop adjacencies
won't come up with strict new implementations.  Does anyone know whether
there are deployed ISIS implementations that don't send ISHs on ptop
circuits?

Thanks,
	
  --Neal
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Neal Castagnoli <[email-masked]>
Date: Mon, 27 Aug 2001 10:48:53 -0700

I think Les has it right.

New strict implementations shouldn't begin sending IIHs until they receive
an ISH.  Perhaps they will accept the IIH, but they won't begin sending the
IIH.

  --Neal

> 
> 
> If my memory serves me, on a PTP circuit, an implementation 
> is required
> to handle receipt of an IIH without having received an ISH, so Les's
> wise general rule doesn't need to be invoked.
> 
> At 04:39 PM 8/21/2001, Les  Ginsberg wrote:
> >This issue is a confusing one, some of which is due to the 
> fact that the
> >original wording in ISO 10589:1992 was revised by Technical 
> Corrigendum I
> >(published in 1993), but because many people do not have 
> ready access to the
> >TCs, they rely on the uncorrected original text. In fact, 
> the original
> >intent was made clear in TC1 by adding:
> >
> >"An IS shall cause ISO 9542 to send an ISH PDU whenever a 
> point-to-point
> >circuit is first enabled."
> >
> >and then changing the original text in 8.2.3a (which Neal 
> refers to in
> >stating that an IIH was supposed to be sent when the circuit 
> was first
> >enabled) to read:
> >
> >"a)the IS receives an ISH PDU"
> >
> >So the original intent was to wait for receipt of an ISH 
> before beginning to
> >send IIHs. The latest ISO 10589 draft further clarifies this 
> by specifying
> >that ISH's should continue to be sent periodically until the 
> adjacency
> >reaches the UP state. This is a logical requirement discovered when
> >implementing that was not clearly stated even in the TC1 changes.
> >
> >In an IP only IS-IS implementation, the use of ISH's is an 
> anachronism. Many
> >implementations relax the requirements, at least on 
> reception, so that
> >receiving an ISH is not required. In following the old axiom of being
> >"strict in what you send and generous in what you receive", a robust
> >implementation should send ISHs until the adjacency is up, 
> but allow (at
> >least for IP operation) the adjacency to come up without 
> ever seeing an ISH.
> >This is easily achieved by starting to send IIHs when you 
> first receive an
> >IIH.
> >
> >I can tell you from first hand experience that there are indeed
> >implementations out there which do not send ISHs.
> >
> >   Les
> >
> >
> >
> >
> >> -----Original Message-----
> >> From: Neal Castagnoli [mailto:[email-masked]]
> >> Sent: Tuesday, August 21, 2001 1:14 PM
> >> To: [email-masked]
> >> Subject: [Isis-wg] New 10589 spec, PtoP and ISHs
> >> 
> >> 
> >>