Subject: Fw: [Isis-wg] Area Architecture

From: "Swati Rastogi" <[email-masked]>
Date: Thu, 9 Aug 2001 21:40:42 +0530

Pl. see my comments inline ..

> Hi Mike,
> I am working in a startup company and we are trying to develop the entire
> tcp/ip stack. I have to look after the integrated ISIS .. this is my
second
> job .. prior to this i was working on BGP for a firm known as Tata
> Consultancy Services (TCS) ..
>
> Regards,
> Swati Rastogi
>
> ----- Original Message -----
> From: "Mike Truskowski" <[email-masked]>
> To: "Swati Rastogi" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Thursday, August 09, 2001 8:49 PM
> Subject: Re: [Isis-wg] Area Architecture
>
>
> > I don't mind answering questions but I want to know
> > who you work for.

> > >
> > > A ----- B ------ C
> > > (l1)      (l2)         (l1)
> > >
> > > A & B are in the same area while C is in a different area.
> > > A and C are L1 routers and B is an L2 only.
> > >
> > > Firstly .. is this configuration possible ??
> > This is not a valid topology "if" the lines connecting
> > them is serial links.  If so put B into the same are by
> > saying:
> > router isis
> > net 12
> > net 11
> >
> > If you want to the the following with an ethernet...
> >
> >        B (11)
> >        |
> >  -------------
> >   |      |
> >   A(12)  C(12)
> >
> >  Then this works as long as either A or C is L1/L2 and
> > B is L2.
> >
> > A and C will create a L1 adjacency.

Can i have L1 adjaceny between ISs in differet areas !
How !?!?!

AFAIK i mentioned that A & B are in the same area while C is in some other
area.

> > C and B will create a L2 adjacency.

I think you got the routers wrong !
Your figure above says that B is L1 then how can it have L2 adjaceny with B
???

> > If A wants to send a packet to B then the router will
> > be A-to-C-to-B... following the L2 route.

Why A and B are in same areas ..  !?!?

I think you had smthg else in mind and you have written something else ..
could you please check that !

Regards,
Swati

> >
> > A will pick C because C having the adjacency with B will
> > have access to external areas.  Then the L1 instance on
> > C will set the ATT bit telling A that C has a path.
> > During SPF time A will set C as the next hop out to forward
> > packets outside the area.
> >
> > > Secondly .. B and C are in different areas so how does the adjaceny go
> up ??
> > The adjacency in this case will not come up.
> > A and C are L1 in area 11.  B is in 12.
> > No level 1 adjacency because they must be in the same area.
> > No level 2 because only B is level 2.
> > If you change, say C, to be L1/L2 then there will be
> > an adjacency between B & C.  A will be black holed.  Alone
> > and unreachable.
> >
> > > Thirdly .. A is a L1 router while B is L2 .. Can they communicate .. I
> > > thought that B should then be L1/L2
> > See above.
> >
> > Mike
> >
> >
> > >
> > > I know i am being miserable .. but please help!
> > >
> > > Thanks in advance ..
> > >
> > > Swati
> > >
> > > ----- Original Message -----
> > > From: "Mike Truskowski" <[email-masked]>
> > > To: "stefano previdi" <[email-masked]>
> > > Cc: <[email-masked]>; <[email-masked]>
> > > Sent: Thursday, August 09, 2001 7:25 PM
> > > Subject: Re: [Isis-wg] Area Architecture
> > >
> > >
> > > > Swati,
> > > > First of all you are discussing the actions of a protocol
> > > > and trying to relate them to how a router is configured.
> > > > This is hard to do.....
> > > >
> > > > Consider a processor with I/O ports attached.
> > > >
> > > > For OSPF, when the processor runs OSPF each I/O port
> > > > must be told that it is running OSPF and "which" area
> > > > it is in.
> > > >
> > > > For ISIS, when the processor runs ISIS it is given
> > > > an area address by default within the NET.   Now
> > > > when an I/O port is enabled for ISIS they belong
> > > > to the same area as the processor or instance of ISIS
> > > >
> > > > Consider a simple example using 1 NET.
> > > > So with a router... you configure the router to
> > > > start ISIS by saying "router isis"  but you also
> > > > must tell this router his NET.
> > > >
> > > > router isis
> > > > net 490001xxxxssssss00
> > > >
> > > > Now when you enable an interface the interface is in
> > > > this area by default....490001xxxx.
> > > >
> > > > mike
> > > >
> > > > >
> > > > > At 08:26 09/08/2001, Swati Rastogi wrote:
> > > > > >Hi,
> > > > > >In OSPF it is said that the areas are bound to the interfaces and
> that
> > > the
> > > > > >OSPF area boundaries fall within a router. This statement is not
> very
> > > clear
> > > > > >and it gets more confusing when its said that in ISIS, area
> boundaries
> > > is on
> > > > > >a link rather than in the router.
> > > > >
> > > > > this because the router itself is configured as part of one area.
> > > > > What you did in your example below is that you forced (through
some
> > > > > interface configuration commands) the router to establish a
specific
> > > > > adjacency level. But this doesn't mean that the router is part of
> > > > > more areas. The router is still part of one area.
> > > > >
> > > > > s.
> > > > >
> > > > >
> > > > > >What is bothering me is the fact that in
> > > > > >ISIS also its only on the interface basis that i say that the
> > > particular
> > > > > >link is L1 or L2.
> > > > > >Let me explain . .
> > > > > >A, B are both  cisco routers
> > > > > >
> > > > > >A ---------------------  B
> > > > > >(L1/L2)                        (L1)
> > > > > >
> > > > > >A and B are both in the same area
> > > > > >
> > > > > >Configuration of router A would be
> > > > > >
> > > > > >interface loopback0
> > > > > >ip address 192.168.1.1 255.255.255.255
> > > > > >!
> > > > > >interface Pos2/0/0
> > > > > >ip address 192.168.16.1 255.255.255.0
> > > > > >ip router isis
> > > > > >isis circuit-type-level-2
> > > > > >!
> > > > > >Fastethernet4/0/0
> > > > > >ip address 192.168.11.1 255.255.255.0
> > > > > >ip router isis
> > > > > >isis circuit-type-level-1
> > > > > >!
> > > > > >router isis
> > > > > >net 49.0001.1921.6800.1001.00
> > > > > >
> > > > > >(1) If we look at the profile definition then here also we have
> defined
> > > the
> > > > > >areas  on the interfaces basis .. saying that 192.168.16/24 is my
> L2
> > > while
> > > > > >192.168.11/24 is L1.
> > > > > >(2) Will all of the LSPs recvd on any one of the interfaces be
> known to
> > > the
> > > > > >other ?
> > > > > >
> > > > > >Router  configuration of Router B
> > > > > >
> > > > > >interface loopback0
> > > > > >ip address 192.168.1.2 255.255.255.255
> > > > > >!
> > > > > >interface Fastethernet0/0
> > > > > >ip address 192.168.11.2 255.255.255.0
> > > > > >ip router isis
> > > > > >isis circuit-type-level-1
> > > > > >!
> > > > > >router isis
> > > > > >net 49.0001.1921.6800.1002
> > > > > >
> > > > > >(1) Here on the 192.168.1/24 interface both the routers are
running
> L1
> > > level
> > > > > >routing .. So is ISIS not interface based ??
> > > > > >
> > > > > >Please explain . .
> > > > > >
> > > > > >Regards,
> > > > > >Swati
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >_________________________________________________________
> > > > > >Do You Yahoo!?
> > > > > >Get your free @yahoo.com address at http://mail.yahoo.com
> > > > > >
> > > > > >_______________________________________________
> > > > > >Isis-wg mailing list  -  [email-masked]
> > > > > >http://external.juniper.net/mailman/listinfo/isis-wg
> > > > >
> > > > > _______________________________________________
> > > > > Isis-wg mailing list  -  [email-masked]
> > > > > http://external.juniper.net/mailman/listinfo/isis-wg
> > > > >
> > >
> > >
> > > _________________________________________________________
> > > Do You Yahoo!?
> > > Get your free @yahoo.com address at http://mail.yahoo.com
> > >
> > > _______________________________________________
> > > Isis-wg mailing list  -  [email-masked]
> > > http://external.juniper.net/mailman/listinfo/isis-wg
> > >
> >
> > _______________________________________________
> > Isis-wg mailing list  -  [email-masked]
> > http://external.juniper.net/mailman/listinfo/isis-wg
>

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Mike Truskowski <[email-masked]>
Date: Thu, 09 Aug 2001 9:20:20 PDT

Swati,
Yep, I got it wrong...

I answered the questions for the following topology.

  A----B----C
 (11) (12) (11).

A and C in same area = 11
B in area 12

A and C are L1 only
B is L1/L2.

I will go back an reply properly to what you sent the first
time...

mike