Subject: [Isis-wg] Area Architecture

From: "Swati Rastogi" <[email-masked]>
Date: Thu, 9 Aug 2001 11:56:13 +0530

Hi,
In OSPF it is said that the areas are bound to the interfaces and that the
OSPF area boundaries fall within a router. This statement is not very clear
and it gets more confusing when its said that in ISIS, area boundaries is on
a link rather than in the router. What is bothering me is the fact that in
ISIS also its only on the interface basis that i say that the particular
link is L1 or L2.
Let me explain . .
A, B are both  cisco routers

A ---------------------  B
(L1/L2)                        (L1)

A and B are both in the same area

Configuration of router A would be

interface loopback0
ip address 192.168.1.1 255.255.255.255
!
interface Pos2/0/0
ip address 192.168.16.1 255.255.255.0
ip router isis
isis circuit-type-level-2
!
Fastethernet4/0/0
ip address 192.168.11.1 255.255.255.0
ip router isis
isis circuit-type-level-1
!
router isis
net 49.0001.1921.6800.1001.00

(1) If we look at the profile definition then here also we have defined the
areas  on the interfaces basis .. saying that 192.168.16/24 is my L2 while
192.168.11/24 is L1.
(2) Will all of the LSPs recvd on any one of the interfaces be known to the
other ?

Router  configuration of Router B

interface loopback0
ip address 192.168.1.2 255.255.255.255
!
interface Fastethernet0/0
ip address 192.168.11.2 255.255.255.0
ip router isis
isis circuit-type-level-1
!
router isis
net 49.0001.1921.6800.1002

(1) Here on the 192.168.1/24 interface both the routers are running L1 level
routing .. So is ISIS not interface based ??

Please explain . .

Regards,
Swati

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: stefano previdi <[email-masked]>
Date: Thu, 09 Aug 2001 11:25:17 +0200

At 08:26 09/08/2001, Swati Rastogi wrote:
>a link rather than in the router.

this because the router itself is configured as part of one area.
What you did in your example below is that you forced (through some
interface configuration commands) the router to establish a specific
adjacency level. But this doesn't mean that the router is part of
more areas. The router is still part of one area.

s.

>What is bothering me is the fact that in

---

From: Mike Truskowski <[email-masked]>
Date: Thu, 09 Aug 2001 6:55:27 PDT

Swati,
First of all you are discussing the actions of a protocol 
and trying to relate them to how a router is configured.
This is hard to do.....

Consider a processor with I/O ports attached.

For OSPF, when the processor runs OSPF each I/O port
must be told that it is running OSPF and "which" area
it is in.

For ISIS, when the processor runs ISIS it is given
an area address by default within the NET.   Now
when an I/O port is enabled for ISIS they belong
to the same area as the processor or instance of ISIS

Consider a simple example using 1 NET.
So with a router... you configure the router to 
start ISIS by saying "router isis"  but you also
must tell this router his NET.

router isis
net 490001xxxxssssss00

Now when you enable an interface the interface is in
this area by default....490001xxxx.

mike

---

From: "Swati Rastogi" <[email-masked]>
Date: Thu, 9 Aug 2001 20:28:05 +0530

Mike,
If this is so then I am having problems visualizing as to how we can assign
multiple addresses to an IS. For i always thought that area addresses are
assigned per interface basis.
There is this line in the rfc 1195 which says .. "A level 1 router will
refuse to become a neighbor with a node whose area addresses do not overlap
its area address." This creates a confusion too .. Consider the topology as
shown below.

A ----- B ------ C
(l1)      (l2)         (l1)

A & B are in the same area while C is in a different area.
A and C are L1 routers and B is an L2 only.

Firstly .. is this configuration possible ??
Secondly .. B and C are in different areas so how does the adjaceny go up ??
Thirdly .. A is a L1 router while B is L2 .. Can they communicate .. I
thought that B should then be L1/L2

I know i am being miserable .. but please help!

Thanks in advance ..

Swati

---

From: Mike Truskowski <[email-masked]>
Date: Thu, 09 Aug 2001 8:19:00 PDT

I don't mind answering questions but I want to know 
who you work for.

In my email I stated that I would give a simple example.

see below...

> Firstly .. is this configuration possible ??
This is not a valid topology "if" the lines connecting
them is serial links.  If so put B into the same are by
saying:
router isis
net 12
net 11

If you want to the the following with an ethernet...

       B (11)
       |
 -------------
  |      |
  A(12)  C(12)  

 Then this works as long as either A or C is L1/L2 and
B is L2.

A and C will create a L1 adjacency.
C and B will create a L2 adjacency.
If A wants to send a packet to B then the router will
be A-to-C-to-B... following the L2 route.

A will pick C because C having the adjacency with B will
have access to external areas.  Then the L1 instance on
C will set the ATT bit telling A that C has a path.
During SPF time A will set C as the next hop out to forward
packets outside the area.

> Secondly .. B and C are in different areas so how does the adjaceny go up ??
The adjacency in this case will not come up.
A and C are L1 in area 11.  B is in 12.
No level 1 adjacency because they must be in the same area.
No level 2 because only B is level 2.
If you change, say C, to be L1/L2 then there will be 
an adjacency between B & C.  A will be black holed.  Alone
and unreachable.

> thought that B should then be L1/L2
See above.

Mike

---

From: Micah Bartell <[email-masked]>
Date: Thu, 09 Aug 2001 11:13:14 -0500

>assigned per interface basis.

NSAP's are applied per node, while IP addresses are applied per interface.

If we assign multiple NSAP's to a single node, that "area" is actually the 
union of those area addresses.

>its area address."

If a router is an L1-Only router and receives an IIH from a neighbor with a 
different Area Address, it will not form an adjacency.

>This creates a confusion too .. Consider the topology as
>shown below.
>
>A ----- B ------ C
>(l1)      (l2)         (l1)
>

If A is L1-Only, and B is L2-Only, what level of adjacency would they 
form?  If C is in a different are, but is L1-Only, what level of adjacency 
would it form with B, which is L2-Only?  This would be a broken 
design.  Make A L1-Only, B L1L2, and C L1L2 and everything works fine.

>Secondly .. B and C are in different areas so how does the adjaceny go up ??

It will only go up if you allow them to form L2 adjacencies.

>Thirdly .. A is a L1 router while B is L2 .. Can they communicate ..

No.

>  I

Yes, you need to allow adjacency usage L1, with B being an L1L2 router.

---

From: Mike Truskowski <[email-masked]>
Date: Thu, 09 Aug 2001 9:27:39 PDT

Swati,
Second try ... here goes with your topology below.

> its area address." This creates a confusion too .. Consider the topology as
  L1        L2           L1

> Firstly .. is this configuration possible ??

It is possible but will not work.
L1 adjacencies are separate from L2 adjacencies.
So A and B need a L1 adj. but can not because B is
not L1.
C can not talk to B because they are in different areas and
 they need a L2 adj.   So C needs to be L1/L2.

This works:

  A--------B-----------C
area 1     1           2
  L1     L1/L2        L2/L1

> Secondly .. B and C are in different areas so how does the adjaceny go up ??
It does not.
C must be L2.  They there will be only a L2 adj.  No L1 adj.

> thought that B should then be L1/L2
B must be L1/L2 for A to talk to it.

The discussion I had before was actually more detailed but the
topology was also different.  Match the discussion with the
topology I replied with and you will have a couple of scenarios
to play iwth.

Mike

---

From: "Swati Rastogi" <[email-masked]>
Date: Thu, 9 Aug 2001 22:46:42 +0530

> union of those area addresses.

Can you please expound on the above point ..
As i understand node refers to an IS .. Are you implying that one IS can be
in multiple areas ??

Regards,
Swati

---

From: Micah Bartell <[email-masked]>
Date: Thu, 09 Aug 2001 12:51:33 -0500

No, I am saying that an area can have multiple area addresses.

/mpb