Subject: RE: [Isis-wg] Routing or forwarding

From: Anand Ammundi <[email-masked]>
Date: Thu, 9 Aug 2001 10:27:03 -0700

A routing protocol is part of the control plane...it merely 
provides the required information to the data plane for the 
forwarding to take place. As far as getting the control packets
themselves across, since IS-IS (and OSPF for that matter) are
not sending out their PDU's beyond 1 hop, the receiving peer will 
know to send the PDU up the stack to ISIS based on the protocol
ID's (0xFEFE or 0x0021 etc)...actually, it is not really a "taken
for granted" thing...for example, say over a POS link, you have 
2 different PDU's ...
  1) PPP-IP
  2) PPP-ISIS
assuming that software forwarding is a thing of the past, in case 1)
the data plane will make a forwarding decision based on the DST_ADDR
and either send it to CPU or forward it directly...for case 2), there
explicitly has to be special handling in the data plane, to send this 
to CPU (stack) as a terminating packet...note that this handling is 
implicitly taken care of for say OSPF or BGP since they are on top of IP.
  hope this answers your question
  anand
ps: Though I don't think the spec has anything against ISIS running over IP,
but
    I doubt if there are any such implementations on the field.
    
-----Original Message-----
From: Manav Bhatia [mailto:[email-masked]]
Sent: Thursday, August 09, 2001 9:22 AM
To: sudhir dskjf; Micah Bartell
Cc: [email-masked]
Subject: Re: [Isis-wg] Routing or forwarding

I think what Sudhir meant was that if IS-IS just performs the routing
functions then who forwards these packets (ISIS) to the underlying network
.. since it is not supposed to be running on top of any networking layer
protocol !

Manav
----- Original Message -----
From: "Micah Bartell" <[email-masked]>
To: "sudhir dskjf" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, August 09, 2001 9:29 PM
Subject: Re: [Isis-wg] Routing or forwarding

> Or are you talking about IS-IS fowarding LSP's?  Because IS-IS runs
> directly over the data link, it would not make use of CLNS or IP for it's
> forwarding.  Some other protocols do make use of other L3 protocols for
> forwarding routing information, such as OSPF making use of IP.
>
> Is this what you were looking for?
>
> /mpb
>
> At 10:20 08/09/2001 +0100, sudhir dskjf wrote:
> >hi all,
> >The Dual Is-Is performs routing i.e to calculate the
> >optimal path or it forwards packets also?
> >I have this doubt because i read that the IS-IS uses
> >the services of the data link directly. Can a routing
> >protocol make use of a lower layer services or the
> >Is-IS protocol makes use of CLNP or Ip for forwarding.
> >
> >thanks in advance
> >srikrishna
> >
> >____________________________________________________________
> >Do You Yahoo!?
> >Send a newsletter, share photos & files, conduct polls, organize chat
> >events. Visit http://in.groups.yahoo.com.
> >_______________________________________________
> >Isis-wg mailing list  -  [email-masked]
> >http://external.juniper.net/mailman/listinfo/isis-wg
>
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Mon, 20 Aug 2001 18:57:40 -0400

> > An alternative proposal to deal with the cell tax was
> > proposed which ... demultiplexes based on the ...
> > the first nibble 
>
>   I wrote the draft for that proposal when I was at a previous job.
>  At the time I contacted a few large ISPs that had ATM backbones.
>  Nobody seemed to be really interested to save some bandwidth.
>  Some because they had enough bandwidth, some because they were
>  planning to move to PacketOverSonet (and MPLS).
>  So I never commited the changes to my former employer's software.
>  And because my idea had no been deployed, I let the draft die.
> 
>   Are there really people using this hack to run ISIS and IP over
>  one aal5mux VC ? I'd be very interested to hear from them.
>  Thanks,
> 
>     Henk.

Henk -

	And I was counting your former employer as one vendor! 

	In a previous life, I heard from ISPs that were interested
in removing the ATM cell tax, and suspect that concern remains. 
We all know that not everything that is requested and delivered
is deployed.  
 
	I have heard more than one vendor discuss your proposal 
with interest.  I don't know of any deployments.  

- jeff parker
- axiowave networks