Subject: [Isis-wg] NSAP Structure

From: "Manav Bhatia" <[email-masked]>
Date: Fri, 10 Aug 2001 10:25:44 +0530

Hi,
The general structure of the NSAP structure as defined in RFC 1629 (6.2.1)
gives the length of system Identifier to be varying from 1-8 octets.
The length of the source ID for all the IS-IS PDUs as given in the rfc 1142
is 6 octets. Now if i have a system ID of 8 octets .. how do i map this into
6 octets in my IS-IS PDUs ??

Regards,
Manav Bhatia

"C is not a big language, and is not well served by a big book." -- K&R2

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Fri, 10 Aug 2001 10:50:29 -0400

Friends don't let friends use 8-byte system IDs ;-)

RFC 1142 is the draft standard.  One of the wonderful things that
the ISO committee did was to permit the system ID to be 1-8 bytes,
making our lives more enjoyable and increasing employment security
for software engineers.  The ID size must be constant throughout
a routing domain.

You need to implement ISO 10589, not the draft standard.

Regards,
Jeff

---

From: Micah Bartell <[email-masked]>
Date: Fri, 10 Aug 2001 10:05:40 -0500

To the best of my knowledge, no one has implemented anything but 6 byte 
systemID's.

Also, the sourceID is systemID Length +1.

Area addresses however are implemented variable length.

/mpb

---

From: "Manav Bhatia" <[email-masked]>
Date: Fri, 10 Aug 2001 20:45:35 +0530

> To the best of my knowledge, no one has implemented anything but 6 byte

But its defined in the RFC .. so there is no garuntee that all systems IDs
will fall under 6 bytes !

> Also, the sourceID is systemID Length +1.

Is the +1 for the SEL byte ??
I dont think the SEL byte is included in defining the unique ID of the IS
i.e. Source ID !

> Area addresses however are implemented variable length.

Area addresses may  computed as (total length - (system ID +1) )
I read it somewhere but its not exactly flashing me where ..

Manav

---

From: Micah Bartell <[email-masked]>
Date: Fri, 10 Aug 2001 10:19:42 -0500

Let me clarify.

The sourceID is IDlength (systemID) for LSP's.
For SNP's, it is IDlength+1, the +1 is a zero circuit ID.

/mpb

---

From: Mike Truskowski <[email-masked]>
Date: Fri, 10 Aug 2001 8:22:53 PDT

See below...

> will fall under 6 bytes !

Look, the systemID can be, by ISO, 1-8 bytes.  If you want to code
for 1-8 bytes.. fine...  but what Micah and Jeff are telling you is
that the "world" uses 6 byte ids and this is consistant domain 
wide.  

> > Also, the sourceID is systemID Length +1.

systemID = 6
nsel     =1

everything else in front of this is the area address.

mwt