Subject: RE: [Isis-wg] Action on receipt of LSP

From: "Sunkad, Ravindra" <[email-masked]>
Date: Fri, 17 Aug 2001 11:33:32 -0400

Ken,

Here's an excerpt from 7.3.16.3

"If the Remaining Lifetime in a received LSP or in an LSP entry in a
received SNP is non-zero, but there is an LSP in the database with the same
sequence number and zero Remaining Lifetime, the LSP in the database shall
be considered most recent.  Otherwise, the PDU with the larger sequence
number shall be considered the most recent."

Ravi

> -----Original Message-----
> From: Ken Larmer [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 11:04 AM
> To: Isis-Wg@Spider. Juniper. Net
> Cc: Ken Larmer
> Subject: [Isis-wg] Action on receipt of LSP
> 
> 
> Hi,
> 
> 	ISO-10589 states the action to take when receiving 
> certain LSPs (Newer,
> Same, Older...). The specification does not state what to do when you
> receive a LSP, which contains the same LSPID, Sequence Number but with
> different Remaining Lifetime values, i.e. the LSP Database Entry has
> Remaining Lifetime = 0 and the received LSP has Remaining 
> Lifetime = 1199.
> What should we do in this situation? Should we return the 
> expired LSP to the
> source?
> 
> Cheers,
> Ken
> 
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg
> 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Nageswara Soma <[email-masked]>
Date: Fri, 17 Aug 2001 08:58:54 -0700

What if received LSP has a different life time than
the one in LSP database? Note that both life times are non-zero.
I had come across such case against a test suite. It regenerated
an LSP with different content with same sequence number.

Thanks
Nageswara

> From: Sunkad, Ravindra [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 8:34 AM
> To: 'Ken Larmer'; Isis-Wg@Spider. Juniper. Net
> Subject: RE: [Isis-wg] Action on receipt of LSP
> 
> 
> Ken,
>

---

From: Satish Dattatri <[email-masked]>
Date: Fri, 17 Aug 2001 11:17:41 -0700

Hi Soma,
Hopefully the checksum would be different in that case also.
7.3.16.2:
Now there are 2 cases the LSP being a 
(a) local one: bump the seq# and regenerate
(b) non-local LSP: purge the LSP since there is no reliable way
to tell which is more recent.

I think this needs to be done also, could not find the ref in the spec:
If the checksum happens also to be same then unless an implementation
does a diff (either on the raw PDU or the contents)it will take it to 
be a duplicate reception of same LSP and ignore. On doing a diff in 
your case, the LSP will be purged becoz of the different content.

Satish

-----Original Message-----
From: Nageswara Soma [mailto:[email-masked]]
Sent: Friday, August 17, 2001 8:59 AM
To: Isis-Wg@Spider. Juniper. Net
Subject: RE: [Isis-wg] Action on receipt of LSP

Thanks
Nageswara

---

From: "Sunkad, Ravindra" <[email-masked]>
Date: Fri, 17 Aug 2001 15:28:12 -0400

The "Remaining Lifetime" field is not used in checksum computation. So, it's
possible that the received LSP has the same seq. no. and the same checksum
(and the same contents except Rem. Life Time). In that case I would think
the IS would just treat it as receiving an LSP "equal" to it's copy.

Ravi

> From: Satish Dattatri [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 2:18 PM
> To: 'Nageswara Soma'; Isis-Wg@Spider. Juniper. Net

---

From: Satish Dattatri <[email-masked]>
Date: Fri, 17 Aug 2001 16:29:06 -0700

But in case of Soma's question a test suite generated a LSP with
same seq# but different contents in the LSP. And you are right
life time *cannot* be a factor to decide which is newer (see b 
in the old mail). This commonly happens when same LSP is recvd from
2 neighbor's.

Satish
-----Original Message-----
From: Sunkad, Ravindra [mailto:[email-masked]]
Sent: Friday, August 17, 2001 12:28 PM
To: 'Satish Dattatri'; 'Nageswara Soma'; Isis-Wg@Spider. Juniper. Net
Subject: RE: [Isis-wg] Action on receipt of LSP

Ravi