Subject: RE: [Isis-wg] ISIS: what ISO protocols do we need? ...

From: NetProtocols Engineer <[email-masked]>
Date: Fri, 14 Sep 2001 11:54:40 -0700 (PDT)

Great! Thanks for helping out on that. But per 1195 section 4.4:
---------------------------------------------------------------------
For point-to-point links, IS-IS requires exchange of ISO 9542 ISHs,
as the first step in establishing the link between routers. All IS-IS
routers are therefore required to transmit and receive ISO 9542 ISH
packets on point-to-point links.
---------------------------------------------------------------------
These ISH packets are different from ISIS Hellos, right? And since
our primary interest is p2p links (duh! like everyone else!! ;-),
I am wondering if we would need to bring in some ISH related code?

Again, thanks in advance for all help.

--- Nageswara Soma <[email-masked]> wrote:
> You don't need CLNP or ESIS to run ISIS.
> ESIS is only used to exchange some information
> between ES and IS. In reality we don't see any ES.
> So just ISIS should work fine. As you pointed out
> ISIS PDUs are encapsulated in Ethernet frames.
> +-----------------------------------------+
> | DA(6) | SA(6) | Len(2) |LLC(3) |  PDU   |
> +-----------------------------------------+
> 
> DA - destination multicast MAC address (refer to ISO10589)
> SA - Source MAC address
> Len - length of payload (LLC header + ISIS PDU)
> LLC - LLC header
> PDU - LSP, IIH, CSNP, PSNP etc
> 
> LLC header:
> DSAP - destination SAP (0xFE for ISO)
> SSAP - source SAP (0xFE for ISO)
> CTRL - control field (0x3 for ISO)
> 
> Hope it helps
> Soma
> 
> > -----Original Message-----
> > From: NetProtocols Engineer [mailto:[email-masked]]
> > Sent: Friday, September 14, 2001 9:33 AM
> > To: [email-masked]
> > Subject: [Isis-wg] ISIS: what ISO protocols do we need? ...
> > 
> > 
> > Hi! I was wondering what all ISO protocols (CLNP, ESIS, etc) 
> > do we need to get
> > ISIS running? Also, is my understanding correct: ISIS goes 
> > directly on top of
> > the link layer (Eth/PPP)? So, what, if any, roles do CLNP and 
> > ESIS, etc play in
> > ISIS' functionality?
> > 
> > Thanks in advance for your responses!
> > 
> > 
> > __________________________________________________
> > Terrorist Attacks on U.S. - How can you help?
> > Donate cash, emergency relief information
> > http://dailynews.yahoo.com/fc/US/Emergency_Information/
> > _______________________________________________
> > Isis-wg mailing list  -  [email-masked]
> > http://external.juniper.net/mailman/listinfo/isis-wg
> > 

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Fri, 14 Sep 2001 15:48:14 -0400

ISO 10589 requires you to send an ESIS ISH PDU when starting
a point-to-point circuit.  (This is in technical corrigendum 1,
and will be in the new version of the spec.)  Also, you are
supposed to wait until you receive an IIH or an ESIS ISH before
sending an IIH.

It may no longer be a practical necessity, but it's required
by the spec.  In any case, you will definitely need to be able
to receive them without causing problems.

Jeff