Subject: [Isis-wg] Questions about isis mib

From: Laura Liu <[email-masked]>
Date: Fri, 1 Feb 2002 11:32:10 -0600

Hi Jeff,

I am not clear why we need the isisCircIndex in isisIPRATable. IP Reachable
Address (either static, or direct connected, or redistributed from other
routing protocol) is per isis router based, not a isis circuit based. 

Any light are appreciated.

Laura

     isisIPRATable OBJECT-TYPE
         SYNTAX SEQUENCE OF IsisIPRAEntry
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "The table of IP Reachable Addresses to networks,
             subnetworks or hosts either manually configured or
             learned from another protocol."
     ::= { isisIPReachAddr 1 }

     isisIPRAEntry OBJECT-TYPE
         SYNTAX IsisIPRAEntry
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "Each entry defines an IP Reachable Address to a network,
             subnetwork or host."
         INDEX {  isisSysInstance,
             isisCircIndex,
             isisIPRAType,
             isisIPRAIndex }
     ::= { isisIPRATable 1 }

----------------------------------------- (on Chiaro SMTP Relay)

This e-mail and any files transmitted with it are the property
of Chiaro Networks, Ltd., and may contain confidential and 
privileged material for the sole use of the intended recipient(s)
to whom this e-mail is addressed. If you are not one of the named
recipient(s), or otherwise have reason to believe that you have 
received this message in error, please notify the sender and 
delete all copies from your system.  Any other use, retention, 
dissemination, forwarding, printing or copying of this e-mail is 
strictly prohibited.

---------------------------------------------------------

---

From: Jeff Parker <[email-masked]>
Date: Fri, 1 Feb 2002 16:12:29 -0500

> Hi Jeff,
> 
> I am not clear why we need the isisCircIndex in 
> isisIPRATable. IP Reachable Address (either 
> static, or direct connected, or redistributed 
> from other routing protocol) is per isis router 
> based, not a isis circuit based. 
> 

Laura -
	You are right that other systems do not need
to know this information.  However, SNMP is used
to manage the router.  If you are to tell ISIS
to add this address, you want the protocol where
to send the packets with that address.

- jeff parker

>              "Each entry defines an IP Reachable Address to a network,
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Laura Liu <[email-masked]>
Date: Fri, 1 Feb 2002 16:31:51 -0600

Hi Jeff,

You mean the isisCircIndex here reports the interface to which next hopw is
connected. Does it consider to be an attribute of IPRA? If we use
isisCircIndex before the IPRAIndex, it will display the IP reachable routes
grouped by its next hop interface. It looks odd to me, because this table is
IPRATable not under a circuit table. I would prefer we add an entry like
isisIPRANextHop (interface name or IP net address as value) and remove
isisCircIndex in oid index.

what do you think?

best regards,

Laura

Laura -

- jeff parker

---

From: Laura Liu <[email-masked]>
Date: Fri, 1 Feb 2002 17:20:19 -0600

It seems isisIPRAAddress obj will give the next hop info. 

isisIPRASNPAAddress OBJECT-TYPE
         SYNTAX OSINSAddress
         MAX-ACCESS read-create
         STATUS current
         DESCRIPTION
             "The SNPA Address to which a PDU may be forwarded in
             order to reach a destination which matches this IP
             Reachable Address. This object follows the
             manualOrAutomatic behavior."
         DEFVAL { ''H }
     ::= { isisIPRAEntry 10 }

Would this be sufficient to know where to send the packets with IPRAddress?

Laura

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]]
Sent: Friday, February 01, 2002 3:12 PM
To: 'Laura Liu'
Cc: IS-IS-WG (E-mail)
Subject: RE: Questions about isis mib

Laura -

- jeff parker

---

From: Jeff Parker <[email-masked]>
Date: Mon, 4 Feb 2002 13:53:44 -0500

> ... will display the IP reachable route
> grouped by its next hop interface. ....I would prefer 
> we add an entry like isisIPRANextHop (interface name 
> or IP net address as value) and remove isisCircIndex 
> in oid index.
> 
> 
> Laura
 
Laura -
	I read this as a suggestion that we index 
the table by IP address, as that makes more sense
when walking the table.  I think this is a 
reasonable request: any objections from the list?

	There was another request to change the
index of the area address table to -NOT- use
the address, but that was really due to the
variable length format of OSI address, which
made the access routines difficult to write.
I think I could honor both requests with 
damage.

- jeff parker

---

From: Laura Liu <[email-masked]>
Date: Mon, 4 Feb 2002 14:51:59 -0600

Jeff,

Thanks for taking my suggestion.

I agree that with area address as index makes the access routine more
difficult. But I could not think of a better or  clear way for "get" command
to access a specific area address. Just my two cents.

best regards,

Laura

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]]
Sent: Monday, February 04, 2002 12:54 PM
To: 'Laura Liu'
Cc: IS-IS-WG (E-mail)
Subject: RE: [Isis-wg] RE: Questions about isis mib

Laura -

- jeff parker