Subject: Re: Re: [Isis-wg] ISIS routing on DA circuit

From: mike shand <[email-masked]>
Date: Fri, 01 Feb 2002 08:07:15 +0000

At 04:47 01/02/2002 +0000, Vijay  Nath wrote:

>mike,
>
>      when only manual route is the solution, what is need of router 
> sending those manual route to other routers.Even other routers too, have 
> manual information in their Reachable address prefix table, so it knows 
> where to send the pkt.

No they don't. They may have reachable address prefixes for OTHER prefixes, 
but not (necessarily) for THIS prefix. Manual routing is NOT used (except 
under VERY strange circumstances, and then usually only as a result of 
misconfiguration) within the core of the network. It is used to hang 
reachable addresses as leaves off the the core tree. Often an RA will only 
appear hung off one router, although sometimes they will be "multi-homed". 
But the point is that you need the propagation of the routing information 
about them to make it all work.

It may help you to think of reachable address prefixes in exactly the same 
way as IP subnets. In a sense they are "manual" routes since they are 
defined on the local interface. But you still need to propagate this 
information across the network so that other routers can route to them.

Reachable addresses on DA circuits are similar

>In sec 8.3.5
>
>"There causes this information to be included in subsequently generated 
>LSPs as described in 7.3.3.2.Routeing PDUs (LSPs and SN PDUs) shall not be 
>sent on DA circuits"
>
>Two contradictory statements in a clause.Pl. explain on this.

Not contradictory at all! The information is included in LSPs which are 
flooded, but NOT flooded over the DA circuits themselves.

         Mike

>TIA,
>V Nath
>
>
>
>
>On Fri, 01 Feb 2002 mike shand wrote :
> > At 10:18 29/01/2002 +0000, Vijay  Nath wrote:
> >
> >
> > >Hi All,
> > >
> > >   As per spec 10589, DA circuits shall not send
> > Hellos, LSPs and
> > > SNPs.Then how dynamic routing is achieved ??.
> > >or it is not possible (dynamic routing) in DA
> > circuits??.
> >
> > It's not possible. A DA circuit has a reachable address
> > prefix (aka manual
> > route) attached to it, and the circuit is only brought
> > up when there is
> > traffic to that destination. The manual route is of
> > course advertised in
> > LSPs and propagated to other routers so that they know
> > where to send the
> > traffic. It was primarily designed for use with X.25
> > SVCs(which tells you
> > how old it is), where you only want to pay for a
> > virtual circuit when you
> > have traffic.
> >
> >          Mike
> >
> >
> >
> > >TIA,
> > >V Nath
> > >
> > >_______________________________________________
> > >Isis-wg mailing list  -  [email-masked]
> > >http://external.juniper.net/mailman/listinfo/isis-wg
> >
> > _______________________________________________
> > Isis-wg mailing list  -  [email-masked]
> > http://external.juniper.net/mailman/listinfo/isis-wg
>

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Fri, 01 Feb 2002 09:03:45 -0500

It's much better to manually configure a route at one location (at
the "source" of the route) and let IS-IS propagate that route to
all routers, than to have to manually configure the same route
on all routers.

Regards,
Jeff

At 11:47 PM 1/31/2002, Vijay  Nath wrote:

>mike,
> 
>     when only manual route is the solution, what is need of router sending those manual route to other routers.Even other routers too, have manual information in their Reachable address prefix table, so it knows where to send the pkt.
>
>In sec 8.3.5
>
>"There causes this information to be included in subsequently generated LSPs as described in 7.3.3.2.Routeing PDUs (LSPs and SN PDUs) shall not be sent on DA circuits"
>

---

From: Jeff Learman <[email-masked]>
Date: Fri, 01 Feb 2002 09:23:55 -0500

Another way of looking at this is, when you do manually configure a route,
you don't want to have to manually configure that route on every router,
do you?  Of course not.  You only configure it at the point of origin,
and IS-IS disseminates it throughout the rest of the area/domain.

Unfortunately, you can't use it to flood this information across a
DA circuit.  I think the idea was that in any sizeable network, there
would be enough chatter on any link where IS-IS was run that it
wouldn't make any sense for it to be a DA circuit.  Also, when the
link connects significant portions of a network, it would normally
have enough traffic to justify a statically assigned circuit.  So,
while I said "unfortunate", I haven't seen any cases where another
method didn't work better (e.g., static routing, BGP).

Regards,
Jeff

At 03:07 AM 2/1/2002, mike shand wrote:
>No they don't. They may have reachable address prefixes for OTHER prefixes, but not (necessarily) for THIS prefix. Manual routing is NOT used (except under VERY strange circumstances, and then usually only as a result of misconfiguration) within the core of the network. It is used to hang reachable addresses as leaves off the the core tree. Often an RA will only appear hung off one router, although sometimes they will be "multi-homed". But the point is that you need the propagation of the routing information about them to make it all work.
>
>It may help you to think of reachable address prefixes in exactly the same way as IP subnets. In a sense they are "manual" routes since they are defined on the local interface. But you still need to propagate this information across the network so that other routers can route to them.
>
>Not contradictory at all! The information is included in LSPs which are flooded, but NOT flooded over the DA circuits themselves.
>
>        Mike
>
>
>
>>TIA,
>>V Nath
>>
>>
>>
>>