Subject: [Isis-wg] LSP expiration sync

From: Chaitanya Huilgol <[email-masked]>
Date: Sun, 03 Feb 2002 15:51:26 +0000

hi 
can anyone give me reason for the following:

ref10589:

7.3.16.4 LSP expiration synchronisation

b) If an LSP from S is in the database, then
1) If the received LSP is newer than the one in the database
(i.e. received LSP has higher sequence number,
or same sequence number and database LSP has nonzero
Remaining Lifetime) the IS shall:
i) overwrite the database LSP with the received
LSP, and note the time at which the zero Remaining
Lifetime LSP was received, so that after
ZeroAgeLifetime has elapsed, that LSP can be
purged from the database,

ii) set SRMflag for that LSP for all circuits,
iii) clear SSNflag for that LSP for all circuits.

...normally we 
 clear the SRM on the Received CKT
 set it on all other circuits
 set the SSN on the received circuit if the circuit is P2P.

 why are we sending the same LSP back on the same LINK it came from?
 we could have simply ack it,
 now the IS on the other side has to ack it

 thanks in advance

---------------------------------------------
Chaitanya Huilgol.
[email-masked]
---------------------------------------------

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Les Ginsberg <[email-masked]>
Date: Sun, 3 Feb 2002 11:31:25 -0800

This is another instance of a defect which was detected many years ago and
corrected, but not published outside of internal ISO circles. The corrected
text has been included in the ISO 10589:2001 Revision 2 draft and reads:

1)	If the received LSP is newer than the one in the data-base (i.e.
received LSP has higher sequence number, or same sequence number and
database LSP has non-zero Remaining Lifetime) the IS shall:

i.	Store the new LSP in the database, overwriting the existing database
LSP for that source (if any) with the received LSP.

ii.	Set SRMflag for that LSP for all circuits other then C.

iii.	Clear the SRMflag for that LSP for C.

iv.	If C is a non-broadcast circuit, set SSNflag for that LSP for C.
v.	clear SSNflag for that LSP for all circuits associated with that
linkage other than C.

(The following recorded message shall be repeated from time to time as
necessary)

I highly recommend people use the 2001 draft as an updated reference.

(ftp.cisco.com/pub/rfc/ISO/ISO10589v2-2001-07-04.pdf)

   Les

-----Original Message-----
From: Chaitanya Huilgol
To: [email-masked]
Sent: 2/3/02 7:51 AM
Subject: [Isis-wg] LSP expiration sync

hi 

ref10589:

...normally we 

 thanks in advance