Subject: [Isis-wg] Regarding draft-ietf-isis-wg-mib-07.txt

From: Koen Vermeulen <[email-masked]>
Date: Wed, 13 Feb 2002 19:34:35 +0100

Hello,

In the IS-IS mib in the 'Circuit Table' an entry called 'isisCircLocalId'

is described. It has the following description:

"An identification that can be used in protocol packets

to identify a circuit.  Values of isisCircLocalID do

not need to be unique.  They are only required to differ

on LANs where the Intermediate System is the Designated

Intermediate System."

According to the draft 'Maintaining more than 255 circuits in

IS-IS' (draft-ietf-isis-wg-255adj-02.txt), which was written some

time ago by Tony Przygienda and is already expired, the unique

circuit id for LAN Designated Intermediate Systems can be

separated between levels (this because a node can become DIS

at either level independently).

Because of this being independent of choosing a unique circuit

id between different levels, doesn't it make sense to have a

separate 'isisCircLocalId' per level? Otherwise, what local

circuit id has to be displayed in this object? The one from level 1

or the one from level 2?

Thanks,

Koen

_______________________________________________
Isis-wg mailing list - [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Wed, 13 Feb 2002 15:07:45 -0500

> [ We should have a ] 
> separate 'isisCircLocalId' per level 

> Koen 

Koen -
	I think you are right.  I have just made 
the change.  Look for it when .08 arrives.  

- jeff parker

---

From: Koen Vermeulen <[email-masked]>
Date: Thu, 14 Feb 2002 07:58:36 +0100

Hello Jeff,

Don't we also need an 'extended local circuit id' (used for
creating point-to-point '3-way handshake' ajacencies) for
point-to-point circuits?

Koen

---

From: Jeff Parker <[email-masked]>
Date: Fri, 15 Feb 2002 14:24:23 -0500

> creating point-to-point '3-way handshake' ajacencies) for

Koen - 
	Won't isisCircIfIndex meet your needs for a unique
ID?  I think at one point I had a distinct 3-way-ID thing,
but all you need is a unique ID, and IfIndex should do 
that.     

- jeff parker

---

From: Koen Vermeulen <[email-masked]>
Date: Mon, 18 Feb 2002 12:01:03 +0100

Hello Jeff,

Good idea. That will do for me.

Thanks,
Koen