Subject: RE: [Isis-wg] draft-hermelin-ext-lsp-frags-03.txt

From: "Amir Hermelin" <[email-masked]>
Date: Wed, 13 Feb 2002 12:06:37 +0200

Alex,
thanks for your comments.
As I recall from the last meeting, the "agreement" that only mode 2 is needed was only stated by three or four people, and objected by one or two (myself included) - hardly a consensus. Some folks also approached me after the meeting and stated that mode 1 is useful.
The important part is this: the draft permits implementation of only mode 2, so mode 1 is optional (as is the whole draft). You don't need extra code, knobs, bugs, etc if your customers don't want this. And since the text is already written, I don't see a good argument for removing it (the text). Of course, whether or not both modes are implemented doesn't affect people who'll want to transition to mode 2 eventually.
Does that sound good to you? Any thoughts from the group on this?

--
Amir Hermelin                    <mailto:[email-masked]>
Charlotte's Web Networks Inc.     <http://www.cwnt.com>

> -----Original Message-----
> From: Alex Zinin [mailto:[email-masked]]
> Sent: Wednesday, February 13, 2002 4:45 AM
> To: Amir Hermelin
> Cc: ISIS-wg (E-mail)
> Subject: Re: [Isis-wg] draft-hermelin-ext-lsp-frags-03.txt
> 
> 
> 
> Amir,
> 
>  If I recall correctly, it was agreed that the "stub" extension
>  does not buy us much, and we should just bite the bullet and
>  do the right thing (i.e., mode 2 in the document ;)...
> 
>  So, I've been trying to convince myself that we really need two
>  modes described in the document and the convincing part is not
>  going well ;)... I keep thinking one solution to the problem is
>  enough and seems that mode 2 provides all we need, so why don't
>  we keep it simple and have just one? Less knobs, less code, less
>  bugs, less headache...
>  
>  I try to argue that mode 1 does not require SPF changes on other
>  systems, but then again it still has the problem of 255 adjacencies
>  max, so it does not solve the issue and eventually people will need
>  mode 2 anyways... So, I guess I'm not convinced... Any ideas?
> 
> -- 
> Alex Zinin
> 
> Tuesday, February 12, 2002, 7:10:28 AM, Amir Hermelin wrote:
> 
> > Hi,
> 
> > here's a new version of the draft. The main change is the 
> merge between the methods to advertise all types of 
> link-state information in extended LSPs. Therefore Operation 
> Mode 2 changed quite a
> > bit. The newly proposed TLVs changed from two to one, and 
> its encoding changed as well. Also, some explanation were clarified.
> > This just about covers all the previous requests from the 
> wg. Please read and post your comments and suggestions.
> > Thanks.
> 
> 
> > Abstract
> 
> >    This document describes a mechanism that allows a system 
> to originate
> >    more than 256 LSP fragments, a limit set by the original 
> Intermediate
> >    System to Intermediate System (IS-IS) Routing protocol, 
> as described
> >    in ISO 10589.  This mechanism can be used in IP-only, 
> OSI-only, and
> >    dual routers.
> 
> 
> > --
> > Amir Hermelin                    <mailto:[email-masked]>
> > Charlotte's Web Networks Inc.     <http://www.cwnt.com>
> 
> 
> 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Russ White <[email-masked]>
Date: Wed, 13 Feb 2002 06:48:48 -0500 (EST)

> The important part is this: the draft permits implementation
> of only mode 2, so mode 1 is optional (as is the whole
> draft). You don't need extra code, knobs, bugs, etc if your
> customers don't want this. And since the text is already
> written, I don't see a good argument for removing it (the
> text). Of course, whether or not both modes are implemented
> doesn't affect people who'll want to transition to mode 2
> eventually.

I don't really see the usefulness of mode 1--but on the other
hand, I don't see any point in taking the text out, now that it's
written, since mode 1 is explicitly optional. I don't think many
people will actually implement the optional mode 1 unless their
customers have code that doesn't support mode 2 in their networks
by the time this little mechanism becomes necessary, just through
natural attrition.

Russ

_____________________________
[email-masked] <>< Grace Alone

---

From: Alex Zinin <[email-masked]>
Date: Wed, 13 Feb 2002 19:43:53 -0800

Amir,

> As I recall from the last meeting, the "agreement" that only mode 2 is needed
> was only stated by three or four people, and objected by one or two (myself
> included) - hardly a consensus.

You're probably right.

> Some folks also approached me after the meeting and stated that mode 1 is useful.
> The important part is this: the draft permits implementation of only mode 2, so
> mode 1 is optional (as is the whole draft).

I'm trying to understand the scenarios where mode 1 would really be
useful... I tend to think (though I might be wrong, and if so, please
correct me) that reachability information is probably not the major
contributing factor (since ISP folks use IGPs to "glue loopbacks together"
and use BGP to distribute the actual routes) and hence off-loading it
to extended LSPs would not free much space in the standard LSPs.

If this is the TE scenario, then most probably most if not all routers
in the network would experience the problem and a) all of them would need
to be SW-upgraded with either mode, and b) we can't put much more topological
info in the LSPs since we still have the same limitation for it.

Could you (or anyone who cares) please shed some light on why you
think mode 1 is useful. Not trying to say it is necessarily not
useful, just trying to understand the motivation...

> You don't need extra code, knobs, bugs, etc if your customers don't want
> this. And since the text is already written, I don't see a good argument
> for removing it (the text). Of course, whether or not both modes are
> implemented doesn't affect people who'll want to transition to mode 2 eventually.

It is surely fine with me if mode 1 happens to add real value.
If not, I guess the argument "it's already written" does not
strike me as very persuasive technically ;)

Regards,

Alex.