Subject: [Isis-wg] Questions

From: <[email-masked]>
Date: Thu, 7 Feb 2002 16:43:28 -0800

Hi,
Currently I am working on ISIS and have two questions
1. In some old mail somebody described that a lot of ISPs were using ISIS at that time (I guess it was in 99). Is it still true? Also do we know whether the use of ISIS among ISPs has increased or decreased since then?
2. I am looking for "A comparison between two routing protocols" "OSPF and IS-IS" by R. Perlman. Where can I get it from?

I don't want to start any controversies by asking for comparison. This is purely for getting more information about both protocols.
Regards
Amit
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Li <[email-masked]>
Date: Thu, 7 Feb 2002 17:10:38 -0800

| 1. In some old mail somebody described that a lot of ISPs were using
 |    ISIS at that time (I guess it was in 99). Is it still true? Also do
 |    we know whether the use of ISIS among ISPs has increased or decreased
 |    since then?

I am unaware of any serious studies.  My (admittedly biased ;-) gut says
that there are many ISPs using IS-IS, and that the percentage is on the
rise, mostly thanks to the demise of ISPs not using IS-IS.  I also believe
that there is a large correlation between use of IS-IS and size of ISP.

 | 2. I am looking for "A comparison between two routing protocols" "OSPF
 |    and IS-IS" by R. Perlman. Where can I get it from?
 | 
 | I don't want to start any controversies by asking for comparison. This
 | is purely for getting more information about both protocols.

That's probably the most controversial question that you could have asked.
;-)

In order to stem the tide, let me put on my WG co-chair hat on and ask that
people NOT start this discussion, please.

In the dusty corners of my memory, I recall that someone did do a scholarly
paper on the subject.  If someone has a pointer to that, could you please
post it?  Thanks.

Tony

---

From: John Harper <[email-masked]>
Date: Thu, 07 Feb 2002 17:22:53 -0800

>paper on the subject.  If someone has a pointer to that, could you please

Alex Zinin did a preso a couple of years ago. Although Alex is a self-confessed
OSPF person, the preso was pretty well balanced and the bottom line was
that, rather like which way the water spins around the plughole, the dominant
factor is what you are doing already. (I think it was Alex anyway). (I happen
to share Tony's views on this but my job rather obliges me to be pragmatic).

         John

---

From: Dave Katz <[email-masked]>
Date: Thu, 7 Feb 2002 19:42:31 -0800 (PST)

I did one at NANOG in June of 2000;  the slides are in the NANOG archives
I think.

   X-Sender: [email-masked]
   From: John Harper <[email-masked]>
   Cc: <[email-masked]>, <[email-masked]>
   Content-Type: text/plain; charset="us-ascii"; format=flowed
   Sender: [email-masked]
   X-BeenThere: [email-masked]
   X-Mailman-Version: 2.0rc1
   Precedence: bulk
   List-Help: <mailto:[email-masked]?subject=help>
   List-Post: <mailto:[email-masked]>
   List-Subscribe: <http://external.juniper.net/mailman/listinfo/isis-wg>,
	   <mailto:[email-masked]?subject=subscribe>
   List-Id: IETF IS-IS working group <isis-wg.external.juniper.net>
   List-Unsubscribe: <http://external.juniper.net/mailman/listinfo/isis-wg>,
	   <mailto:[email-masked]?subject=unsubscribe>
   List-Archive: <http://external.juniper.net/pipermail/isis-wg/>
   Date: Thu, 07 Feb 2002 17:22:53 -0800

	    John

---

From: Alan Hannan <[email-masked]>
Date: Thu, 7 Feb 2002 22:11:26 -0800

> 2. I am looking for "A comparison between two routing protocols" "OSPF and IS-IS" by R. Perlman. Where can I get it from?

  http://citeseer.nj.nec.com/context/50541/0

  R. Perlman. A comparison between two routing protocols: OSPF and IS-IS. IEEE Networks.vol.5,Sept. 1991, pp. 18-24.

  I suspect you could get this from IEEE archives, but I haven't checked.  I think they're scanning
  stuff in from that far back....

  (from google http://www.google.com/search?sourceid=navclient&q=A+comparison+between+two+routing+protocols+Radia+Perlman)

  -a

---

From: Naiming Shen <[email-masked]>
Date: Thu, 07 Feb 2002 23:00:01 -0800

checkout this nanog thread, but it seems author giving lots of
credit to ospf:

http://www.merit.edu/mail.archives/nanog/1999-01/msg00012.html

cheers.
- Naiming