Subject: RE: [Isis-wg] draft-ietf-isis-auto-encap-03

From: Philip Christian <[email-masked]>
Date: Thu, 10 Apr 2003 11:00:18 +0100 (BST)

That's another thing I don't understand.  If you don't
have any up neighbour, and you don't put yourself in
LAN ID of your Hellos, then what do you put as LAN ID
?  A random number ?

Philip

 --- mike shand <[email-masked]> wrote: > Ah yes. I
forgot we added that. But you can still
> get strange connectivity 
> when you have pieces of ethernet cable that are too
> long etc. etc.
> 
>          Mike
> 
> At 05:34 10/04/2003 -0400, Jonnala, Nagi wrote:
> 
> 
> >At 10:06 10/04/2003 +0100, Philip Christian wrote:
> > >It is not clear in my mind why non-DISs echo the
> DIS
> > >LAN ID back onto the LAN if everyone is ignoring
> it
> > >anyway.  It is almost as if 10589 was architected
> for
> > >some sort of checking, but then it got forgotten
> or
> > >something.  As no-one checks the LAN ID from
> non-DISs,
> > >then why does a non-DIS even bother copying the
> LAN ID
> > >of the DIS into its own Hellos?  okay it might be
> > >useful if you network is broken and you have a
> LAN
> > >analyser, but I don't think that that is what the
> > >original authors had in mind...
> >
> >Exactly so. I seem to recall that it was thought it
> might be a useful
> >diagnostic tool. You could tell without having to
> use "management" what
> >everyone's view of the DIS was. There was a
> particular concern about broken
> >receivers, which of course cause you to elect
> yourself DIS, since you can't
> >hear anyone else.
> >
> ><Nagi>
> >I thought broken receivers do not have any DIS
> since the election process
> >needs atleast one "UP" neighbor. Am I wrong?
> >
> >thanks
> >Nagi.
> >
> >
> >_______________________________________________
> >Isis-wg mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/isis-wg
>  

__________________________________________________
Yahoo! Plus
For a better Internet experience
http://www.yahoo.co.uk/btoffer
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: mike shand <[email-masked]>
Date: Thu, 10 Apr 2003 11:13:54 +0100

>LAN ID of your Hellos, then what do you put as LAN ID

No you DO put your own LAN ID in there to begin with. Even if you have no 
neighbors. However what you don't do is start sending CSNPs and generating 
a pseudonode (and, worse, purging any "old" pseudonode), etc.

see ISO/IEC 10589:1992 8.4.1 (a)

---

From: Philip Christian <[email-masked]>
Date: Fri, 11 Apr 2003 10:41:48 +0100 (BST)

Would you guys prefer this text over what is there
now?
Personally I think something should be there given the
slight deviance from 10589, even if it seems obvious
to some of us.  Philip

5.2. LAN ID 
    
   ISO/IEC 10589 [6] states than an IS shall take the
LAN ID from the 
   neighbour that it considers to be the DIS and use
it as the LAN ID
   in its own Hello PDUs.  If there are two or more
DISs on a LAN then
   an automatically encapsulating IS will be able to
use only one of
   these LAN IDs in its own Hellos.

   Clearly if an automatically encapsulating IS is
elected DIS by
   either OSI, IPv4 or IPv6 ISs then it MUST use its
own LAN ID in
   Hello PDUs as per ISO/IEC 10589.

   If an automatically encapsulating IS is elected DIS
by no subset of
   the LAN and if there are multiple DISs on the LAN
with which the
   automatically encapsulating IS has up adjacencies,
then an
   implementer will need to decide which LAN ID the
automatically
   encapsulating IS puts in its Hello PDUs.  Whichever
LAN ID is
   chosen, other ISs on the LAN SHOULD in any case
ignore it if they do
   not consider the automatically encapsulating IS to
be DIS.