Subject: [Isis-wg] Use of isisSysReceiveLSPBufferSize

From: Jeff Parker <[email-masked]>
Date: Tue, 29 Apr 2003 09:38:55 -0400

> I guess, Les trying to point out isisSysReceiveLSPBufferSize 
> is more of
> related to MTU, not how you store in the system. Even I am 
> with Les, it
> should more of MTU related constraint.

Swami -

There are a number of variables here.  MTU is one.
Originating size is another.  But Rx buffer size is
a third.  They all play a part.

Is a system with 1492 byte LSP buffers compliant?
Is it complaint if it is deployed in a network
with only 4K MTU links?  I think the answer is 
yes in both cases.  The MTU does not tell you 
what the isisSysReceiveLSPBufferSize is.  

> If it is related to storage problem, why let the user 
> to configure that variable?

I'm suggesting that you can read it.  You may be 
able to set it, but you might not be able to.  

Most people get to read then number of valves in their
car's engine.  It doesn't mean they can configure this
parameter, much less change it while they are driving.  

> It can be hard coded with a value, whichever 
> vendor feels good for its implementation.

Exactly.  Just like the car makers do.  But they
still let us find out what that value is.  

> I feel, isisSysReceiveLSPBufferSize should be 
> maintained in the MIB with description 
> pointing out more of MTU constraint.
> 
> Thanks,
> Swami

If the issue is the text of the description 
clause, I will be happy to accept suggestions
on how to clear up the meaning.  

- jeff parker
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 29 Apr 2003 13:52:28 -0400

> From: Les Ginsberg [mailto:[email-masked]]
> Sent: Tuesday, April 29, 2003 1:37 PM
> To: Jeff Parker
> Subject: RE: [Isis-wg] RE: Use of isisSysReceiveLSPBufferSize
> 
> I haven't been following the MIB as closely lately. 

It isn't something everyone scans over breakfast, is it?

> In looking at it today I see:
> 
>     isisSysReceiveLSPBufferSize OBJECT-TYPE
>          SYNTAX Unsigned16TC (1492..65535)
> 
>      isisOriginatingBufferSize OBJECT-TYPE
>          SYNTAX Integer32 (1..2147483647)
>
> So why is one variable 16 bits and the other 32 bits?? 

Thanks.  It now reads

    isisOriginatingBufferSize OBJECT-TYPE
        SYNTAX Integer32 (512..65535)
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "Holds the size of isisSysOrigLSPBuffSize
             advertised by peer in TLV."
    ::= { isisNotificationEntry 9 }

- jeff