Subject: [Isis-wg] Wide Counters

From: "Parker, Jeff" <[email-masked]>
Date: Tue, 14 Jun 2005 17:25:18 -0400

I am reviewing comments that came in during last call.

------ Forwarded Message
> From: Adrian Farrel <[email-masked]>
> Reply-To: <[email-masked]>
> Date: Tue, 24 May 2005 11:45:24 +0100
> To: <[email-masked]>
> Cc: <[email-masked]>
> Subject: Re: [Isis-wg] WG Last Call on IS-IS MIB.
  
> 11. Wide counters
> 
>   Are you happy with running the hello and packet counters at
>   only 32 bits? Woth considering how often they would wrap in
>   normal (default timer) processing. Then note that they would
>   be used to diagnose misconfiguration of timers when packet
>   thrash might occur.

------ End of Forwarded Message

It is easy for me to make this change, but I'd like to ask other
implementors what they think pro and con about such a change (to change all
32 bit counters to 64 bit counters)

- jeff parker

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Jonathan Harrison" <[email-masked]>
Date: Wed, 15 Jun 2005 11:56:22 +0100

Jeff,

The isisSystemCounter and isisCircuitCounter should definitely stay as 32-bit counters, as these count rare events (for most of these, any change indicates a configuration issue).

My view is that the packet counts are also fine as 32-bit counters.  If I were using the counters to check for timer misconfiguration, I would expect to check the values initially, and then check the values again a short time later.  The main requirement for the size of the counter is that it should give an unambiguous count of packets received over this short period.  For example, if the reading is 1000 on the first check, and 1001 on the second check shortly afterwards, the network manager should be able to be confident that 1 packet has been received and the counter hasn't wrapped in-between the two checks.

At the fairly high rate for steady state IS-IS of 10 packets a second, it will be 13.6 years before the 32-bit counter wraps.  Even a packet thrash with, say, 10,000 packets a second would only cause the counters to wrap after 5 days - which ought to be long enough to check the MIB a couple of times.

So I'm happy with the counters as they are now.
Jon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Parker, Jeff
Sent: 14 June 2005 22:25
To: ISIS WG
Subject: [Isis-wg] Wide Counters

------ Forwarded Message

- jeff parker