Subject: RE: [Isis-wg] Computation of areas in MT-ISIS

From: "Pudiyapura, Ajeer" <[email-masked]>
Date: Wed, 12 Oct 2005 15:28:48 -0700

Mike, Les.

  Thanks for the clarification. I agree that there is no routing between
N1 and N5 in the IPv6 topology because L1 routing is partitioned in area
A2. This would be the expected behavior in the absence of partition
repair.

		      N3(L2-only)
		     /  \
		    /    \
 		   /      \
		  /        \
		 /          \
	(L1L2)N2 		N4(L1L2)
		|	       |  
		|	       |
	      |	  	 | 
	      |		 |
	  	N1(L1)	N5(L1)

Area Configurations:

 N1: A1
 N2: A1, A2
 N3: Any subset of {A1,A2,A3}
 N4: A2, A3
 N5: A3

  But if you consider the same topology for IPv4 topology, without
partition repair, routing will work between N1 and N5 for the following
reason.

1. N2 will compute Union Area Address set = {A1, A2}
2. N4 will compute Union Area Address set = {A2, A3}
3. Both N2 and N4 will set attached bit set in their L1 LSPs.
4. Both N1 and N5 will install default routes.
5. Routing will work smoothly between N1 and N5 using the backbone. Is
there any mechanism to prevent this?

  So apparently, there is some discrepancy in the behavior between
default routing and MT routing for the same topology. Is this true? And
is this documented? 

Thanks
-Ajeer Pudiyapura

-----Original Message-----
From: mike shand [mailto:[email-masked]] 
Sent: Wednesday, October 12, 2005 12:51 AM
To: Les Ginsberg (ginsberg)
Cc: Les Ginsberg (ginsberg); Pudiyapura, Ajeer; Naiming Shen (naiming);
May Lu; [email-masked]
Subject: RE: [Isis-wg] Computation of areas in MT-ISIS

A few comments inline below.

At 08:27 12/10/2005, Les Ginsberg \(ginsberg\) wrote:
>One addition below.
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
>Behalf
> > Of Les Ginsberg (ginsberg)
> > Sent: Tuesday, October 11, 2005 11:45 PM
> > To: Pudiyapura, Ajeer; Naiming Shen (naiming); May Lu
> > Cc: [email-masked]
> > Subject: RE: [Isis-wg] Computation of areas in MT-ISIS
> >
> > Ajeer -
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
On
> > Behalf
> > > Of Pudiyapura, Ajeer
> > > Sent: Tuesday, October 11, 2005 12:07 PM
> > > To: Naiming Shen (naiming); May Lu
> > > Cc: [email-masked]
> > > Subject: RE: [Isis-wg] Computation of areas in MT-ISIS
> > >
> > > Naiming,
> > >
> > >    Please consider the following MT-ISIS network example:
> > >
> > >
> > >                   N3(L2-only)
> > >                  /  \
> > >                 /    \
> > >             V6/      \V6
> > >               /        \
> > >             /          \
> > >     (L1L2)N2 -------- N4(L1L2)
> > >             |       V4     |
> > >             |              |
> > >     V4/V6|          | V4/V6
> > >           |         |
> > >             N1(L1)  N5(L1)
> > >
> > > Area Configurations:
> > >
> > >  N1: A1
> > >  N2: A1, A2
> > >  N4: A2, A3
> > >  N5: A3
> > >
> >
> > You don't specify the area address(es) for N3, which make it a bit
> > difficult to follow your example, but I am assuming it is in the set
>of
> > (A1,A2,A3). If not, please explain where I have marked "**N3**"
below.
> >
> > As this does not seem to be key to your question, I continue to
>comment
> > below.
> >
> >
> > > The default (IPv4) Topology of the above network would be:
> > >
> > >
> > >     (L1L2)N2 -------- N4(L1L2)
> > >             |              |
> > >             |              |
> > >           |            |
> > >           |         |
> > >             N1(L1)  N5(L1)
> > >
> > >
> > > Here:
> > > 1. Each adjacent router is configured with at least one common
area
> > id,
> > > hence forming an L1 adjacency.

While such "pairwise" assignment of area addresses is technically
possible, 
it is strongly deprecated because it can lead to unexpected area 
configurations during failure conditions even in standard ISO/IEC 10589.

The original design of allowing multiple area addresses per area was to 
allow for area splitting and merging (and decnet PhaseIV  addressing).
It 
was expected that ALL routers within an area would have the same set of 
area addresses, except during split/merge operations, and even then that

only one area address would be added or deleted at a time, so preserving

the transitive property."

> > > 2. Both N2 and N4 computes Union Area Address set, which would be
> > > {A1,A2,A3}
> > > 3. Neither N2 nor N4 would set the attached bit in L1 LSP since
the
> > > entire network acts as an L1 cloud.
> > > 4. Neither N1 nor N5 would install a default route.
> > > 5. Since N1 would get L1 LSP from N5 and vice versa, routing
between
> > > them would work fine, as expected.
> > >
> > >
> > >  Now please consider the IPv6 Topology of the above network:
> > >
> > >
> > >                   N3(L2-only)
> > >                  /  \
> > >                 /    \
> > >                /      \
> > >               /        \
> > >             /          \
> > >     (L1L2)N2                N4(L1L2)
> > >             |              |
> > >             |              |
> > >           |         |
> > >           |         |
> > >             N1(L1)  N5(L1)
> > >
> > >
> > > 6. Since both N2 and N4 would use the Union Area Address set from
> > > Default topology, it will be {A1,A2,A3} as in step 2 above.
> > > 7. Neither N2 nor N4 would set the attached bit in their L1 LSPs
> > because
> > > no more Areas are reachable through L2 routing than the Union Area
> > > Address set.
> >
> > **N3**
> > I therefore conclude N3 has area addresses in the set of (A1,A2,A3).
> > Which means there is no reason to set ATT bit.

Agreed.

> >
> > > 8. Neither N1 nor N5 would install a default route.
> > > 9. Since N1 in this case would not get L1 LSPs from N5 (and vice
> > versa)
> > > routing will not be available between N1 and N5, even though there
>is
> > a
> > > path between them that uses the L2 connectivity.
> > >
> >
> > How do you conclude that N1 would get no L1 LSPs from N5 (and vice
> > versa)??
> >
> > Even if you were to use the optimized flooding rules described in
> > Section 10 of the draft, in your example the only LSPs N4 could
choose
> > to "not flood" to N2 would be an LSP from N5 which only had V6 TLVs
in
> > it. It would still be obligated to flood any LSPs from N5 with any
V4
> > info in them.
> >
> > Of course if there is no link between N2 and N4 in any topology,
then
> > the IPv4 topology is partitioned - and no attempt to support
partition
> > repair is defined in the draft (See Section 7).
>
>It should also be noted that the IPv6 (not v4) topology is partitioned
>at L1 as currently defined, regardless of the presence or absence of a
>V4 enabled link between N2 and N4.

Exactly.

         Mike

>   Les
>
> >
> > That said, I think the optimized flooding rules are not worth the
> > trouble - and require additional logic than what is specified in the
> > draft e.g. special CSNPs to be generated for neighbors on which
> > optimized flooding is attempted and LSP #0 must always be flooded
(at
> > least to L1L2 neighbors). I have suggested to Naiming that Section
10
>be
> > removed.
> >
> >    Les
> >
> >
> > > Please correct me if I am wrong.
> > > Thanks
> > > -Ajeer Pudiyapura
> > >
> > >
> > > -----Original Message-----
> > > From: Naiming Shen [mailto:[email-masked]]
> > > Sent: Monday, October 10, 2005 11:34 AM
> > > To: May Lu
> > > Cc: Pudiyapura, Ajeer; [email-masked]
> > > Subject: Re: [Isis-wg] Computation of areas in MT-ISIS
> > >
> > > May,
> > >
> > > May Lu said the following on 10/10/2005 09:20 AM:
> > > > If a MT-ISIS node runs different protocols on its interfaces,
how
> > > > does the node broadcast its union address in L2 LSP?
> > > >
> > > > See configuration below:
> > > >
> > > > Node1(area 01, 04) ----  Node2 (area 01, 02) --- Node3 (area 02,
>05)
> > > > IP                               Ipv6
> > > >
> > > > All three nodes are MT-ISIS nodes. Node2 is connected to Node1
>with
> > > > IP protocol. Node2 and Node3 are connected with IPV6 protocol.
>Node2
> > > > IP union addresses should be 01, 02 and 04. Node2 Ipv6 union
> > > > addresses should be 01, 02 and 05. Is this correct?
> > > >
> > > > If the union address does not consider the protocol, in the
> > following
> > > > case, there is a problem:
> > > >
> > > > Node1 (area 01)  ------ Node2 (area 01) ----- Node3 (area 01,
02)
>IP
> > > > Ipv6 All three nodes are MT-ISIS nodes. Node1 and Node2 are
> > connected
> > > > via IP protocol. Node2 and Node3 are connected via Ipv6
protocol.
> > > > Node1 is a level1 only node. Node2's union addresses are 01 and
>02.
> > > > Node2 will set attached bit on IP protocol and Node1 will set
the
>IP
> > > > default route towards Node2. Actually Node1 and Node2 are using
>the
> > > > same area address in IP network and Node1 shouldn't set default
> > route
> > > > to Node2.
> > > >
> > >
> > > But don't you already have problem even if Node3 is IP(not IPv6) ?
> > > or do we already have problem if they are not MT-ISIS nodes?  If
we
> > > are playing with IP/IPv6, why should we assigning different areas
to
> > > those nodes ?
> > >
> > > thanks.
> > > - Naiming
> > >
> > > > Thanks, - Xiaomei Lu
> > > >
> > > >
> > > > -----Original Message----- From:  Naiming Shen
> > > > [mailto:[email-masked]] Sent:  Saturday, October 08, 2005
12:01
> > > AM
> > > > To:       Pudiyapura, Ajeer Cc:   [email-masked] Subject:
>Re:
> > > [Isis-wg]
> > > > Computation of areas in MT-ISIS
> > > >
> > > >
> > > >
> > > > Pudiyapura, Ajeer said the following on 10/06/2005 11:09 AM:
> > > >
> > > >> Hi.
> > > >>
> > > >>
> > > >>
> > > >> I have the following questions:
> > > >>
> > > >>
> > > >>
> > > >> 1)       How is Area Address Computation (section 7.2.11 of
>ISO/IEC
> > > >>  10589) done in Multi Topology IS-IS? Are they computed
>separately
> > > >> for each topology?
> > > >>
> > > >
> > > >
> > > > No. MT-ISIS node keeps the same system-id, areas, levels,
>hostname,
> > > > etc. there is no change to any of that.
> > > >
> > > > thanks. - Naiming
> > > >
> > > >
> > > >> 2)       If so, how is the resulting set advertised in L2 LSPs
> > > >> since there is no mechanism to do this per topology?
> > > >>
> > > >>
> > > >>
> > > >> Thanks
> > > >>
> > > >> -Ajeer Pudiyapura
> > > >>
> > > >>
> > > >>
> > > >> ============================================================
The
> > > >> information contained in this message may be privileged and
> > > >> confidential and protected from disclosure. If the reader of
this
> > > >> message is not the intended recipient, or an employee or agent
> > > >> responsible for delivering this message to the intended
>recipient,
> > > >> you are hereby notified that any reproduction, dissemination or
> > > >> distribution of this communication is strictly prohibited. If
you
> > > >> have received this communication in error, please notify us
> > > >> immediately by replying to the message and deleting it from
your
> > > >> computer. Thank you. Tellabs
> > > >> ============================================================
> > > >>
> > > >>
> > > >>
> > >
> >
>-----------------------------------------------------------------------
-
> > > >>
> > > >>
> > > >> _______________________________________________ Isis-wg mailing
> > > >> list [email-masked]
> > > >> https://www1.ietf.org/mailman/listinfo/isis-wg
> > > >
> > > >
> > > > _______________________________________________ Isis-wg mailing
>list
> > > > [email-masked] https://www1.ietf.org/mailman/listinfo/isis-wg
> > > ============================================================
> > > The information contained in this message may be privileged
> > > and confidential and protected from disclosure. If the reader
> > > of this message is not the intended recipient, or an employee
> > > or agent responsible for delivering this message to the
> > > intended recipient, you are hereby notified that any reproduction,
> > > dissemination or distribution of this communication is strictly
> > > prohibited. If you have received this communication in error,
> > > please notify us immediately by replying to the message and
> > > deleting it from your computer. Thank you. Tellabs
> > > ============================================================
> > >
> > > _______________________________________________
> > > Isis-wg mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/isis-wg
> >
> > _______________________________________________
> > Isis-wg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/isis-wg
>
>_______________________________________________
>Isis-wg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/isis-wg
============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Wed, 12 Oct 2005 16:08:02 -0700

Ajeer,

Pudiyapura, Ajeer said the following on 10/12/2005 03:28 PM:
> default routing and MT routing for the same topology. Is this true?

Not really.
The MT TLV has the A bit. For the most simple approach, the IPv6 topology
just set the ATT bit as it would for the default topology(if the default
and IPv6 topology has the same links and adjacencies), unless there is
some other reasons not to do so. An implementation can also configure
routemaps, ACLs to match and set the ATT bit for diff topologies or
unconditaionally set or unset ATT bit.

thanks.
- Naiming

> And is this documented?