Subject: RE: [Isis-wg] Final WG LC draft-ietf-isis-wg-mib-23.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 12 Oct 2005 17:14:58 +0200

I was already happy Jeff.
This makes it even better.

Thanks

Bert

> -----Original Message-----
> From: Parker, Jeff [mailto:[email-masked]]
> Sent: Wednesday, October 12, 2005 17:00
> To: Wijnen, Bert (Bert)
> Cc: C. M. Heard; [email-masked]
> Subject: Re: [Isis-wg] Final WG LC draft-ietf-isis-wg-mib-23.txt 
> 
> 
> On 10/12/05 10:37 AM, "Wijnen, Bert (Bert)" 
> <[email-masked]> wrote:
> 
> > In rev 23 I am happy to see THis:
> > 
> >     IsisSystemID ::= TEXTUAL-CONVENTION
> >         STATUS current
> >         DESCRIPTION
> >             "A system ID."
> >         SYNTAX OCTET STRING (SIZE(6))
> > 
> > changed into this:
> > 
> >     IsisSystemID ::= TEXTUAL-CONVENTION
> >         STATUS current
> >         DESCRIPTION
> >             "The ID for an Intermediate System.  This should
> >              be unique within a network, and is included
> >              in all PDUs originated by an Intermediate System.
> >>            Some implementations may automatically assign
> >>            values and not permit an SNMP write, while
> >>            others may require the value to be set manually.
> >              The protocol does not place any meanings upon
> >              the bits, other than using ordering to break
> >              ties in electing a Designated IS on a LAN."
> >         REFERENCE "{ISIS.aoi systemId (119)}"
> >         SYNTAX OCTET STRING (SIZE(6))
> > 
> > But the 3 lines marked with > seem not part of the TC.
> > It depends on where /how the TC is used. Some may use it
> > for a read-only object and then those 3 lines mean nothing
> > or may be confusing. The 3 lines belong in a DESCRIPTION clause
> > where the TC is used as a SYNTAX in an OBJECT-TYPE and whihc
> > has possibly a MAX-ACCESS of read-write or read-create.
> > I am not hung up on this though.
> 
> Removed
> 
> > When I see this
> >     IsisLinkStatePDUID ::= TEXTUAL-CONVENTION
> >         STATUS current
> >         DESCRIPTION
> >             "A Link State PDU Identifier."
> >         SYNTAX OCTET STRING (SIZE(8))
> > 
> > changed into:
> >    IsisLinkStatePDUID ::= TEXTUAL-CONVENTION
> >        STATUS current
> >        DESCRIPTION
> >            "A Link State PDU Identifier formed from the
> >             6 byte System ID, a one byte PseudoNode ID,
> >             and a one byte LSP fragment number."
> >        REFERENCE "{See section 9.8 of ISO 10589}"
> >        SYNTAX OCTET STRING (SIZE(8))
> > Then I like that. But it would have been even more helpful
> > if you had been more explicit on the sequence of th 6, 1 nad 1 byte.
> > Maybe you imply that that is the sequence, but that is not 
> very clear.
> > Again, I can live with it.
> 
>             "The 8 byte Link State PDU (LSP) ID,
>              consisting of the 6 byte SystemID of the
>              originating IS, a one byte PseudoNode ID
>              which is 0 unless the LSP represents the
>              topology of a LAN, and one byte LSP
>              fragment number that are issued in sequence,
>              starting with 0.  Non zero PseudoNode IDs
>              need to be unique to the IS, but need not
>              match the IfIndex."
> 
> This probably says too much about the PseudoNode ID.  I believe it be
> wordsmithed further: the byte really only needs to be unique at that
> -level-.
> 
> > When I see:
> >         Configured values will survive an agent reboot."
> > I am happy. Better/clearer might have been:
> >         Configured values MUST survive an agent reboot."
> > assuming that is what the WG wants.
> > I am not hung up on it. Besides, I see that Mike suggested the
> > "will survive" so I should not keep nitpicking further.
> > 
> > Ready to go, as far as I am concerned!
> > Thanks Jeff!
> > 
> > Bert
> 
> myrmidon:~/MIB jeff$ grep survive mib
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Dynamically created rows MUST survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically created rows MUST survive an agent reboot.
>              Dynamically created rows MUST survive an agent reboot.
>              Dynamically learned rows do not survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Dynamically created rows MUST survive an agent reboot."
>              Configured values MUST survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically created rows MUST survive an agent reboot."
>              Dynamically created rows MUST survive an agent reboot.
>              Dynamically learned rows will not survive an
>              Dynamically learned rows will not survive an
>  
> myrmidon:~/MIB jeff$ grep survive mib | grep -v MUST
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows do not survive an agent reboot."
>              Dynamically learned rows will not survive an
>              Dynamically learned rows will not survive an
> 
>  
> Other issues?
> 
> - jdp
> 

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Christian Hopps <[email-masked]>
Date: Wed, 12 Oct 2005 16:14:03 -0700

Jeff,

I suggest that we make these changes if necessary (sounds like not)  
as editorial in the RFC process. I *really* don't want to publish a  
new draft and then go through *another* WG LC.

Thanks,
Chris.

---

From: "C. M. Heard" <[email-masked]>
Date: Wed, 12 Oct 2005 16:58:26 -0700 (PDT)

> new draft and then go through *another* WG LC.

I am not sure that the proposed changes -- especially the relatively
important one shown below, deleting the inappropriate text from the
IsisSystemID DESCRIPTION clause -- would be allowed by the RFC
Editor without consultation with the IESG/cognizant ADs.  It's
possible to put this is in as an IESG note, but it's really better
to have the I-D that is sent to the RFC Editor be as close as
possible to what you want to publish.

In any case it does not seem like full 2-week WG last call should be
needed for these changes ... seems to me it should suffice to have a
short (e.g. 48-hour) "does anybody object to these changes" last
call.  The document will after all still be going through IETF last
call before it gets to the IESG.

//cmh