Subject: [Isis-wg] Re: [Fwd: [mpls] WG Last Call on draft-ietf-mpls-number-0-bw-te-lsps-02.txt]

From: JP Vasseur <[email-masked]>
Date: Wed, 29 Nov 2006 15:13:43 -0500

Hi Acee,

Thanks for your comments -

As soon as you ACK that the changes address your comments I'll post  
the updated ID.

see in line,

On Oct 10, 2006, at 5:03 PM, Acee Lindem wrote:

> JP,
>
> One more comment - Please write the document so that it can
> apply to OSPFv3 TE as well. The existing draft can be an informative
> reference (draft-ietf-ospf-ospfv3-traffic-07.txt)
>

OK. Text added:

OLD:

    The Number of 0-bandwidth TE LSP(s) sub-TLV is OPTIONAL and MUST
    appear at most once within the Link TLV (Type 2) that is itself
    carried within the Traffic Engineering LSA specified in  
[RFC3630]. If
    a second instance of the Number of 0-bandwidth TE LSP(s) sub-TLV is
    present, the receiving system MUST only process the first  
instance of
    the sub-TLV.

NEW:

    The Number of 0-bandwidth TE LSP(s) sub-TLV is OPTIONAL and MUST
    appear at most once within the Link TLV (Type 2) that is itself
    carried within the OSPFv2 Traffic Engineering LSA specified in  
[RFC3630]
    or the OSPFv3 Intra-Area-TE LSA (function code 10) defined in  
draft-ietf-ospf-ospfv3-traffic.
    If a second instance of the Number of 0-bandwidth TE LSP(s) sub- 
TLV is
    present, the receiving system MUST only process the first  
instance of
    the sub-TLV.

see below

> Thanks,
> Acee
>
> Acee Lindem wrote:
>> I've reviewed the subject document and don't have any comments on it
>> from the perspective of the OSPF WG. However, I have the following
>> comments as a member of the routing directorate (copying JP):
>>
>>   1. Why the cryptic sub-TLV name? RFC 3630 doesn't define short
>>       cryptic names for sub-TLVs so I don't really see why you've  
>> defined
>>       NB-0-BW-LSP? Why not just call it the Unconstrained LSP  
>> Count sub-TLV?
>>       Or at least come up with a better short name :^),  e.g. BW-0- 
>> LSP-CNT.

Yes, no problem. I renamed it ;-)

Number of 0-bandwidth TE LSP(s) sub-TLV.

>>   2. How did you arrive at 19 for the suggested value for the sub- 
>> TLV type? I checked
>>       IANA and 18 is the next available. I may be missing a  
>> document though.

As documented, 18 looks the next one available (when I first wrote  
the ID I vaguely remember having seen another ID using 18 but I'm not  
quite sure). Let's propose 18 and will see with IANA.

>>   3. Do  you want to reserve a value (e.g., 0xffffffff) to  
>> indicate no unconstrained
>>       LSPs are to traverse a given link.

Let's just use the value 0.

>>   4. Nit - in section 4, replace "OSPF LSA" with "OSPF LSAs" and  
>> "ISIS LSP"
>>       with "ISIS LSPs".

Thanks.

Cheers.

JP.

>>
>> Thanks,
>> Acee
>>              David Ward wrote:
>>> Do you want our WG to review? Co-Last Call (as we have for other  
>>> WG that
>>> affect our protocol)? Do you have a desired date for end of last  
>>> call from
>>> the IGPs?
>>>
>>> Thanks
>>>
>>> -DWard
>>>
>>>
>>> On 9/4/06 5:01 AM, "Loa Andersson" <[email-masked]> wrote:
>>>
>>>
>>>> All,
>>>>
>>>> the MPLS working group want to notify the ospf and is-s
>>>> working groups, as well as the routing directorate that
>>>> we are currently doing a wg last call on
>>>> draft-ietf-mpls-number-0-bw-te-lsps-02.txt.
>>>>
>>>> Loa and George
>>>>
>>>>
>>>> -------- Original Message --------
>>>> Subject: [mpls] WG Last Call on draft-ietf-mpls-number-0-bw-te- 
>>>> lsps-02.txt
>>>> Date: Fri, 01 Sep 2006 10:08:10 +0200
>>>> From: Loa Andersson <[email-masked]>
>>>> Organization: Acreo AB
>>>> To: [email-masked]
>>>>
>>>> Working Group,
>>>>
>>>> this initiates a two week working group last call on
>>>> draft-ietf-mpls-number-0-bw-te-lsps-02.txt
>>>>
>>>> The wg last call ends on September 17.
>>>>
>>>> Please send comments to the working group mailing list and/or
>>>> the working group chairs.
>>>>
>>>> /Loa and George
>>>>
>>>
>>>
>>
>>
>

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Acee Lindem <[email-masked]>
Date: Thu, 30 Nov 2006 11:56:44 -0500

Hi JP,
Looks good. See one question below.

JP Vasseur wrote:
>    carried within the Traffic Engineering LSA specified in [RFC3630]. If
>    present, the receiving system MUST only process the first instance of
>    the sub-TLV.
>
>
> NEW:
>
>    If a second instance of the Number of 0-bandwidth TE LSP(s) sub-TLV is
>    present, the receiving system MUST only process the first instance of
>    the sub-TLV.
>
> see below
>
>> Thanks,
>> Acee
>>
>> Acee Lindem wrote:
>>>       NB-0-BW-LSP? Why not just call it the Unconstrained LSP Count 
>>> sub-TLV?
>>>       Or at least come up with a better short name :^),  e.g. 
>>> BW-0-LSP-CNT.
>
>>>   2. How did you arrive at 19 for the suggested value for the 
>>> sub-TLV type? I checked
>>>       IANA and 18 is the next available. I may be missing a document 
>>> though.
>
> As documented, 18 looks the next one available (when I first wrote the 
> ID I vaguely remember having seen another ID using 18 but I'm not 
>>>   3. Do  you want to reserve a value (e.g., 0xffffffff) to indicate 
>>> no unconstrained
Since this is the current number wouldn't there be ambiguity between 
designating there
are currently no BW-0 LSPs traversing this link and no BW-0 LSPs are allowed
to traverse this linke?

Thanks,
Acee

>>>> Do you want our WG to review? Co-Last Call (as we have for other WG 
>>>> that
>>>>> Subject: [mpls] WG Last Call on

---

From: JP Vasseur <[email-masked]>
Date: Thu, 30 Nov 2006 14:29:49 -0500

Hi Acee,

On Nov 30, 2006, at 11:56 AM, Acee Lindem wrote:

>> As soon as you ACK that the changes address your comments I'll  
>> post the updated ID.
>>
>> see in line,
>>
>>>>       cryptic names for sub-TLVs so I don't really see why  
>>>> you've defined
>> the ID I vaguely remember having seen another ID using 18 but I'm  
>> not quite sure). Let's propose 18 and will see with IANA.
>>
> Since this is the current number wouldn't there be ambiguity  
> between designating there

Other attributes such as affinity should be used to not allows 0-bw  
TE LSP to traverse a specific link. This TLV is only used to report  
the number of such TE LSPs traversing the link.

Thanks.

JP.

>>>>> Do you want our WG to review? Co-Last Call (as we have for  
>>>>> other WG that
>>>>> affect our protocol)? Do you have a desired date for end of  
>>>>> last call from
>>>>> the IGPs?
>>>>>
>>>>> Thanks
>>>>>
>>>>> -DWard
>>>>>
>>>>>

---

From: Acee Lindem <[email-masked]>
Date: Thu, 30 Nov 2006 14:32:32 -0500

JP - Sounds good.
Acee
JP Vasseur wrote:
> Other attributes such as affinity should be used to not allows 0-bw TE 
> LSP to traverse a specific link. This TLV is only used to report the 
> number of such TE LSPs traversing the link.
>
> Thanks.
>
> JP.
>
>>
>> Thanks,
>> Acee
>>
>>>

---

From: JP Vasseur <[email-masked]>
Date: Thu, 30 Nov 2006 14:34:21 -0500

OK thanks so I'll now post the revised version.

Cheers.

JP.

On Nov 30, 2006, at 2:32 PM, Acee Lindem wrote:

>>>>    carried within the OSPFv2 Traffic Engineering LSA specified  
>>>> in [RFC3630]
>>>> As documented, 18 looks the next one available (when I first  
>>>> wrote the ID I vaguely remember having seen another ID using 18  
>>>> but I'm not quite sure). Let's propose 18 and will see with IANA.
>>>>
>> Other attributes such as affinity should be used to not allows 0- 
>> bw TE LSP to traverse a specific link. This TLV is only used to  
>> report the number of such TE LSPs traversing the link.
>>
>> Thanks.
>>
>> JP.
>>
>>>
>>> Thanks,
>>> Acee
>>>
>>>>
>>>>>>   4. Nit - in section 4, replace "OSPF LSA" with "OSPF LSAs"  
>>>>>> and "ISIS LSP"
>>>>>>       with "ISIS LSPs".
>>>>
>>>> Thanks.
>>>>
>>>> Cheers.
>>>>
>>>> JP.
>>>>
>>>>>>
>>>>>> Thanks,
>>>>>> Acee
>>>>>>              David Ward wrote:
>>>>>>>> Subject: [mpls] WG Last Call on draft-ietf-mpls-number-0-bw- 
>>>>>>>> te-lsps-02.txt