Subject: Re: [iucg] mixing different direction labels within same domain

From: JFC Morfin <[email-masked]>
Date: Mon, 08 Aug 2011 14:57:08 +0200

Dear Abdulrahman, dear Slim,

we try to consolidate all the post-IDNA2008 points that are now to be 
addressed at Internet technology level (including those with an 
impact on the protocols but belonging to the architectural level that 
we plan to consolidate further on). This mostly concerns inputs from 
IANA, IAB, IETF/WG/IDNA2008, IETF/WG/PRECIS, ICANN/WG/VIP, UNICODE, 
IUCG, IUTF, ALFA, ITU, John Klensin, Andrew Sullivan, Paul Hoffman, 
Vint Cerf, etc. The target is to help them all to consistently work 
in being aware of all the issues and in using the same terms with the 
same meaning.

The current version of this compilation is at 
http://iucg.org/wiki/IDNS_Common_Glossary.

Once we have compiled all the potocol level issues we will propose 
all the concerned parties to consolidate them into a common Draft to 
everyone's benefit and for us to complete the design of an ML-DNS 
prototype implementation, i.e. a multi-layer, multi-prupose 
(intertechnology), multi-orthotypography IDNA2008 
conformant  front-end of the IDNA2008 stabilised Internet DNS.

Among the points we noted there is the Bidi issue 
http://iucg.org/wiki/Bidi_discussion that you raised on 2/14/2010. 
Harald's response is at the IDNA2008 level (on the Internet side). 
The question now is to know how to address it at the use level: I 
would be interested in a description of the problem which could 
permit a solution at protocol, use or architural level.

I thank you if you can help us.
jfc

At 22:55 07/08/2011, Harald Alvestrand wrote:
>On 06/21/11 07:55, Abdulrahman I. ALGhadir wrote:
>>Dear all,
>>I am just wondering whenever it is permitted or not to have this case:
>><r2l chars><num1>.<num2>.<etc ..>
>This particular case has all labels legal, but the overall display 
>name will display very oddly (as noted). The oddity is caused by our 
>inability to mandate whole-domain tests, as described in the RFC.
>
>It is logical for the administrator of <etc ..> to forbid 
>registration of leading-numeric labels if it anticipates R2L labels 
>at the next level down, and it is logical for application writers to 
>simply reject such names because they are going to confuse the users 
>(much in the spirit of Firefox' refusal to do mixed-script names), 
>but the RFC does not require them to do so.
>
>>As you know in case r2l labels the display will be like this
>><etc..>.<num1>.<num2><r2l chars>
>I think the display will depend on the direction of <etc> and 
>whether it is in an RTL context or an LTR context, but I'm still not 
>confident of my ability to execute the BIDI algorithm in my head.
>>As you see both of them have different display order which 
>>isn't  the same as network order.
>>And I know it is mentioned in the RFC
>>
>>
>>
>>    Several stronger statements were considered and rejected, because
>>
>>    they seem to be impossible to fulfill within the constraints of the
>>
>>    Unicode bidirectional algorithm.
>>And one of the statement is
>>
>>   o  The sequence of labels should be consistent with network order.
>>       This proved impossible -- a domain name consisting of the labels
>>       in network order) L1.R2.R3.L4 will be displayed as L1.R3.R2.L4 in
>>       an LTR context.  (In an RTL context, it will be displayed as
>>       L4.R3.R2.L1)
>>
>>
>>
>>
>>And I have tried two implemented tools (well I don't know if they 
>>follow the RFC fully or not).
>>
>>
>><http://unicode.org/cldr/utility/idna.jsp?a=%D8%B1%D8%A7%D8%A6%D8%AF888.999.%D8%A7%D9%84%D8%B3%D8%B9%D9%88%D8%AF%D9%8A%D8%A9#notes>http://unicode.org/cldr/utility/idna.jsp?a=%D8%B1%D8%A7%D8%A6%D8%AF888.999.%D8%A7%D9%84%D8%B3%D8%B9%D9%88%D8%AF%D9%8A%D8%A9#notes
>>
>>http://mct.verisign-grs.com/conversiontool/convertServlet?input=%D8%B1%D8%A7%D8%A6%D8%AF888.999.%D8%A7%D9%84%D8%B3%D8%B9%D9%88%D8%AF%D9%8A%D8%A9&type=UTF8
>>
>>
>>Abdulrahman,
>>
>>
>>
>>
>>_______________________________________________
>>Idna-update mailing list
>><mailto:[email-masked]>[email-masked]
>>http://www.alvestrand.no/mailman/listinfo/idna-update
>
>_______________________________________________
>Idna-update mailing list
>[email-masked]
>http://www.alvestrand.no/mailman/listinfo/idna-update

---

From: "Abdulrahman I. ALGhadir" <[email-masked]>
Date: Wed, 10 Aug 2011 08:44:54 +0000

Dear JFC,
Thank you for letting me in this I'll try to gather most of pointed issues in IDNA and I'll try to send to you later hopefully!

But have ever seen this proposed solution on improving the display of URI?
http://www.unicode.org/review/pri185/
This solution has been pended waiting for any feeds on it so that they can publish it, and I think this solution will solve most of confusing problems in the display, yet it'll give us defending points on removing some limitations  in the IDNA (hopefully!).

Abdulrahman,

From: [email-masked] [mailto:[email-masked]] On Behalf Of JFC Morfin
Sent: 8/Aug/2011 3:57 PM
To: Abdulrahman I. ALGhadir; Slim Amamou
Cc: [email-masked]; [email-masked] work; [email-masked]; Arabic Scripts IDNA
Subject: Re: mixing different direction labels within same domain

we try to consolidate all the post-IDNA2008 points that are now to be addressed at Internet technology level (including those with an impact on the protocols but belonging to the architectural level that we plan to consolidate further on). This mostly concerns inputs from IANA, IAB, IETF/WG/IDNA2008, IETF/WG/PRECIS, ICANN/WG/VIP, UNICODE, IUCG, IUTF, ALFA, ITU, John Klensin, Andrew Sullivan, Paul Hoffman, Vint Cerf, etc. The target is to help them all to consistently work in being aware of all the issues and in using the same terms with the same meaning.

The current version of this compilation is at http://iucg.org/wiki/IDNS_Common_Glossary.

Once we have compiled all the potocol level issues we will propose all the concerned parties to consolidate them into a common Draft to everyone's benefit and for us to complete the design of an ML-DNS prototype implementation, i.e. a multi-layer, multi-prupose (intertechnology), multi-orthotypography IDNA2008 conformant  front-end of the IDNA2008 stabilised Internet DNS.

Among the points we noted there is the Bidi issue http://iucg.org/wiki/Bidi_discussion that you raised on 2/14/2010. Harald's response is at the IDNA2008 level (on the Internet side). The question now is to know how to address it at the use level: I would be interested in a description of the problem which could permit a solution at protocol, use or architural level.

Dear all,
I am just wondering whenever it is permitted or not to have this case:
<r2l chars><num1>.<num2>.<etc ..>
This particular case has all labels legal, but the overall display name will display very oddly (as noted). The oddity is caused by our inability to mandate whole-domain tests, as described in the RFC.

It is logical for the administrator of <etc ..> to forbid registration of leading-numeric labels if it anticipates R2L labels at the next level down, and it is logical for application writers to simply reject such names because they are going to confuse the users (much in the spirit of Firefox' refusal to do mixed-script names), but the RFC does not require them to do so.

As you know in case r2l labels the display will be like this
<etc..>.<num1>.<num2><r2l chars>
I think the display will depend on the direction of <etc> and whether it is in an RTL context or an LTR context, but I'm still not confident of my ability to execute the BIDI algorithm in my head.

As you see both of them have different display order which isn?t  the same as network order.
And I know it is mentioned in the RFC

   Several stronger statements were considered and

rejected, because

   they seem to be impossible to fulfill within the

constraints of

the

   Unicode bidirectional

algorithm.

And I have tried two implemented tools (well I don?t know if they follow the RFC fully or not).

http://unicode.org/cldr/utility/idna.jsp?a=%D8%B1%D8%A7%D8%A6%D8%AF888.999.%D8%A7%D9%84%D8%B3%D8%B9%D9%88%D8%AF%D9%8A%D8%A9#notes

Abdulrahman,

Idna-update mailing list

[email-masked]<mailto:[email-masked]>

<http://www.alvestrand.no/mailman/listinfo/idna-update>

-----------------------------------------------------------------------------------
Disclaimer:
This message and its attachment, if any, are confidential and may contain legally
privileged information. If you are not the intended recipient, please contact the
sender immediately and delete this message and its attachment, if any, from your
system. You should not copy this message or disclose its contents to any other
person or use it for any purpose. Statements and opinions expressed in this e-mail
are those of the sender, and do not necessarily reflect those of the Communications
and Information Technology Commission (CITC). CITC accepts no liability for damage
caused by this email.

---

From: JFC Morfin <[email-masked]>
Date: Thu, 11 Aug 2011 03:18:29 +0200

At 10:44 10/08/2011, Abdulrahman I. ALGhadir wrote:
>Content-Language: en-US
>Content-Type: multipart/alternative;
> 
>boundary="_000_E393942FC3AB7F4C9C50F559E9E4E45F13AE6518ry2mail2citcgov_"
>
>Dear JFC,
>Thank you for letting me in this I'll try to gather most of pointed 
>issues in IDNA and I'll try to send to you later hopefully!
>
><http://www.unicode.org/review/pri185/>http://www.unicode.org/review/pri185/
>This solution has been pended waiting for any feeds on it so that 
>they can publish it, and I think this solution will solve most of 
>confusing problems in the display, yet it'll give us defending 
>points on removing some limitations  in the IDNA (hopefully!).
>
>Abdulrahman,

Dear Abdulrahman,

Thank you for your annouced help. I am looking for your contribution 
to add to our wiki consolidation.

At this stage I am just trying to compile the post IDNA2008 problems 
people raise in various areas. And possibly the terminology which can 
be adequate to describe/address them among network operations and use 
oriented WGs and NGOs (ICANN, IETF, ITU, IUTF). This is for all these 
people to come with a simple, consistent, stable way to address them 
at protocol level and then be able to discuss with Unicode what they 
may need from them. In focusing first on the roots of the problems in 
his are, one may help others to identify a similar problem they were 
not aware until now.

Thank you for quoting pri185: from it I am going to try to extract 
the problems they raise; in the way it impacts us. However, I am not 
familiar with Bidi. So I would prefer specialists to summarize the 
difficulties they meet and Unicode discusses. So, ICANN and other 
people might understand better, decide if they also are impacted and 
how to handle a possible difficulty they would have identified this 
way in their own bailiwick.

Best!
jfc