Subject: [jose] POLL: Add other than pre-shared MAC key

From: "Jim Schaad" <[email-masked]>
Date: Fri, 17 Aug 2012 16:36:32 +0930

<CHAIR>

If you voted at the face-2-face please do not vote again.  If you want to
provide comments please change the title from POLL to DISCUSS.

Should we add the ability to have a randomly generated MAC key protected by
a different key?  The other key could be either a pre-shared symmetric key
or a public key.

Room vote:  3 yes, 5 no, 3 discuss

---

From: Dick Hardt <[email-masked]>
Date: Fri, 17 Aug 2012 08:02:27 -0700

DISCUSS

On Aug 17, 2012, at 12:06 AM, Jim Schaad wrote:

> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: "Manger, James H" <[email-masked]>
Date: Sun, 19 Aug 2012 21:40:35 +1000

MAC-with-per-message-key is a reasonable mode, regardless of whether or not it is important enough to make the initial cut for JOSE. It would look more like JWE then JWS.
It highlights that we really need to drop this JWE/JWS dichotomy, and have a single JOSE message that supports any number of modes (at least plain, signed, MACed, encrypted, key-exchange + encrypt; perhaps key-exchange + MAC, compressed, plus whatever the future needs).

--
James Manger

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jim Schaad
> Sent: Friday, 17 August 2012 5:07 PM
> To: [email-masked]
> Subject: [jose] POLL: Add other than pre-shared MAC key
> 
> <CHAIR>
> 
> If you voted at the face-2-face please do not vote again.  If you want
> to provide comments please change the title from POLL to DISCUSS.
> 
> Should we add the ability to have a randomly generated MAC key
> protected by a different key?  The other key could be either a pre-
> shared symmetric key or a public key.
> 
> 
>

---

From: <[email-masked]>
Date: Mon, 27 Aug 2012 10:18:26 +0200

NO

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Friday, August 17, 2012 9:07 AM
To: [email-masked]
Subject: [jose] POLL: Add other than pre-shared MAC key

<CHAIR>

If you voted at the face-2-face please do not vote again.  If you want to provide comments please change the title from POLL to DISCUSS.

Should we add the ability to have a randomly generated MAC key protected by a different key?  The other key could be either a pre-shared symmetric key or a public key.

---

From: "HAYASHI, Tatsuya" <[email-masked]>
Date: Tue, 28 Aug 2012 15:54:46 +0900

NO

-- 
HAYASHI, Tatsuya
Lepidum Co. Ltd.

---

From: Brian Campbell <[email-masked]>
Date: Tue, 28 Aug 2012 09:02:34 -0600

no

---

From: Torsten Lodderstedt <[email-masked]>
Date: Tue, 28 Aug 2012 18:50:30 +0200

NO

---

From: Edmund Jay <[email-masked]>
Date: Tue, 28 Aug 2012 10:48:49 -0700 (PDT)

NO

________________________________
From: Jim Schaad <[email-masked]>
To: [email-masked]
Sent: Fri, August 17, 2012 12:08:06 AM
Subject: [jose] POLL: Add other than pre-shared MAC key

<CHAIR>

---

From: Chuck Mortimore <[email-masked]>
Date: Tue, 28 Aug 2012 12:14:38 -0700

NO
On Aug 28, 2012, at 8:02 AM, Brian Campbell wrote:

no

On Fri, Aug 17, 2012 at 1:06 AM, Jim Schaad <[email-masked]<mailto:[email-masked]>> wrote:
<CHAIR>

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose

---

From: nov matake <[email-masked]>
Date: Wed, 29 Aug 2012 13:46:15 +0900

NO

---

From: prateek mishra <[email-masked]>
Date: Wed, 29 Aug 2012 09:04:43 -0400

YES, this is a significant use-case, wherein a server is provisioned 
with a certificate and clients generate a symmetric key
(per session or transaction). Said key is encrypted using the server 
public key and used for integrity protection and
encryption during the session/transaction.

---

From: John Bradley <[email-masked]>
Date: Wed, 29 Aug 2012 11:14:13 -0400

I think there is some confusion.

We support this for encryption + integrity now.

I think the question in the room was should we add a way in JWE to HMAC the message body with a key that is sent in the same message that is signed by another key.

I think the questions to the list are not entirely consistent with what was discussed in the room in some cases.

Perhaps others can clarify if my recollection is wrong.

John B.

On 2012-08-29, at 9:04 AM, prateek mishra <[email-masked]> wrote:

> YES, this is a significant use-case, wherein a server is provisioned with a certificate and clients generate a symmetric key
> (per session or transaction). Said key is encrypted using the server public key and used for integrity protection and