Subject: [jose] POLL: Criticality of understanding header fields

From: "Jim Schaad" <[email-masked]>
Date: Fri, 17 Aug 2012 16:35:19 +0930

<CHAIR>

If you voted at the face-2-face please do not vote again.  If you want to
provide comments please change the title from POLL to DISCUSS.

What should be the criticality of header fields as defined by the core
specification?

YES - all headers fields are critical
NO - all header fields are non-critical
MAYBE - header fields are marked critical or criticality should be defined
by the application
DISCUSS - need to talk more

Room vote:  2 yes, 0 no, 4 maybe, 3 discuss

---

From: "Manger, James H" <[email-masked]>
Date: Sun, 19 Aug 2012 21:21:01 +1000

NO -- all *unrecognized* fields are non-critical

(lots of fields are critical, but based on each type of message. Eg for a JOSE message that does key agreement then encryption, the "agr":<key-agreement-alg> and "enc":<AEAD-alg> fields are critical)

--
James Manger

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jim Schaad
> Sent: Friday, 17 August 2012 5:05 PM
> To: [email-masked]
> Subject: [jose] POLL: Criticality of understanding header fields
> 
> <CHAIR>
> 
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: <[email-masked]>
Date: Mon, 27 Aug 2012 10:16:19 +0200

YES

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Friday, August 17, 2012 9:05 AM
To: [email-masked]
Subject: [jose] POLL: Criticality of understanding header fields

<CHAIR>

If you voted at the face-2-face please do not vote again.  If you want to provide comments please change the title from POLL to DISCUSS.

What should be the criticality of header fields as defined by the core specification?

YES - all headers fields are critical
NO - all header fields are non-critical
MAYBE - header fields are marked critical or criticality should be defined by the application DISCUSS - need to talk more

---

From: "HAYASHI, Tatsuya" <[email-masked]>
Date: Tue, 28 Aug 2012 15:55:07 +0900

YES

-- 
HAYASHI, Tatsuya
Lepidum Co. Ltd.

---

From: Torsten Lodderstedt <[email-masked]>
Date: Tue, 28 Aug 2012 18:51:44 +0200

YES

---

From: Edmund Jay <[email-masked]>
Date: Tue, 28 Aug 2012 10:47:07 -0700 (PDT)

YES

________________________________
From: Jim Schaad <[email-masked]>
To: [email-masked]
Sent: Fri, August 17, 2012 12:07:40 AM
Subject: [jose] POLL: Criticality of understanding header fields

<CHAIR>

---

From: Chuck Mortimore <[email-masked]>
Date: Tue, 28 Aug 2012 12:13:23 -0700

YES

---

From: nov matake <[email-masked]>
Date: Wed, 29 Aug 2012 13:45:26 +0900

YES