Subject: Re: [jose] #4: Impossible to separate wrapped key from encrypted data

From: "jose issue tracker" <[email-masked]>
Date: Mon, 25 Feb 2013 19:19:52 -0000

#4: Impossible to separate wrapped key from encrypted data

Comment (by [email-masked]):

 4.6 Dierct Encryption with a Shared Symmetric Key of JWA seems to be
 addressing the needs in this ticket.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-jose-json-web-
  [email-masked]        |  [email-masked]
     Type:  defect       |      Status:  new
 Priority:  major        |   Milestone:
Component:  json-web-    |     Version:
  encryption             |  Resolution:
 Severity:  Active WG    |
  Document               |
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/jose/trac/ticket/4#comment:1>
jose <http://tools.ietf.org/jose/>

---

From: Richard Barnes <[email-masked]>
Date: Mon, 25 Feb 2013 16:36:24 -0500

That still doesn't address how the key is transmitted.

A solution for encryption requires (1) a way to encrypt a JWE under a given
key, and (2) a way to transmit wrapped keys.  You are proposing a solution
to (1), with some mechanism for (2).

JWE already solves (1) and (2), just not in a way that the keys are
separable. Because the keys are included under the JWE integrity check, the
JWE integrity check value will be different for each wrapped key.

Your answer already concedes that there is no benefit to including the key
under the JWE integrity check.  We should just make it that way with JWE in
general and the issue will be resolved.

On Mon, Feb 25, 2013 at 2:19 PM, jose issue tracker <
[email-masked]> wrote:

> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>

---

From: Mike Jones <[email-masked]>
Date: Tue, 26 Feb 2013 01:09:13 +0000

Actually, I think Matt's draft-miller-jose-jwe-protected-jwk, written in response to our new proposed charter item (8), exactly addresses how the key is transmitted for separable keys.

                                                            -- Mike

From: Richard Barnes [mailto:[email-masked]]
Sent: Monday, February 25, 2013 1:36 PM
To: jose issue tracker
Cc: [email-masked]; Nat Sakimura; [email-masked]
Subject: Re: [jose] #4: Impossible to separate wrapped key from encrypted data

A solution for encryption requires (1) a way to encrypt a JWE under a given key, and (2) a way to transmit wrapped keys.  You are proposing a solution to (1), with some mechanism for (2).

JWE already solves (1) and (2), just not in a way that the keys are separable. Because the keys are included under the JWE integrity check, the JWE integrity check value will be different for each wrapped key.

Your answer already concedes that there is no benefit to including the key under the JWE integrity check.  We should just make it that way with JWE in general and the issue will be resolved.

On Mon, Feb 25, 2013 at 2:19 PM, jose issue tracker <[email-masked]<mailto:[email-masked]>> wrote:
#4: Impossible to separate wrapped key from encrypted data

Comment (by [email-masked]<mailto:[email-masked]>):

  [email-masked]<mailto:[email-masked]>        |  [email-masked]<mailto:[email-masked]>

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose

---

From: Richard Barnes <[email-masked]>
Date: Tue, 26 Feb 2013 14:15:59 -0500

So the proposal is to have two different ways of transmitting protected
keys, one for JWE and one separate?  Why?

On Mon, Feb 25, 2013 at 8:09 PM, Mike Jones <[email-masked]>wrote:

>  Actually, I think Matt’s draft-miller-jose-jwe-protected-jwk, written in
> response to our new proposed charter item (8), exactly addresses how the
> key is transmitted for separable keys.****
>
> ** **
>
>                                                             -- Mike****
>
> ** **
>
> *From:* Richard Barnes [mailto:[email-masked]]
> *Sent:* Monday, February 25, 2013 1:36 PM
> *To:* jose issue tracker
> *Cc:* [email-masked]; Nat Sakimura;
> [email-masked]
> *Subject:* Re: [jose] #4: Impossible to separate wrapped key from
> encrypted data****
>
> ** **
>
> That still doesn't address how the key is transmitted.****
>
> ** **
>
> A solution for encryption requires (1) a way to encrypt a JWE under a
> given key, and (2) a way to transmit wrapped keys.  You are proposing a
> solution to (1), with some mechanism for (2).****
>
> ** **
>
> JWE integrity check value will be different for each wrapped key.****
>
> ** **
>
> general and the issue will be resolved.****
>
> ** **
>
>  ****
>
> ** **
>
> ** **
>
> [email-masked]> wrote:****
>
> https://www.ietf.org/mailman/listinfo/jose****
>
> ** **
>