Subject: [jose] One JOSE toolkit...

From: Brian Campbell <[email-masked]>
Date: Wed, 13 Mar 2013 09:30:04 -0400

Parteek expressed concern about a perceived lack of available JOSE
implementations at the WG meeting this morning. A few people, including
myself, chimed in about implementations.

I've not publicized it previously because it's still very much a work in
progress but I've got an open source implementation, which is available at:
https://bitbucket.org/b_c/jose4j

There's no JWE support yet (I've been procrastinating doing that and
waiting for JWE to stabilize more) but it should currently provide a fairly
complete implementation of JWS and JWK (and the relevant pieces of JWA).

---

From: Nat Sakimura <[email-masked]>
Date: Wed, 13 Mar 2013 23:40:26 +0900

Here is another one:

https://github.com/nov/json-jwt/tree/master/lib/json

2013/3/13 Brian Campbell <[email-masked]>:
> There's no JWE support yet (I've been procrastinating doing that and waiting
> for JWE to stabilize more) but it should currently provide a fairly complete
> implementation of JWS and JWK (and the relevant pieces of JWA).
>
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>

-- 
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/
@_nat_en

---

From: Justin Richer <[email-masked]>
Date: Wed, 13 Mar 2013 11:04:37 -0400

I'm not sure if it got brought up this morning, but there's also the 
Nimbus library:

https://bitbucket.org/nimbusds/nimbus-jose-jwt

  -- Justin

---

From: Axel Nennker <[email-masked]>
Date: Wed, 13 Mar 2013 17:16:09 +0100

And of course the library which ich the basis for the Nimbus library:
http://jsoncrypto.org/

2013/3/13 Justin Richer <[email-masked]>

> https://bitbucket.org/**nimbusds/nimbus-jose-jwt<https://bitbucket.org/nimbusds/nimbus-jose-jwt>
>
>  -- Justin
>
>
>> https://github.com/nov/json-**jwt/tree/master/lib/json<https://github.com/nov/json-jwt/tree/master/lib/json>
>>
>>> https://bitbucket.org/b_c/**jose4j <https://bitbucket.org/b_c/jose4j>
>>>
>>> waiting
>>> ______________________________**_________________
>>> jose mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/**listinfo/jose<https://www.ietf.org/mailman/listinfo/jose>
>>>
>>>
>>
>>
> ______________________________**_________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/jose<https://www.ietf.org/mailman/listinfo/jose>
>

---

From: Axel Nennker <[email-masked]>
Date: Wed, 13 Mar 2013 17:17:50 +0100

s/ich/is/

-Axel

stupid autocorrection

2013/3/13 Axel Nennker <[email-masked]>

---

From: Dick Hardt <[email-masked]>
Date: Wed, 13 Mar 2013 09:28:05 -0700

I have the makings of a nodejs library that is currently embedded in another open source project that I will spin out once the spec goal posts hold still if the Mozilla people don't make their code an npm module.

-- Dick

On Mar 13, 2013, at 8:04 AM, Justin Richer <[email-masked]> wrote:

> I'm not sure if it got brought up this morning, but there's also the Nimbus library:
>

---

From: Brian Campbell <[email-masked]>
Date: Wed, 13 Mar 2013 13:09:42 -0400

There's also jsjws, which bills itself as a "pure JavaScript implementation
of JSON Web Signature and JWS-JS"

http://kjur.github.com/jsjws/

I have no association with it but I have done some basic JWS introp testing
between it and my own jose4j lib.

On Wed, Mar 13, 2013 at 12:28 PM, Dick Hardt <[email-masked]> wrote:

> I have the makings of a nodejs library that is currently embedded in
> another open source project that I will spin out once the spec goal posts
> hold still if the Mozilla people don't make their code an npm module.
>
> -- Dick
>

---

From: Ryo Ito <[email-masked]>
Date: Thu, 14 Mar 2013 02:51:41 +0900

There is perl implementation of JWT.

https://metacpan.org/module/JSON::WebToken

-- 
====================
Ryo Ito
Email : [email-masked]
====================