Subject: [jose] Naming of JWK key_ops values for wrap and unwrap

From: Mark Watson <[email-masked]>
Date: Wed, 5 Feb 2014 15:01:00 -0800

All,

Since JWK key_ops was added primarily to accurately represent WebCrypto
keys, would it be possible to amend the values for "wrap" and "unwrap" to
"wrapKey" and "unwrapKey" to align with the WebCrypto naming ?

...Mark

---

From: Mike Jones <[email-masked]>
Date: Wed, 5 Feb 2014 23:06:02 +0000

I believe that we should make this change, since it aligns with the WebCrypto editor's draft at https://dvcs.w3.org/hg/webcrypto-api/raw-file/tip/spec/Overview.html.  I believe that the names "wrap" and "unwrap" came from the older draft at http://www.w3.org/TR/WebCryptoAPI/.

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Mark Watson
Sent: Wednesday, February 05, 2014 3:01 PM
To: [email-masked]
Subject: [jose] Naming of JWK key_ops values for wrap and unwrap

All,

Since JWK key_ops was added primarily to accurately represent WebCrypto keys, would it be possible to amend the values for "wrap" and "unwrap" to "wrapKey" and "unwrapKey" to align with the WebCrypto naming ?

...Mark

---

From: John Bradley <[email-masked]>
Date: Wed, 5 Feb 2014 20:07:33 -0300

I am fine with that.

On Feb 5, 2014, at 8:06 PM, Mike Jones <[email-masked]> wrote:

> I believe that we should make this change, since it aligns with the WebCrypto editor’s draft at https://dvcs.w3.org/hg/webcrypto-api/raw-file/tip/spec/Overview.html.  I believe that the names “wrap” and “unwrap” came from the older draft athttp://www.w3.org/TR/WebCryptoAPI/.
>  
>                                                             -- Mike
>  
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: Brian Campbell <[email-masked]>
Date: Wed, 5 Feb 2014 16:10:33 -0700

+1
On Feb 5, 2014 4:06 PM, "Mike Jones" <[email-masked]> wrote:

>  I believe that we should make this change, since it aligns with the
> WebCrypto editor's draft at
> https://dvcs.w3.org/hg/webcrypto-api/raw-file/tip/spec/Overview.html.  I
> believe that the names "wrap" and "unwrap" came from the older draft at
> http://www.w3.org/TR/WebCryptoAPI/.
>
>
>
>                                                             -- Mike
>
>
>
> *From:* jose [mailto:[email-masked]] *On Behalf Of *Mark Watson
> *Sent:* Wednesday, February 05, 2014 3:01 PM
> *To:* [email-masked]
> *Subject:* [jose] Naming of JWK key_ops values for wrap and unwrap
>
>
>
> All,
>
>
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 5 Feb 2014 18:36:50 -0500

+1

---

From: Mike Jones <[email-masked]>
Date: Sat, 15 Feb 2014 01:47:39 +0000

These changes have been applied in the -21 JOSE drafts.

                                                -- Mike

All,

...Mark