Subject: Re: [jose] COSE / JOSE at IETF 97 Hackathon

From: Vladimir Dzhuvinov <[email-masked]>
Date: Fri, 11 Nov 2016 09:09:34 +0200

Hi Jim,

I'm pleased to hear this is being worked on. Is this an open source project?

Cheers,

Vladimir

On 10 Nov 2016 22:37, Jim Schaad <[email-masked]> wrote:

I have the signature operations running and am working on the ECDH operations.  I have the code (from COSE) but have not yet generate any test vectors.

I validate the signature examples in the RFC that Ilari wrote for JOSE.

Jim

From: jose [mailto:[email-masked]] On Behalf Of Vladimir Dzhuvinov
Sent: Friday, November 11, 2016 5:22 AM
To: [email-masked]
Subject: Re: [jose] COSE / JOSE at IETF 97 Hackathon

Have there been any thoughts about implementing the new CFRG curves?

On 09/11/16 22:22, Matt Miller wrote:

Hello all,

Jim and I will be at a table working on various things related to COSE

and JOSE.  We have a couple of broad goals and projects noted on the

[WIKI] we'd like to make progress on.

If you're interested in working on some crypto formats, or wanted to

learn how to use this stuff, feel free join us.

_______________________________________________

jose mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/jose

--

Vladimir Dzhuvinov

---

From: Jim Schaad <[email-masked]>
Date: Fri, 11 Nov 2016 17:20:34 +0900

The answer is yes, but I am going to throw some heavy caveats at you first.

1.      It was written mostly to do a sanity check and to validate the examples in the JOSE documents.  As such it is not necessarily very solid and it has some holes that I am in the middle of finding as I expand how it is checking the test cases.

2.      It is probably not written in a language that you want to be using as it is in C#.

3.      There are lots of other libraries that you can find on github that probably do a better job and in a language which you want to use.

4.      It is tightly bound in some respects to my COSE implementation

5.      I am probably going to be moving the repository it is in over the weekend as part of the code sprint in order to get Travis to do builds and tests for me.

That said it can be found at https://github.com/cose-wg/cose-implementations in the csharp directory.

Jim

From: jose [mailto:[email-masked]] On Behalf Of Vladimir Dzhuvinov
Sent: Friday, November 11, 2016 4:10 PM
To: Jim Schaad <[email-masked]>
Cc: [email-masked]
Subject: Re: [jose] COSE / JOSE at IETF 97 Hackathon

Hi Jim, 

On 10 Nov 2016 22:37, Jim Schaad <[email-masked] <mailto:[email-masked]> > wrote:

Jim

From: jose [mailto:[email-masked]] On Behalf Of Vladimir Dzhuvinov
Sent: Friday, November 11, 2016 5:22 AM
To: [email-masked] <mailto:[email-masked]> 
Subject: Re: [jose] COSE / JOSE at IETF 97 Hackathon

Hello all,

_______________________________________________
jose mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/jose

-- 
Vladimir Dzhuvinov