Subject: [Justfont] font top-level type: Outlines "in various combinations"

From: Chris Lilley <[email-masked]>
Date: Sat, 6 Feb 2016 15:02:32 +0100

Hello,

Open issue #2 concerns this rather wooly phrase:

  TTF, CFF or SVG outlines can be present in various combinations in
  the same font file, therefore, multiple values for the same optional
  parameter may be defined.
  https://github.com/svgeesus/ietf-justfont/issues/2

First, I assume this means multiple values for the parameter, not
specifying the parameter multiple times which I have not seen in
Internet Media type parameters.

Second, specified how exactly? comma separated list?  space separated?

Thirdly, is this vagueness for forwards compat in case someday CFF and
TTF are allowed in the same font file? There are (in OFF v.3) only
four valid combinations:

    TTF
    CFF
    TTF, SVG
    CFF, SVG

It seems clearer to say either TTF or CFF, optionally followed by SVG.

Do I need to give a whole grammar along the lines of
(wsp? comma wsp*) | wsp+

Alternatively, no commas and just whitespace separated (one or more
0x20). What do people think.

-- 
Best regards,
 Chris  Lilley
 Technical Director, W3C Interaction Domain

---

From: "Levantovsky, Vladimir" <[email-masked]>
Date: Mon, 8 Feb 2016 04:38:48 +0000

Hi Chris, all,

Although it is unusual to see TTF and CFF outlines present in the same font file, I don't think it is prohibited by the current OFF specification. While the "version" field" only offers a single choice of values for either TTF or CFF outlines having both types be present is a possibility. I'd suggest that we should say that multiple values of the parameter in question can be defined as a comma-separated list of values without imposing any particular restrictions on what these values can be or how different types of outlines can be combined. Whether there is a valid use case to have only SVG outlines present, or if there is (is not) a use case that combines TTF and CFF outlines shouldn't be decided here, I'd rather allow the parameter to reflect what the font data provides.

Thank you,
Vlad

-----Original Message-----
From: Justfont [mailto:[email-masked]] On Behalf Of Chris Lilley
Sent: Saturday, February 06, 2016 9:03 AM
To: [email-masked]
Subject: [Justfont] font top-level type: Outlines "in various combinations"

Hello,

First, I assume this means multiple values for the parameter, not specifying the parameter multiple times which I have not seen in Internet Media type parameters.

Thirdly, is this vagueness for forwards compat in case someday CFF and TTF are allowed in the same font file? There are (in OFF v.3) only four valid combinations:

    TTF
    CFF
    TTF, SVG
    CFF, SVG

Do I need to give a whole grammar along the lines of (wsp? comma wsp*) | wsp+

Alternatively, no commas and just whitespace separated (one or more 0x20). What do people think.

_______________________________________________
Justfont mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/justfont

---

From: Chris Lilley <[email-masked]>
Date: Tue, 9 Feb 2016 23:08:36 +0100

Hello Vlad,

Monday, February 8, 2016, 5:38:48 AM, you wrote:

> I'd suggest that we should say that
> multiple values of the parameter in question can be defined as a
> comma-separated list of values without imposing any particular
> restrictions on what these values can be or how different types of
> outlines can be combined. Whether there is a valid use case to have
> only SVG outlines present, or if there is (is not) a use case that
> combines TTF and CFF outlines shouldn't be decided here, I'd rather
> allow the parameter to reflect what the font data provides.

A good point.

I have added wording to that effect:

  "this optional parameter is a list containing one or more items, separated by
   commas, with optional whitespace. Order in the list is not significant."

Does that sound okay or does it need more EBNF precision, like

  separator:  wsp* "," wsp*

The same wording occurs in several places: here are the exact commits

  https://github.com/svgeesus/ietf-justfont/commit/a1d2709bd29d59f4a007bb2819494e66246c51f5
  https://github.com/svgeesus/ietf-justfont/commit/6e7d2612e4fe5a6c0b97b4f4db2b5509b5fb0edf
  https://github.com/svgeesus/ietf-justfont/commit/34a37f5a5f8ce13f2528384b2e9dfaae3cb378c9

---

From: "Levantovsky, Vladimir" <[email-masked]>
Date: Tue, 9 Feb 2016 22:16:51 +0000

Hi Chris,

Your recent changes look good, and I think the description is sufficiently detailed.

Thank you very much,
Vlad

-----Original Message-----
From: Chris Lilley [mailto:[email-masked]] 
Sent: Tuesday, February 09, 2016 5:09 PM
To: Levantovsky, Vladimir; [email-masked]
Subject: Re: [Justfont] font top-level type: Outlines "in various combinations"

Hello Vlad,

A good point.

  separator:  wsp* "," wsp*