Subject: [karp] draft-zheng-mpls-ldp-hello-crypto-auth

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Mon, 4 Apr 2011 03:04:45 +0530

Hi,

The current version of draft-zheng-mpls-ldp-hello-crypto-auth does not contain any cryptographic sequence numbers and I spoke to Mach and Vero about this in Prague. It seems that they were told that replay attacks are not considered a big deal for LDP. While I can concede that replay attacks are a trifle more difficult for LDP deployments (mostly service providers environment) I am not comfortable in developing a solution that precludes the possibility of us ever supporting this.

Given this I would like to suggest the following change in the draft:

We either define a new 4 byte field for crypto-sequence numbers that the implementations MAY chose to ignore or define two Auth types where one contains this field and the other doesn't.

Also I just noticed that the TLV defines Auth Type which indicates the kind of algo being used. I think this is redundant and I see no need for this given that we are already carrying a Key ID.

Cheers, Manav

--
Manav Bhatia,
IP Division, Alcatel-Lucent,
Bangalore - India

---

From: Sam Hartman <[email-masked]>
Date: Wed, 06 Apr 2011 15:25:43 -0400

I agree that draft would be improved by sequence numbers.

Will the boot count mechanism work or is freshness an issue?
In particular, is one LDP hello enough, or is there a non-trivial state
machine?

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 7 Apr 2011 03:39:49 +0530

The boot count is applicable here as well as LDP is also susceptible to inter-session replay attacks.

Cheers, Manav 

> -----Original Message-----
> From: Sam Hartman [mailto:[email-masked]] 
> Sent: Thursday, April 07, 2011 12.56 AM
> To: Bhatia, Manav (Manav)
> Cc: Mach Chen; zhenglianshu 50128; [email-masked]
> Subject: Re: [karp] draft-zheng-mpls-ldp-hello-crypto-auth
>

---

From: Sam Hartman <[email-masked]>
Date: Wed, 06 Apr 2011 18:11:52 -0400

>>>>> "Bhatia," == Bhatia, Manav (Manav) <[email-masked]> writes:

    Bhatia,> The boot count is applicable here as well as LDP is also
    Bhatia,> susceptible to inter-session replay attacks.  Cheers, Manav

No, my question was whether the boot count will work?

What does the LDP state machine look like?
Are you sure a full replay wouldn't be useful?

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 7 Apr 2011 03:49:34 +0530

Oh, Ok I get it now. I think we can bring up an entire session with the replays which means we may have to mandate freshness if we really want to avoid the inter-session attacks. The router whose packets are replayed will play the passive role when establishing a session. 

Cheers, Manav

> Sent: Thursday, April 07, 2011 3.42 AM
> Cc: Sam Hartman; Mach Chen; zhenglianshu 50128; [email-masked]
> >>>>> "Bhatia," == Bhatia, Manav (Manav) 
> <[email-masked]> writes:
>

---

From: "Dacheng Zhang(Dacheng)" <[email-masked]>
Date: Thu, 07 Apr 2011 01:43:19 +0000

Do you imply there should be a challenge/Response solution for LDP as well. Similar with what we have proposed for OSPF?

BR,
Dacheng
>> 
>> Oh, Ok I get it now. I think we can bring up an entire session with the replays
>> which means we may have to mandate freshness if we really want to avoid
>> the inter-session attacks. The router whose packets are replayed will play the
>> passive role when establishing a session.
>> 
>> Cheers, Manav
>> 
>> _______________________________________________
>> karp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/karp

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 7 Apr 2011 07:57:45 +0530

Yes, that's precisely what I mean.

Cheers, Manav 

> From: Dacheng Zhang(Dacheng) [mailto:[email-masked]] 
> Sent: Thursday, April 07, 2011 7.13 AM
> To: Bhatia, Manav (Manav); Sam Hartman
> Cc: Mach Chen; [email-masked]
> Subject: re: [karp] draft-zheng-mpls-ldp-hello-crypto-auth
> 
> Do you imply there should be a challenge/Response solution 
> for LDP as well. Similar with what we have proposed for OSPF?
> 
> BR,
> Dacheng
> >>