Subject: Re: [keyassure] who to trust

From: "Jeffrey A. Williams" <[email-masked]>
Date: Fri, 20 Aug 2010 10:19:50 -0500 (GMT-05:00)

Richard and all,

  Do I understand you right stating what you said below
differently, that your less concerned regarding the end
points than ensuring that the binded keys to any domain name
overlaying DNS is valid and/or good?  If I do understand
you right, than I see your point.  But shouldn't we
have a better/stronger and known trusted starting point?
Can the user even assume same necessarly?  

-----Original Message-----
>From: "Richard L. Barnes" <[email-masked]>
>Sent: Aug 20, 2010 9:55 AM
>To: Phillip Hallam-Baker <[email-masked]>
>Cc: [email-masked], Scott Rea <[email-masked]>
>Subject: Re: [keyassure] who to trust
>
>Ah, I have only just now read the initial charter proposal that Warren  
>sent out.  I agree that that one is too root-centric.
>
>But clearly the problem can be phrased more in terms of application  
>needs (binding keys to domain names) and validation paths (overlaid on  
>DNS) instead of what TAs those paths end in.  That's what I tried to  
>do in my earlier proposal.
>
>
>
>
>On Aug 20, 2010, at 10:46 AM, Phillip Hallam-Baker wrote:
>
>> Plenty of people have asserted that the objective is to do PKI for
>> 'free'. Others have expressed the opinion that certain services are
>> 'overpriced'.
>>
>> Those are pricing discussions.
>>
>>
>> If you read the other charter proposals you will see that they both
>> contain statements to the effect that the advantage the group seeks to
>> realize is to enforce use of a single root of trust. Those are the
>> parts I find unacceptable.
>>
>>
>> On Fri, Aug 20, 2010 at 10:40 AM, Richard L. Barnes  
>> <[email-masked]> wrote:
>>>> If people want to propose a system with a single point of failure  
>>>> then
>>>> that point of failure has to be on the table for discussion. The  
>>>> only
>>>> reason I brought ICANN up is that others insisted that we only  
>>>> design
>>>> a system where the only choice is to trust the ICANN monopoly.
>>>
>>> [Citation needed]
>>>
>>>
>>>> I do not think that we want two separate groups, one to do DNSSEC  
>>>> for
>>>> applications using only the ICANN root and a separate group for
>>>> applications using a choice of roots. And even if we wanted to, I
>>>> doubt that a charter of that nature could be accepted by the IESG.
>>>
>>> Obviously we don't, because this whole discussion is completely  
>>> unrelated to
>>> a choice of trust anchors.  DNSSEC and other protocols we develop  
>>> in the
>>> IETF do not require any relying party to use any given trust  
>>> anchor.  If you
>>> want a concrete example, just look at the DLV.
>>>
>>>
>>>> One other charter point. We cannot have any discussion of pricing of
>>>> products or services (including 'free'). IETF rules have been quite
>>>> lax on this point to date. However we have to take care not to be  
>>>> the
>>>> group that brings down the lawyers.
>>>
>>> That seems kind of obvious.  Who has expressed a desire to discuss  
>>> pricing?
>>>
>>> --Richard
>>>
>>>
>>>
>>>
>>>>
>>>>
>>>> On Fri, Aug 20, 2010 at 6:43 AM, Scott Rea <[email-masked]>
>>>> wrote:
>>>>>
>>>>>  On 8/19/2010 9:16 PM, Paul Hoffman wrote:
>>>>>>
>>>>>> At 2:01 AM +0100 8/20/10, Tony Finch wrote:
>>>>>>>
>>>>>>> It seems to me from this week's discussion that (exaggerating  
>>>>>>> slightly)
>>>>>>> no
>>>>>>> one wants to trust the x.509 certificate authorities and no one  
>>>>>>> wants
>>>>>>> to
>>>>>>> trust ICANN's DNSSEC root anchor.
>>>>>>
>>>>>> Exaggerating wildly, I would say. Who other than Phill have said  
>>>>>> they
>>>>>> don't trust ICANN's DNSSEC root anchor?
>>>>>>
>>>>>> --Paul Hoffman, Director
>>>>>> --VPN Consortium
>>>>>> _______________________________________________
>>>>>> keyassure mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/keyassure
>>>>>
>>>>> Hmmm... nothing against ICANN personally, but lots against a  
>>>>> single point
>>>>> of
>>>>> failure, I prefer to share that responsibility around
>>>>>
>>>>> --
>>>>> Scott Rea
>>>>> Sr PKI Architect (Contractor)
>>>>> Em: [email-masked]
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> keyassure mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/keyassure
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Website: http://hallambaker.com/
>>>> _______________________________________________
>>>> keyassure mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/keyassure
>>>
>>>
>>
>>
>>
>> -- 
>> Website: http://hallambaker.com/
>
>_______________________________________________
>keyassure mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/keyassure

Jeffrey A. Williams
Spokesman for INEGroup LLA. - (Over 300k members/stakeholders and growing, strong!)
"Obedience of the law is the greatest freedom" -
   Abraham Lincoln

"Credit should go with the performance of duty and not with what is very
often the accident of glory" - Theodore Roosevelt

"If the probability be called P; the injury, L; and the burden, B; liability
depends upon whether B is less than L multiplied by
P: i.e., whether B is less than PL."
United States v. Carroll Towing  (159 F.2d 169 [2d Cir. 1947]
===============================================================
Updated 1/26/04
CSO/DIR. Internet Network Eng. SR. Eng. Network data security IDNS. div. of
Information Network Eng.  INEG. INC.
ABA member in good standing member ID 01257402 E-Mail [email-masked]
Phone: 214-244-4827

---

From: "Jeffrey A. Williams" <[email-masked]>
Date: Fri, 20 Aug 2010 12:48:40 -0500 (GMT-05:00)

Paul and all,

  As you already know the 'Trust system' you refrence is
not widely trusted.  There inlies the crux of the problem
and brings up multipul issues.  I for one still contend
that there never was, and still isn't a rough consensus
in respect to the 'Trust system' to which your refrence
in your remarks/statements below...

  That yet again re-stated and none the less, moving forward
'as is' is a compermise that we can supposedly attempt
to move forward with in a constructive manner.

-----Original Message-----
>From: Paul Hoffman <[email-masked]>
>Sent: Aug 20, 2010 12:11 PM
>Cc: [email-masked]
>I strongly support a charter that specifically ties the gaining of trust that a key/cert is associated with a domain name to the DNS itself, using the DNSSEC protocol as the cryptographic protection for the binding statements. Doing so uses a trust system that is well understood and a protocol that is well understood.
>
>It is fine to propose that a different trust system be used. In order to make that proposal understandable, you can write an Internet Draft that explains the trust system and compares it to the ones commonly in use today (PKIX certificates with CAs, OpenPGP certificates with web-of-trust, DNS responses signed with DNSSEC).
>
>It is fine to propose that DNS responses be used but to use a different cryptographic method for assuring the origin. In order to make that proposal understandable, you can write an Internet Draft that explains the new cryptographic binding, and compare it to DNSSEC.
>
>At 11:33 AM -0400 8/20/10, Phillip Hallam-Baker wrote:
>>An IETF WG charter requires more than consensus amongst the proposers.
>>There has to be an IETF consensus and the IESG has to concur and there
>>has to be an AD willing to accept the WG.
>>
>>Making assertions and then ruling rebuttals as 'off topic' as you keep
>>doing is not the way to get an IETF charter accepted.
>
>Yes, it is.
>
>Allowing one person to derail the charter discussion because he or his employer doesn't like where it is going is not considered a best practice in the IETF. Instead, if you think that you have a group of people that would support your view, start your own pre-BoF mailing list, show that you have an interested group, and bring that to the IESG.
>
>>If you want to persist in making a proposal which tries to enforce a
>>certain trust model then it has to be in the security area.
>
>Your "has to be" and "must be" statements are not backed by any known precedent, are they?
>
>>I think
>>you will find at least one of the security ADs rather skeptical of the
>>viability of a single rooted model as even the US federal government
>>could not come to agreement on that architecture.
>
>And, at that point, we can continue the discussion with them. So far, you are only speculating in a way that supports your (to this point) lone opinion.
>
>>Consensus does not mean that you get to choose a group of people who
>>want to do it your way and then get a WG chartered to coronate that
>>specific proposal.
>
>Nor does it mean listening to one person who repeats arguments over and over without gaining support from others in the discussion. Some of us prefer the former method to the one you are proposing.
>
>--Paul Hoffman, Director
>--VPN Consortium

Regards,

Jeffrey A. Williams

---

From: "Jeffrey A. Williams" <[email-masked]>
Date: Fri, 20 Aug 2010 16:44:28 -0500 (GMT-05:00)

David and all,

  The financial relationship between PIR and the ISOC regarding
.ORG one has to admit is symbiotic, but perhaps not a COI
yet, But no one really knows that for sure do they?

  ICANN leadership has emphatically stated on more than
one occasion that the IETF is ICANN's "Good right arm".
So yes the arms length relationship between PIR/ICANN is two 
pronged at least.  Still again this does not necessarly
mean that there is 'problem' with such a relationship but
the appearance of such gives some pause.  There are also
some strong potential positives in such relationships that
can and do benifit everyone...   

-----Original Message-----
>From: David Conrad <[email-masked]>
>Sent: Aug 20, 2010 4:25 PM
>Cc: "[email-masked]" <[email-masked]>
>Phillip,
>On Aug 20, 2010, at 1:09 PM, Phillip Hallam-Baker wrote:
>> Last I heard isoc has a financial interest in .org
>
>So, your logic is that because PIR has a contract with ICANN for the operation of .ORG, ISOC receives money from PIR, and ISOC supports the IETF, that this imputes a commercial relationship between IETF and ICANN?  Really?
>
>> Qualifying that with the weasel word direct and claiming it impacts my credibility would seem to saymore about yours
>
>Riiight.  As Randy Bush might say <plonk>.
>
>Regards,
>-drc
>

Regards,
Jeffrey A. Williams

---

From: "Jeffrey A. Williams" <[email-masked]>
Date: Sat, 21 Aug 2010 15:01:13 -0500 (GMT-05:00)

Phillip and all,

  Yes, and this tactic from David and Randy has been used
many times before with unfortunately significant success.
As such the Internet community has on occasion been damaged
accordingly and to some degree suffers still as history has 
clearly shown.

-----Original Message-----
>From: Phillip Hallam-Baker <[email-masked]>
>Sent: Aug 20, 2010 5:08 PM
>To: David Conrad <[email-masked]>
>You know for people who say they want to focus on technology, you do
>all keep digging.
>
>Damn right I consider forming PIR as a bidding consortium and
>participating in a share of the profits on the award of the contract
>to be a commercial relationship.
>
>
>By the way, agenda denial is not a particularly effective tactic on
>me. I keep attempting to engage on technical proposals, I note that
>instead you and others prefer to focus on the assumptions on which my
>proposals are based and make assertions that you then declare to be
>off limits for discussion and then declare the conversation closed.
>
>
>On Fri, Aug 20, 2010 at 5:25 PM, David Conrad <[email-masked]> wrote:
>> Phillip,
>>

Regards,
Jeffrey A. Williams