Subject: Re: [keyassure] who to trust

From: "Jeffrey A. Williams" <[email-masked]>
Date: Fri, 20 Aug 2010 10:08:33 -0500 (GMT-05:00)

Phillip and all,

  From a personal prefrence point of view only, I would
much prefer a single root of trust.  But the practical
and technical side of me keeps such notions in check as
such notions are not realistic.  Same would be so for 
free PKI.  Free PKI is not realistic.  Inexpensive PKI
is definately possible and done now.  However business
entities see t eh potential huge quick profit potential
and will likely put upward pressure on PKI costs.

  Back the roots of trust and trust models and methods.

  What we seem to be gradually moving towards is multipul
trust roots with the seemingly growing desire to do so
via a inside DNS method, OR the use of trust anchors
for validation of certs but with a simpler yet robust
means of providing same.   So two of my questions are 
for now:

1.) How many trust anchors is sufficient and/or trustworthy
    and how is the trustworthyness of same determined?

2.)Key strength of certs: is NIST's current standard sufficient?
   My answer to this currently is NO.

3.) Is the current trust chain for trusted anchors sufficient,
    secure, and also consistantly trustworthy?

  What we do know is that there at least 5m domains that
by any reasonably thinking person are not presently
trustworthy and need to either become so via some
means of method, or be dispensed with entirely.
See:

http://news.slashdot.org/story/10/08/16/214228/5-Million-Domains-Serving-Malware-Via-Netwo%7C

http://blog.armorize.com/2010/08/smci-widget-by-network-solutions-still.html
http://www.net-security.org/malware_news.php?id=1431
http://blog.armorize.com/2010/08/more-than-500000-network-solutions.html

-----Original Message-----
>From: Phillip Hallam-Baker <[email-masked]>
>Sent: Aug 20, 2010 9:46 AM
>To: "Richard L. Barnes" <[email-masked]>
>Cc: [email-masked], Scott Rea <[email-masked]>
>Subject: Re: [keyassure] who to trust
>
>Plenty of people have asserted that the objective is to do PKI for
>'free'. Others have expressed the opinion that certain services are
>'overpriced'.
>
>Those are pricing discussions.
>
>
>If you read the other charter proposals you will see that they both
>contain statements to the effect that the advantage the group seeks to
>realize is to enforce use of a single root of trust. Those are the
>parts I find unacceptable.
>
>
>On Fri, Aug 20, 2010 at 10:40 AM, Richard L. Barnes <[email-masked]> wrote:
>>> If people want to propose a system with a single point of failure then
>>> that point of failure has to be on the table for discussion. The only
>>> reason I brought ICANN up is that others insisted that we only design
>>> a system where the only choice is to trust the ICANN monopoly.
>>
>> [Citation needed]
>>
>>
>>> I do not think that we want two separate groups, one to do DNSSEC for
>>> applications using only the ICANN root and a separate group for
>>> applications using a choice of roots. And even if we wanted to, I
>>> doubt that a charter of that nature could be accepted by the IESG.
>>
>> Obviously we don't, because this whole discussion is completely unrelated to
>> a choice of trust anchors.  DNSSEC and other protocols we develop in the
>> IETF do not require any relying party to use any given trust anchor.  If you
>> want a concrete example, just look at the DLV.
>>
>>
>>> One other charter point. We cannot have any discussion of pricing of
>>> products or services (including 'free'). IETF rules have been quite
>>> lax on this point to date. However we have to take care not to be the
>>> group that brings down the lawyers.
>>
>> That seems kind of obvious.  Who has expressed a desire to discuss pricing?
>>
>> --Richard
>>
>>
>>
>>
>>>
>>>
>>> On Fri, Aug 20, 2010 at 6:43 AM, Scott Rea <[email-masked]>
>>> wrote:
>>>>
>>>>  On 8/19/2010 9:16 PM, Paul Hoffman wrote:
>>>>>
>>>>> At 2:01 AM +0100 8/20/10, Tony Finch wrote:
>>>>>>
>>>>>> It seems to me from this week's discussion that (exaggerating slightly)
>>>>>> no
>>>>>> one wants to trust the x.509 certificate authorities and no one wants
>>>>>> to
>>>>>> trust ICANN's DNSSEC root anchor.
>>>>>
>>>>> Exaggerating wildly, I would say. Who other than Phill have said they
>>>>> don't trust ICANN's DNSSEC root anchor?
>>>>>
>>>>> --Paul Hoffman, Director
>>>>> --VPN Consortium
>>>>> _______________________________________________
>>>>> keyassure mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/keyassure
>>>>
>>>> Hmmm... nothing against ICANN personally, but lots against a single point
>>>> of
>>>> failure, I prefer to share that responsibility around
>>>>
>>>> --
>>>> Scott Rea
>>>> Sr PKI Architect (Contractor)
>>>> Em: [email-masked]
>>>>
>>>>
>>>> _______________________________________________
>>>> keyassure mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/keyassure
>>>>
>>>
>>>
>>>
>>> --
>>> Website: http://hallambaker.com/
>>> _______________________________________________
>>> keyassure mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/keyassure
>>
>>
>
>
>
>-- 
>Website: http://hallambaker.com/
>_______________________________________________
>keyassure mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/keyassure

Regards,

Jeffrey A. Williams
Spokesman for INEGroup LLA. - (Over 300k members/stakeholders and growing, strong!)
"Obedience of the law is the greatest freedom" -
   Abraham Lincoln

"Credit should go with the performance of duty and not with what is very
often the accident of glory" - Theodore Roosevelt

"If the probability be called P; the injury, L; and the burden, B; liability
depends upon whether B is less than L multiplied by
P: i.e., whether B is less than PL."
United States v. Carroll Towing  (159 F.2d 169 [2d Cir. 1947]
===============================================================
Updated 1/26/04
CSO/DIR. Internet Network Eng. SR. Eng. Network data security IDNS. div. of
Information Network Eng.  INEG. INC.
ABA member in good standing member ID 01257402 E-Mail [email-masked]
Phone: 214-244-4827

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 20 Aug 2010 11:24:16 -0400

Let's try this again: Selection of trust anchors is not a topic for  
this list.  Not that it's not important; it's just irrelevant for  
protocol engineering.