Subject: Re: AD Review: draft-ietf-kink-kink [starting at section 5]

From: Shoichi Sakane <[email-masked]>
Date: Mon, 07 Mar 2005 08:40:29 +0900

> Section 11:
> 
> Needs work.  You may want to stop by tthe IANA office hours and ask
> them for advice.  They are generally quite good at working with
> authors to figure out how things need to be specified.

I will take the following questions, and try to contact the desk.

	which codes do we want ?
	which codes should we define ?
		kink port number
		kink error number
		kink payload type

I am thinking that the port number should be assigned by IANA,
and others are defined by us.

---

From: Shoichi Sakane <[email-masked]>
Date: Wed, 09 Mar 2005 22:51:09 +0900

Hi, I went to the IANA desk yesterday.  She suggested me that:

1) we have to decide which codes are the IANA matter.
2) we have to explain in the IANA consideration of the draft
  2-1) which codes do we want the IANA to assign ?
       We can request a specific system port number for the KINK
       to the IANA although the number will not be accepted by
       some reason.
  2-2) which codes do we want to register into the registry ?
       and which registry do we want to register ?

So, my opinion is that

#1. from the current docuemnt, the followin codes are IANA matter.
	- KINK message type
	- KINK payload type
	- KINK error code
	- KINK port number

#2. We have to register
	- KINK message type
	- KINK payload type
	- KINK error code

    I don't think it is necessary to register them into the ISAKMP
    registry.  so we have to request a new registry creation
    such like KINK registry.

    And the KINK port number has to be assigned by the IANA.
    I don't think that we need a specific system port number.
    so we can leave it to the IANA.