Subject: Kitten Recharter (Volunteers Needed)

From: Shawn Emery <[email-masked]>
Date: Wed, 14 Jul 2010 17:11:02 -0600

There has been push-back on the proposed Kitten recharter because of the 
following:

1. Milestones should be defined for each of the proposed work items
2. Editors should be assigned to each of these

We are imploring anyone who would like to solve some of these problems 
to volunteer.  Anyone that might not have prior IETF process experience 
should not hesitate to volunteer.  We will help in getting volunteers up 
to speed.

For reference I have included the list of work items below.  For those 
that already have an assignment and for any new volunteers, please 
provide proposed milestones for:

1. WGLC of the corresponding draft with month/year
2. Submission to the IESG of the corresponding draft with month/year

Proposed work items:

* GSS-API: initializing credentials
[editor: TBD]

* GSS-API: iterating credentials
[editor: TBD]

* GSS-API: exporting/importing credentials
[editor: TBD]

* GSS-API: specification for asynchronous calls
[editor: TBD]

* GSS-API: interfaces/improvements for better error message reporting
[editor: TBD]

* GSS-API: programmer friendly interfaces
[editor: TBD]

* GSS-API: transition SASL mechanism for OpenID
[editor: TBD]

* GSS-API: transition SASL mechanism for SAML
[editor: TBD]

* GSS-API: publish draft-ietf-kitten-gssapi-extensions-iana
[editor: Nicolas Williams]

* GSS-API: publish draft-ietf-kitten-gssapi-naming-exts
[editor: Leif Johansson]

* SASL: publish draft-melnikov-digest-to-historic
[editor: Alexey Melnikov]

* SASL: publish draft-williams-tls-app-sasl-opt
[editor: Nicolas Williams]

Shawn.
kitten co-chair
--

---

From: "Scott Cantor" <[email-masked]>
Date: Thu, 15 Jul 2010 11:01:15 -0400

> We are imploring anyone who would like to solve some of these problems to
> volunteer.  Anyone that might not have prior IETF process experience
should
> not hesitate to volunteer.  We will help in getting volunteers up to
speed.

> * GSS-API: transition SASL mechanism for SAML

I'm happy to volunteer for the mechanism I drafted, obviously.

-- Scott

---

From: Eliot Lear <[email-masked]>
Date: Thu, 15 Jul 2010 17:17:36 +0200

I volunteer for the SASL OpenID draft.

Eliot

On 7/15/10 1:11 AM, Shawn Emery wrote:
>
> There has been push-back on the proposed Kitten recharter because of
> the following:
>
> to volunteer.  Anyone that might not have prior IETF process
> experience should not hesitate to volunteer.  We will help in getting
> volunteers up to speed.
>
> _______________________________________________
> sasl mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sasl

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 15 Jul 2010 20:26:45 +0200

I volunteer to work on GS2/GSS-API related aspects of the OpenID and
SAML documents.  And generally, I volunteer to work any SASL mechanism
that is interested to explore GS2/GSS-API compatibility.

/Simon

---

From: Nicolas Williams <[email-masked]>
Date: Thu, 15 Jul 2010 14:16:16 -0500

> [editor: Nicolas Williams]

if we adopt it as a WG item, or, if we don't, I'll consider continuing
as an individual submission if there's enough interest.

Nico
--

---

From: "Klaas Wierenga (kwiereng)" <[email-masked]>
Date: Thu, 15 Jul 2010 21:12:44 +0200

And I volunteer on the non-gs2/gss-api part of the saml document ;-)

Klaas

Sent from my iPad

On Jul 15, 2010, at 8:27 PM, "Simon Josefsson" <[email-masked]> wrote:

> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten

---

From: Eliot Lear <[email-masked]>
Date: Thu, 15 Jul 2010 21:57:03 +0200

Just to be more clear, I volunteer to be the editor for the WG version
of draft-lear-sasl-openid should it be accepted by the working group.

Eliot

On 7/15/10 5:17 PM, Eliot Lear wrote:
>> We are imploring anyone who would like to solve some of these
>> problems to volunteer.  Anyone that might not have prior IETF process
>> For reference I have included the list of work items below.  For
>> those that already have an assignment and for any new volunteers,
>> please provide proposed milestones for:
>>

---

From: Klaas Wierenga <[email-masked]>
Date: Fri, 16 Jul 2010 10:35:26 +0200

> of draft-lear-sasl-openid should it be accepted by the working group.

ditto for the sasl-saml draft

Klaas