Subject: [kitten] draft-ietf-kitten-saml-ec-20

From: Margaret Cullen <[email-masked]>
Date: Tue, 11 May 2021 11:29:58 -0400

Hi All,

As was announced on the list, I have published a new version of draft-ietf-kitten-sasl-saml-ec, which can be found here:

https://datatracker.ietf.org/doc/draft-ietf-kitten-sasl-saml-ec/ <https://datatracker.ietf.org/doc/draft-ietf-kitten-sasl-saml-ec/>
I have volunteered to take over editing this draft, to see if we can get it completed and published.

The -20 version of the draft contains a large number of small changes intended to address many of the nits and editorial issues raised by Ben Kaduk in his AD Review.  It was my intention, in this version, to address as many of Ben’s issues as possible that could be easily addressed with purely editorial changes to the spec — no substantive changes.  Please review this version, and let me know if you have any questions or concerns about the changes.

This draft will serve as the basis for addressing Ben’s more substantive issues.  I will be starting separate threads, over time, for each of the substantive issues he raised.  In some cases, where there is an obvious fix, I will propose text changes to address the issue.  In other cases, I will raise topics for discussion in the working group, in the hope that we can find a solution.

If there are any other open issues with this draft, older ones or ones that you find when reviewing this version, please let me know. 

Margaret

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 11 May 2021 12:25:46 -0700

Hi Margaret,

> I have volunteered to take over editing this draft, to see if we can get it completed and published.

Thank you!

> The -20 version of the draft contains a large number of small changes intended to address many of the nits and editorial issues raised by Ben Kaduk in his AD Review.  It was my intention, in this v…

The changes generally look good to me.
The one part I want to check about is in the introduction -- in the -20,
the first paragraph is about SAML, the second about SASL, the fourth about
GSSAPI, and now the third appears to also be about SAML (and possibly not
SASL -- hard to tell without following the references).  We may want to
clarify what the "related protocols, ..." are related to -- SAML or SASL
(or both).

Thanks again,

Ben

> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten