Subject: RE: [L1vpn] question on optimality

From: "Don Fedyk" <[email-masked]>
Date: Sun, 13 Nov 2005 21:31:32 -0500

Hi Tomonori

> -----Original Message-----
> 
> Hi Dimitri,
> 
> Thanks for raising this issue again, which we missed to 
> discuss in the meeting.
> 
> In my understanding, in UNI applications, a customer chooses 
> ingress and egress ports, and the provider decides path 
> within the provider network. This applied to the L1VPN basic 
> mode as well.
> 
> If a customer is allowed some visibility of the provider 
> network, the customer may be able to choose "better" ingress 
> and egress ports. For example, suppose ingress and egress CEs 
> are connected to multiple PEs. In UNI applications, a 
> customer may choose ingress and egress ports randomly, and 
> CE-CE LSP may not be established due to lack of resources. On 
> the other hand, by having some visibility, a cusomter may 
> choose correct ingress and egress ports, and CE-CE LSP may be 
> established.
> 
> Furthermore, if a part of provider network resource is 
> dedicated to a specific customer, and the customer is allowed 
> to use this resource "as you like", the customer may be able 
> to optmize resource usage within its limit. (This is more 
> like "per-VPN Peer model", I think.)
> 
> Of course, we need to be careful about customer-provider 
> trust model, and not to over-engineer things. We may need a 
> good balance, and that is why it would be nice to hear WG opinions.
> 
> Comments?

This seems tricky to me. You have a valid point however I would think
one goal of L1VPN should be to decouple the Provider network from the
customer network such that the provider may change infrastructure with
minimal obligation to tell the customer details.  
I can imagine there will be some non-optimality in connectivity.  I
would think a topology free abstraction and a set of constraints would
be the best way to address this requirement. 
In many ways this may be similar to the requirement to describe paths to
PCE.  Is there work we can borrow from there?

Regards,
Don 
> 
> Thanks,
> Tomonori
> 
> On Fri, 11 Nov 2005 19:50:35 +0100
> dimitri papadimitriou <[email-masked]> wrote:
> 
> > all -
> > 
> > during the meeting i raised the question concerning the issue about
> > optimality in the context of the enhanced mode discussion - 
> see slide 3 
> > of the discussion material ("More advanced Traffic Engineering: 
> > Optimality") - would be interesting to have further details 
> captured 
> > around this requirement
> > 
> > thanks,
> > - dimitri.

_______________________________________________
L1vpn mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l1vpn

---

From: Tomonori TAKEDA <[email-masked]>
Date: Tue, 15 Nov 2005 00:27:31 +0900

Hi Don,

Thanks for your comments.

Please see in-line.

On Sun, 13 Nov 2005 21:31:32 -0500

> minimal obligation to tell the customer details.

OK. I may be saying too much around solution aspects already, which was
not my intention.

But I guess we are in-line with what we want to achieve in terms of
optimality. (NOTE: I think there are other aspects where Enhanced Mode
may help, such as avoidance of N-square routing adjacency.)

> be the best way to address this requirement.

Could you elaborate this a bit more?

> PCE.  Is there work we can borrow from there?

As mentioned in the meeting, I agree this work *may* have potential
relationship to CCAMP inter-domain work and PCE work. At this point, I
am not yet sure how certain PCE is applicable, but this may be an
interesting option. Do you have any idea on this?

Thanks,
Tomonori

---

From: dimitri papadimitriou <[email-masked]>
Date: Mon, 14 Nov 2005 22:00:58 +0100

hi don

> minimal obligation to tell the customer details.  

this is exactly the point i wanted to make - do we speak here about

a) an optimized network resource usage wrt a given set of end-point to 
be connected (we could refer to this as a CE-based constraint)

b) an optimized set of CE-CE connections wrt a given set of network 
resources allocated to a VPN (we could refer to this as a PE-based 
constraint) ?

> be the best way to address this requirement. 

it depends on the objective - i think as you stated that the VPN usage 
is to allow for CE connectivity flexibility while keeping a) - i.e. 
network resource usage under control -

> PCE.  Is there work we can borrow from there?

in the L1VPN context the "time" component and hence scheduling plays an 
important role, at the end the attractivness for an operator is to offer 
a larger connectivity than the number of connections it can actually 
provide

> .