Subject: [L1vpn] Port information exchange (was: Re: Draft meeting report)

From: Tomonori TAKEDA <[email-masked]>
Date: Thu, 17 Nov 2005 18:07:51 +0900

Hi Dimitri,

Thanks for initiating this.

Some thoughts below...

- All of below information elements are optional? Or some of them are mandatory?
- At some point, we may want to consider whether to exchange customer port 
information and provider port information separately (e.g., in the case of 
IGP, as different LS components, and in the case of BGP, as different NLRI) 
or together.

Thanks,
Tomonori

At 22:36 05/11/15 +0100, dimitri papadimitriou wrote:
>all -
>
>here below a first suggestion on optional C/P "port identifiers"
>
>customer port switching capability (8 bits)
>provider port switching capability (8 bits)
>
>encoding (8 bits)
>
>bandwidth granularity: min/max LSP bandwidth (2 x 32 bits)
>
>once ok will draft the corr. text
>
>comments ?
>
>thanks,
>- dimitri;
>
>
>Adrian Farrel wrote:
>
>>Hi,
>>You can see the draft meeting report at
>>http://www3.ietf.org/proceedings/05nov/minutes/l1vpn.html
>>In a break with tradition I have followed the rules which are to write a
>>report to capture the agreements and open issues rather than a verbatim
>>record.
>>Let me know what you think of this approach.
>>Thanks,
>>Adrian
>>
>>_______________________________________________
>>L1vpn mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/l1vpn
>>.
>
>_______________________________________________
>L1vpn mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/l1vpn

_______________________________________________
L1vpn mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l1vpn

---

From: dimitri papadimitriou <[email-masked]>
Date: Thu, 17 Nov 2005 11:04:54 +0100

hi tomonori

> - All of below information elements are optional? Or some of them are 

i consider them all as optional (as indicated in the initial proposal) 
as this information is considered when the VPN includes ports with 
different capabilities

> - At some point, we may want to consider whether to exchange customer 
> port information and provider port information separately (e.g., in the 
> case of IGP, as different LS components, and in the case of BGP, as 
> different NLRI) or together.

in this case, you have to consider two triplets of the form

customer port switching capability (8 bits)
customer port encoding (8 bits)
customer port bandwidth granularity: min/max LSP bandwidth (2 x 32 bits)

provider port switching capability (8 bits)
provider port encoding (8 bits)
provider port bandwidth granularity: min/max LSP bandwidth (2 x 32 bits)

note however that if the information has to be carried separately an 
"association" should be provided in the newly defined NLRI (since its 
present definition combines the CPI, PPI information)

thanks,
- dimitri.