Subject: [L1vpn] Autodiscovery Protocol

From: "Kunze, Ruediger" <[email-masked]>
Date: Thu, 23 Mar 2006 18:36:03 +0100

Hi all,

just two comments from a network provider perspective. 
>From our perspective there are two reasons to choose BGP as auto-discovery protocol for L1VPNs.

The first one is simplicity of producing services in the network.Currently we have been deploying L3VPNs based on BGP. We will deploy L2VPNs also based on BGP.
We we should use IGP for Layer 1? So give us a chance to keep production processes and OAM simple. I vote for BGP!  

The second reason is interoperability. I have concerns that a second solution complicates interoperability. Therfore im in favor of a BGP-autodiscovery solution.
If an IGP solution is indispensable (in case of carriers are only producing L1VPNs), then is vote for a must for BGP-autodiscovery. 

Regards Rüdiger

_______________________________________________
L1vpn mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l1vpn

---

From: <[email-masked]>
Date: Mon, 27 Mar 2006 20:35:20 +0200

> 
> [IB] I really would like to have a multi-AS L1 network operator as a
> customer of Movaz :=) 

You may miss out on the opportunity with only OSPF based discovery ;-))

> However,  I am yet to see a multi-area 
> L1 network. You
> have mentioned interop issues between the two solutions and 
> inconvenience
> supporting them both, and I am afraid you are missing a point 
> here. In IP
> network BGP and OSPF work together just fine - they both 
> populate the same
> RIB. How is it different from populating the PIT, which what L1VPN
> auto-discovery is all about?

Two protocols would add complexity in this case. You now would need two
discovery mechanisms to fill a single VPN's PIT. (which may be
considered a feature as well) In general two cost more than one.

Furthermore, in many SP IP networks, the IGP more and more is used only
for the infrastructure routes, moving all the customer (and VPN)
information to BGP. In that respect the analogy is slightly off I think.

cheers,
	Eduard

---

From: <[email-masked]>
Date: Tue, 28 Mar 2006 09:55:49 +0200

> 
> >>>>o) time - depending on need's importance vs urgency, if 
> dynamic PTI 
> >>>>tables population is to be there in a couple of month, or 
> in a couple of 
> >>>>years (would like to point out that understimating the 
> time it may take
> >>>>to convince l1/trans networks to make use of BGP may be impacting)
> >>>
> >>>I think I understand the timing issue, but what is the specific
> >>>'problem' with BGP in relation to L1 transport network? 
> >>>(with BGP being used for the purpose of discovery)
> >>
> >>afaik, there is no large "install base" as for IP/MPLS (L3VPN) 
> > 
> > Okay, but debatable. there is probably no large base of 
> anything in this
> > area.
> 
> at least creating a small install base took some time ;-)
> 

Fair enough. What I meant to indicate is that considering the small
installed base, this is not really an argument against BGP or in favor
of OSPF in this case. 

> picking your words if there is no large control plane 
> deployment in the 
> L1 networks can we assume that L1VPN would become a real 
> driver for such 
> large scale deployment ? and by when ?
> 

L1VPN will be one of the important drivers I think. By when .. I do not
know. Already in research / GRID networks this is becoming an important
topic (these typically need inter-domain solutions btw). 

/Eduard