Subject: RE: [L1vpn] BGP Traffic Engineering attribute

From: "Don Fedyk" <[email-masked]>
Date: Fri, 20 Oct 2006 09:45:04 -0400

Hi Igor

Sorry for the delay on this. 

TE Metric is covered by the BGP MED metric - We will add a note to this
effect. SRLG we have not included right now. I proposed to Hamid and
Yakov we carry colors for a rudimentary SRLG capability but we have not
closed on this. 

I not sure about your reference of the link protection capability.
Could you look at the list below and see if we missed it?

Here is the objects we have so far:

-Switching Cap (Covered)  	
-Encoding (Covered)  
-Max LSP Bandwidth at priority 0 (Covered)  	
-Max LSP Bandwidth at priority 1 (Covered) 
-Max LSP Bandwidth at priority 2(Covered) 
-Max LSP Bandwidth at priority 3(Covered) 
-Max LSP Bandwidth at priority 4(Covered) 
-Max LSP Bandwidth at priority 5(Covered) 
-Max LSP Bandwidth at priority 6(Covered) 
-Max LSP Bandwidth at priority 7(Covered) 
-Capability-specific information (variable)(Covered) 
-Local and Remote Identifiers(Covered) 
-Link Protection Type(Covered) 
-Interface Switching Capability(Covered) 
-Minimum LSP Bandwidth(Covered)
-Indication(Covered)  

Regards,
Don 

> -----Original Message-----
> From: Igor Bryskin [mailto:[email-masked]] 
> Sent: Tuesday, July 18, 2006 10:13 AM
> To: [email-masked]; Yakov Rekhter
> Subject: Re: [L1vpn] BGP Traffic Engineering attribute
> 
> Yakov,
> 
> I have a couple of questions.
> 
> 1. Why do you believe that advertising of just ISCD attribute 
> is sufficient?
> How about other TE Link TLV attributes like link protection 
> capability, SRLGs, colors, TE metric, etc.? Do you think that 
> there is no benefit to account such attributes of CE-PE links 
> in L1VPN service path computation?
> 
> 2. What will happen if a new TE Link sub-TLV is introduced 
> (like for example, Interface Termination/Adaptation 
> Capability Descriptor (ITACD), which is necessary in 
> multi-layer environments with unified (say, GMPLS) control 
> plane? Will your draft track all these changes and adjust the 
> BGP TE advertisings accordingly?
> 
> Thanks,
> Igor
> 
> ----- Original Message -----
> From: "Yakov Rekhter" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, July 18, 2006 9:48 AM
> Subject: [L1vpn] BGP Traffic Engineering attribute
> 
> 
> > Folks,
> >
> > As I promised at the L1VPN WG meeting last week, here is 
> the Internet
> > Draft that defines a BGP attribute that could be used to carry
> > (G)MPLS Traffic Engineering information. One possible application
> > of this attribute is L1VPN.
> >
> > Comments/review are appreciated (as usual).
> >
> > Yakov.
> > ------- Forwarded Message
> >
> > Date:    Mon, 17 Jul 2006 15:50:01 -0400
> > From:    [email-masked]
> > To:      [email-masked]
> > cc:
> > Subject: I-D ACTION:draft-fedyk-bgp-te-attribute-00.txt
> >
> > - --NextPart
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> >
> >
> > Title : Traffic Engineering Attribute
> > Author(s) : D. Fedyk, et al.
> > Filename : draft-fedyk-bgp-te-attribute-00.txt
> > Pages :
> > Date : 2006-7-17
> >
> >    This document defines a new BGP attribute, Traffic Engineering
> >    attribute, than enables BGP to carry Traffic Engineering 
> information
> >
> > A URL for this Internet-Draft is:
> > 
> http://www.ietf.org/internet-drafts/draft-fedyk-bgp-te-attribu
te-00.txt
> >
> > To remove yourself from the I-D Announcement list, send a message to
> > [email-masked] with the word unsubscribe in 
> the body of the
> mess
> > age.
> > You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> > to change your subscription settings.
> >
> >
> > Internet-Drafts are also available by anonymous FTP. Login with the
> username
> > "anonymous" and a password of your e-mail address. After logging in,
> > type "cd internet-drafts" and then
> > "get draft-fedyk-bgp-te-attribute-00.txt".
> >
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> >
> > Internet-Drafts can also be obtained by e-mail.
> >
> > Send a message to:
> > [email-masked].
> > In the body type:
> > "FILE /internet-drafts/draft-fedyk-bgp-te-attribute-00.txt".
> >
> > NOTE: The mail server at ietf.org can return the document in
> > MIME-encoded form by using the "mpack" utility.  To use this
> > feature, insert the command "ENCODING mime" before the "FILE"
> > command.  To decode the response(s), you will need "munpack" or
> > a MIME-compliant mail reader.  Different MIME-compliant mail readers
> > exhibit different behavior, especially when dealing with
> > "multipart" MIME messages (i.e. documents which have been split
> > up into multiple messages), so check your local documentation on
> > how to manipulate these messages.
> >
> >
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> >
> > - --NextPart
> > Content-Type: Multipart/Alternative; Boundary="OtherAccess"
> >
> > - --OtherAccess
> > Content-Type: Message/External-body; access-type="mail-server";
> > server="[email-masked]"
> >
> > Content-Type: text/plain
> > Content-ID: <[email-masked]>
> >
> > ENCODING mime
> > FILE /internet-drafts/draft-fedyk-bgp-te-attribute-00.txt
> >
> > - --OtherAccess
> > Content-Type: Message/External-body;
> > name="draft-fedyk-bgp-te-attribute-00.txt"; site="ftp.ietf.org";
> > access-type="anon-ftp"; directory="internet-drafts"
> >
> > Content-Type: text/plain
> > Content-ID: <[email-masked]>
> >
> >
> > - --OtherAccess--
> >
> > - --NextPart
> > Content-Type: text/plain; charset="us-ascii"
> > MIME-Version: 1.0
> > Content-Transfer-Encoding: 7bit
> > Content-Disposition: inline
> >
> > _______________________________________________
> > I-D-Announce mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/i-d-announce
> >
> > - --NextPart--
> >
> > ------- End of Forwarded Message
> >
> >
> > _______________________________________________
> > L1vpn mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/l1vpn
> >
> 
> 
> _______________________________________________
> L1vpn mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/l1vpn
> 

_______________________________________________
L1vpn mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l1vpn

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 20 Oct 2006 11:37:53 -0700 (PDT)

Hi Don,

Please, see 1.2 RFC4203 for the link protection type/ capability. You said it is covered, but I couldn't find the word "protection" in your draft. How exactly it is covered?
Note also that IP metric/cost and TE metric are different things. What is covered by the BGP MED?
Also how about the "Interface MTU size" attribute(1.4)?

Igor

Don Fedyk <[email-masked]> wrote: Hi Igor

-Switching Cap (Covered)   
-Encoding (Covered)  

Regards,
Don 

> From: "Yakov Rekhter" 
> To: 
te-00.txt

 			
---------------------------------
Get your own web address for just $1.99/1st yr. We'll help. Yahoo! Small Business.

---

From: "Igor Bryskin" <[email-masked]>
Date: Fri, 20 Oct 2006 14:34:23 -0400

Hi Don,

Please, see 1.2 RFC4203 for the link protection type/ capability. You
said it is covered, but I couldn't find the word "protection" in your
draft. How exactly it is covered?
Note also that IP metric/cost and TE metric are different things. What
is covered by the BGP MED?
Also how about the "Interface MTU size" attribute(1.4)?

Igor

-----Original Message-----
From: Don Fedyk [mailto:[email-masked]] 
Sent: Friday, October 20, 2006 9:45 AM
To: Igor Bryskin; [email-masked]
Cc: [email-masked]; Hamid Ould-Brahim
Subject: RE: [L1vpn] BGP Traffic Engineering attribute

Hi Igor

-Switching Cap (Covered)  	
-Encoding (Covered)  

Regards,
Don 

te-00.txt

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 20 Oct 2006 11:47:54 -0700

Igor,

> is covered by the BGP MED?

The latter.

> Also how about the "Interface MTU size" attribute(1.4)?

What about it ? Quoting from draft-fedyk-bgp-te-attribute-02.txt:

   When the Switching Capability field is PSC-1, PSC-2, PSC-3, or PSC-4,
   the Switching Capability specific information field includes Minimum
   LSP Bandwidth, Interface MTU, and padding.

       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |                  Minimum LSP Bandwidth                        |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |           Interface MTU       |            Padding            |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Yakov.

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 20 Oct 2006 11:58:43 -0700 (PDT)

Hi Yakov,

       0                   1                   2                   3

IB>> Sorry, you are right, I missed that

Igor

Yakov.

 		
---------------------------------
Stay in the know. Pulse on the new Yahoo.com.  Check it out.

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Fri, 20 Oct 2006 15:26:00 -0400

Igor,
 
*chair hat off*

>Please, see 1.2 RFC4203 for the link protection type/ capability.  
 
I think we'd like to get more feedback from the WG on that
and if there is consensus then we'll just add it.
 
Hamid. 

Don Fedyk <[email-masked]> wrote:

Hi Igor

-Switching Cap (Covered) 
-Encoding (Covered) 

Regards,
Don 

te-00.txt

  _____  

Get your own web
<http://us.rd.yahoo.com/evt=43290/*http://smallbusiness.yahoo.com/domain
s> address for just $1.99/1st yr. We'll help. Yahoo!
<http://us.rd.yahoo.com/evt=41244/*http://smallbusiness.yahoo.com/>
Small Business.

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 21 Oct 2006 18:00:42 +0100

Hamid,

I think you should just add it.

I can't see any value in having some TE links having a different set of 
available information compared to others.
If you believe that the TE links that you propose to advertise using BGP 
cannot offer link-level protection, then you should say so.

Cheers,
Adrian

----- Original Message ----- 
From: "Hamid Ould-Brahim" <[email-masked]>
To: "Igor Bryskin" <[email-masked]>; "Don Fedyk" <[email-masked]>; 
"Igor Bryskin" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, October 20, 2006 8:26 PM
Subject: RE: [L1vpn] BGP Traffic Engineering attribute