Subject: [L2CP] TLV number clash in new wadhwa draft

From: Jakob Heitz <[email-masked]>
Date: Mon, 22 May 2006 15:06:56 -0700

For PORT UP TLVs, new addition,
        2. Type (Access-Loop-Remote-Id = 0x02)
required a renumbering of
        3. Type (Access-Aggregation-Circuit-ID-Binary = 0x04)
from 0x02 to 0x04.
However,
        5. Type (DSL Line Attributes = 0x04):
is 0x04. A clash!
Because this one contains its own TLVs, is it even needed?
The encapsulated TLVs have no numbering clashes.

The new version is incompatible with the old due to
the renumbered items. Therefore could we please
bump the version, say to 0x32.

_______________________________________________
L2cp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2cp

---

From: Jakob Heitz <[email-masked]>
Date: Mon, 22 May 2006 15:19:53 -0700

Also, Access-Aggregation-Circuit-ID-ASCII
for VLAN is specified thus:
Access-Node-Identifier eth slot/port [:inner-vlan-id][:outer-vlan-id]

Could we swap the outer and inner, like this ?
Access-Node-Identifier eth slot/port [:outer-vlan-id][:inner-vlan-id]

-- 
Jakob Heitz. x5475. 510-566-2901

---

From: "Peter Arberg" <[email-masked]>
Date: Mon, 22 May 2006 21:07:43 -0700

So at the moment there is no need to even read the new draft.

Most of these changes is done because I have requested them
based on other customer discussions, non DT, and to make ANCP
more compliant to TR-101 from information it includes.

But unfortunately the update is not made consistent, so there
is even number disagreement inside the draft.

So for now, forget it is there, and stay at the .0 draft.

This .01 version is actually a lot closer to the PDD, but since
mainly the DSLAM vendors kept arguing against the draft, and 
Wadhwa was to slow to get it out, it will not make the DT trail
which was the idea back in January.

Peter

> -----Original Message-----
> From: Jakob Heitz [mailto:[email-masked]] 
> Sent: 22. maj 2006 15:20
> To: [email-masked]
> Subject: Re: [L2CP] TLV number clash in new wadhwa draft
>

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Tue, 23 May 2006 10:14:04 -0400

Known issues (thanks to Thomas and Norbert) and will be fixed. Today Access-Aggregation-Circuit-ID-Binary is not supported by any implementation.

>Sent: Monday, May 22, 2006 6:07 PM
>To: [email-masked]
>Subject: [L2CP] TLV number clash in new wadhwa draft
>
>

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Tue, 23 May 2006 10:25:00 -0400

Peter
  Most of this doesn't belong to the list. Let us limit the discussion
here to technical issues if any with the current version of the draft.

Thanks
-Sanjay

>From: Peter Arberg [mailto:[email-masked]]
>Sent: Tuesday, May 23, 2006 12:08 AM
>To: 'Jakob Heitz'; [email-masked]
>Subject: RE: [L2CP] TLV number clash in new wadhwa draft
>
>

---

From: "Peter Arberg" <[email-masked]>
Date: Tue, 23 May 2006 21:26:21 -0700

Hi Sanjay,

I know. My mistake, it was a user error where an internal company email
by mistake got send to the ietf list.

sorry for the mistake,
peter

> From: Sanjay Wadhwa [mailto:[email-masked]] 
> Sent: 23. maj 2006 07:25
> To: [email-masked]; Jakob Heitz; [email-masked]