Subject: [L2sm] Adoption poll for draft-wen-l2sm-l2vpn-service-model-03.txt

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 18 Nov 2016 00:26:17 -0000

Hi,

Our charter mandates that we consider basing our work on
draft-wen-l2sm-l2vpn-service-model-03.txt

As we discussed in the meeting, that draft is not perfect. But when I asked the
room whether we thought that it would provide a good starting point that we
could work with to polish and adapt to become the I-D that we ultimately submit
for publication as an RFC, I believe I heard a good hum in favour and silence in
opposition.

So this email starts a formal poll for adoption. Please answer:

Do you think that the WG should adopt draft-wen-l2sm-l2vpn-service-model-03.txt?

If "yes," it would help if you could indicate whether you have read the draft
and how happy you are with it.
If "no", it is important that you provide reasons.

This poll will last for two weeks, ending on Saturday 3rd December.

Just to reassure everyone that adoption does not imply that anything is set in
stone: we expect the WG to continue to develop the content and change whatever
needs to be changed.

Thanks,
Adrian and Qin

---

From: David Ball <[email-masked]>
Date: Fri, 18 Nov 2016 10:32:16 +0000

I do not believe that draft is a good basis for L2SM work as is - much 
of the content pertains to information that is internal to the SP's 
network and implementation of the service, rather than what is relevant 
to the customer of the service.  Such content does not belong in a 
customer service model (which is what L2SM is chartered to develop).  In 
addition the draft is not well aligned with MEF specifications.

I have given further feedback to the authors of the draft offline, 
including asking them to clarify the intent of their draft.  To date I 
have had assurances from Adrian but no response from the authors.

     David

On 18/11/2016 00:26, Adrian Farrel wrote:
> _______________________________________________
> L2sm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/l2sm

-- 
David Ball
<[email-masked]>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 18 Nov 2016 14:25:12 -0000

Hi David,

A similar question about the amount of protocol or network implementation
details in the model was raised a couple of times at the mic in the meeting.

IIRC it was Himanshu who offered to take a pass on the document to try to list
those excessive objects.

But I think there are several categories that we need to consider.

1. Those parameters that described the CE-PE link in a PE-mode VPN.
    These can be presented per-service or per-link. They are a necessary
    part of the service specification and cannot be omitted, I believe.

2. Those parameters that describe behaviors within the network. As I
    understand it, these fall into two sub-categories:

   a. Parameters that don't belong in a truly abstract description of the
      service, but which customers habitually request the ability to specify 
      and which the service providers habitually offer. I think we will need
      to have support for these because we are aiming for a model that
      will see support and deployment at once, as (obviously) this is not
      an academic exercise. 

   b. Parameter that are a "step to far" and which should be removed.

Determining the balance between these categories will probably require some
discussion.

But let's quickly jump from that discussion to try to understand the way forward
you would like to see. Clearly you think changes to the document are needed and
it sounds like everyone agrees that that is true. And that sounds (to me) like
you believe we have a document we can work with to serve as a basis for updates.
What isn't obvious to me is why you don't think that the working group should
have control of this discussion and the changes to the document. What do you
propose?

Thanks,
Adrian

> -----Original Message-----
> From: David Ball [mailto:[email-masked]]
> Sent: 18 November 2016 10:32
> To: [email-masked]; [email-masked]
> Subject: Re: [L2sm] Adoption poll for

---

From: David Ball <[email-masked]>
Date: Mon, 21 Nov 2016 09:38:15 +0000

Hi Adrian,

> have control of this discussion and the changes to the document. What do you

Fundamentally, given the amount of work needed on this document, it's 
not clear to me that taking it as a basis for the WG work is the 
least-effort option; we should as a minimum consider alternatives - e.g. 
starting from scratch, or using the MEF modules as a basis (I believe 
MEF have recently liaised their in-progress work to IETF).

I also really would like to hear from the authors - their document may 
be useful in its own right (just not aligned with the WG charter), so it 
may be that they want to proceed with it in that direction, as an 
individual draft.  Of course that doesn't stop the WG "forking" it, but 
one might imagine the authors would be less inclined to participate in 
the WG in that case.

     David

-- 
David Ball
<[email-masked]>

---

From: 顾 戎 <[email-masked]>
Date: Tue, 22 Nov 2016 04:01:49 +0000

Hi, chairs and authors.

I agree with the WG adoption of the L2SM service model draft. As I attend the L2SM in Seoul, I think service model is actually important which can be regarded as a reference or guidance to the operator when providing the VPN service. This is the reason of my agreement.

However, this draft needs to be updated as a much more abstract service model.

Gu Rong

[email-masked]

[email-masked]
________________________________
发件人: L2sm <[email-masked]> 代表 Adrian Farrel <[email-masked]>
发送时间: 2016年11月18日 0:26
收件人: [email-masked]
主题: [L2sm] Adoption poll for draft-wen-l2sm-l2vpn-service-model-03.txt

Hi,

Thanks,
Adrian and Qin

_______________________________________________
L2sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l2sm
L2sm Info Page - ietf.org<https://www.ietf.org/mailman/listinfo/l2sm>
www.ietf.org
Your email address: Your name (optional): You may enter a privacy password below. This provides only mild security, but should prevent others from messing with ...

---

From: Giles Heron <[email-masked]>
Date: Tue, 22 Nov 2016 13:28:48 +0000

Hi David,

> On 21 Nov 2016, at 09:38, David Ball <[email-masked]> wrote:
> 
> Hi Adrian,
> Fundamentally, given the amount of work needed on this document, it's not clear to me that taking it as a basis for the WG work is the least-effort option; we should as a minimum consider alternatives - e.g. starting from scratch, or using the MEF modules as a basis (I believe MEF have recently liaised their in-progress work to IETF).
> 
agreed.   I think we need to stand back and look at what needs to be in an L2VPN service model and then compare that to this draft and to the MEF work (perhaps without going as far as a formal requirements draft).

and I think we should perhaps consider a layered approach where we have:
a) technology-specific models for PWE-based VPWS/VPLS and for EVPN, which expose the internal details of the protocols (e.g. PW IDs, BGP RTs/RDs to the layer above) and which can be used as components in more complex end-to-end models (e.g. PWE access to an L3VPN).
b) technology-neutral but still resource-facing service models for e.g. E-Line and E-LAN which can be implemented using PWE, EVPN, L2TPv3, Ethernet VLANs, wet string etc.
c) customer-facing service models with constructs such as customer info/account number etc.

Were we to take the layered approach I’d suggest that IETF be responsible for (a), MEF for (b) and the individual service provider for (c) (though there may be value in standardising some of the customer-facing stuff to enable multi-provider orchestration etc.) 

within the context of (a) we should also look to maximise reuse between the L2VPN and L3VPN models (e.g. using common groupings for BGP RTs/RDs etc., using common site definitions etc.)

we may also want to consider whether we look to augment the I2RS network and topology models rather than creating models from scratch.   The “N” in “VPN” stands for “Network” after all.   That also gives us a potential approach to exposing the dependencies between layers (a), (b) and (c) by using the “supporting-“ network/node/link concepts.

Giles
> I also really would like to hear from the authors - their document may be useful in its own right (just not aligned with the WG charter), so it may be that they want to proceed with it in that direction, as an individual draft.  Of course that doesn't stop the WG "forking" it, but one might imagine the authors would be less inclined to participate in the WG in that case.
> 
>     David
> 
> -- 
> David Ball
> <[email-masked]> <mailto:[email-masked]>_______________________________________________
> L2sm mailing list
> [email-masked]