Subject: [L2sm] New Liaison Statement, "Response to your liaison dated 31st October 2016"

From: Liaison Statement Management Tool <[email-masked]>
Date: Mon, 26 Dec 2016 09:51:17 -0800

Title: Response to your liaison dated 31st October 2016
Submission Date: 2016-12-26
URL of the IETF Web page: https://datatracker.ietf.org/liaison/1501/

From: "Adrian Farrel" <[email-masked]>
To: [email-masked]
[email-masked]
Cc: Joel Jaeggli <[email-masked]>,Adrian Farrel <[email-masked]>,Benoit Claise <[email-masked]>,Qin Wu <[email-masked]>,Raghu Ranganathan <[email-masked]>,L2VPN Service Model Discussion List <[email-masked]>,Scott Mansfield <[email-masked]>,Mahesh Jethanandani <[email-masked]>,,
Response Contacts: Adrian Farrel <[email-masked]>,Qin Wu <[email-masked]>
Technical Contacts: [email-masked]
Purpose: In response

Referenced liaison: Liaison to IETF on proposed Working Group on L2SM (https://datatracker.ietf.org/liaison/1498/)

Body: Thank you for your liaison message of 31st October this year addressed to the IESG and OPS Area Directors.
 
Since your liaison, the Layer 2 VPN Service Model (L2SM) working group has been formed by the IESG. This happened right after the L3SM working group succeeded in its goal of describing an L3VPN service as a data model by documenting it in the YANG modeling language. You can see the new working group's charter at https://datatracker.ietf.org/wg/l2sm/charter/ and the product of the L3SM working group at https://datatracker.ietf.org/wg/l3sm/documents/
 
The L2SM working group met for the first time at IETF-97 in Seoul during November and had a lively discussion about its work including the issues of terminology, functional boundaries, and potential overlap with or use of MEF work. You can see the meeting materials and draft minutes at https://datatracker.ietf.org/meeting/97/materials/ by searching for "L2SM".  Both Mahesh Jethanandani and Scott Mansfield were in the room during the meeting and can probably give you their views on what happened.
 
L2SM will follow the same path as was taken for L3SM, and is tasked to do something similar to L3SM. 

Your liaison message is most helpful in pointing out and supplying copies of existing and on-going MEF work related to the task of the L2SM working group, and the fact of you making available log-in details and material for your work-in-progress is very much appreciated. 

You asked a specific question in your communication:

> Is the focus of L2SM about the internal network technologies and
> implementations as opposed to "characteristics of the service as
> discussed between the operators and their customers"?

The answer is the latter (although it should be noted that there is some debate about whether "operator" or "service provider" is the correct term).

Through the discussion during the meeting and on the list, we believe a suitable point of differentiation between MEF and L2SM is that MEF has worked on CE-based models while L2SM will work on PE-based models. PE-based models necessarily include a number of technology-specific details and will focus on the networking aspects of the service while still keeping the realisation of the service within the provider's network as technology agnostic.

Furthermore, while the MEF clearly embraces all aspects of the LSO architecture including billing, SLA, order management, life-cycle management, etc, the L2SM working group is tasked to do something much smaller: a self-contained service YANG module similar to tat produced for L3SM. While it would be nice to fit the L2SM work into the MEF LSO architecture, it appears that L2SM follows a different architectural approach, and that there is no value in trying to "fit a square peg in a round hole" by trying to force a match of the functions across the two approaches. This does not invalidate either approach, but only observes that they are different.
 
The working group has so far been clear in its intent to, where possible and consistent with its own work, re-use by reference any relevant existing material such as that developed by the MEF Forum. So far it has identified SLAs, QoS, and Billing as components that may very well be candidates for such re-use.
 
At the moment, the working group is at a very early stage. We welcome  participation by all interested parties, but in particular by service providers and service customers since they are the principal users of the YANG model under construction. Participation is open to all via the mailing list https://www.ietf.org/mailman/listinfo/l2sm.
 
We wish you well with your January meeting.
 
Qin Wu and Adrian Farrel
L2SM Working Group Chairs

Attachments:

No document has been attached

---

From: "Ranganathan, Raghu" <[email-masked]>
Date: Tue, 27 Dec 2016 18:29:05 +0000

Hello Qin Wu and Adrian,
Thanks. I will post it to the attention of our Members.

--Raghu (Sent from Phone)

From: Liaison Statement Management Tool
Sent: Tuesday, December 27, 2:56 AM
Subject: New Liaison Statement, "Response to your liaison dated 31st October 2016"
To: Ranganathan, Raghu
Cc: Ranganathan, Raghu, Mahesh Jethanandani, Scott Mansfield, L2VPN Service Model Discussion List, Benoit Claise, Joel Jaeggli, Adrian Farrel, Qin Wu, Adrian Farrel

Title: Response to your liaison dated 31st October 2016 Submission Date: 2016-12-26 URL of the IETF Web page: https://datatracker.ietf.org/liaison/1501/ From: "Adrian Farrel" To: [email-masked] [email-masked] Cc: Joel Jaeggli ,Adrian Farrel ,Benoit Claise ,Qin Wu ,Raghu Ranganathan ,L2VPN Service Model Discussion List ,Scott Mansfield ,Mahesh Jethanandani ,, Response Contacts: Adrian Farrel ,Qin Wu Technical Contacts: [email-masked] Purpose: In response Referenced liaison: Liaison to IETF on proposed Working Group on L2SM (https://datatracker.ietf.org/liaison/1498/) Body: Thank you for your liaison message of 31st October this year addressed to the IESG and OPS Area Directors. Since your liaison, the Layer 2 VPN Service Model (L2SM) working group has been formed by the IESG. This happened right after the L3SM working group succeeded in its goal of describing an L3VPN service as a data model by documenting it in the YANG modeling language. You can see the new working group's charter at https://datatracker.ietf.org/wg/l2sm/charter/ and the product of the L3SM working group at https://datatracker.ietf.org/wg/l3sm/documents/ The L2SM working group met for the first time at IETF-97 in Seoul during November and had a lively discussion about its work including the issues of terminology, functional boundaries, and potential overlap with or use of MEF work. You can see the meeting materials and draft minutes at https://datatracker.ietf.org/meeting/97/materials/ by searching for "L2SM". Both Mahesh Jethanandani and Scott Mansfield were in the room during the meeting and can probably give you their views on what happened. L2SM will follow the same path as was taken for L3SM, and is tasked to do something similar to L3SM. Your liaison message is most helpful in pointing out and supplying copies of existing and on-going MEF work related to the task of the L2SM working group, and the fact of you making available log-in details and material for your work-in-progress is very much appreciated. You asked a specific question in your communication: > Is the focus of L2SM about the internal network technologies and > implementations as opposed to "characteristics of the service as > discussed between the operators and their customers"? The answer is the latter (although it should be noted that there is some debate about whether "operator" or "service provider" is the correct term). Through the discussion during the meeting and on the list, we believe a suitable point of differentiation between MEF and L2SM is that MEF has worked on CE-based models while L2SM will work on PE-based models. PE-based models necessarily include a number of technology-specific details and will focus on the networking aspects of the service while still keeping the realisation of the service within the provider's network as technology agnostic. Furthermore, while the MEF clearly embraces all aspects of the LSO architecture including billing, SLA, order management, life-cycle management, etc, the L2SM working group is tasked to do something much smaller: a self-contained service YANG module similar to tat produced for L3SM. While it would be nice to fit the L2SM work into the MEF LSO architecture, it appears that L2SM follows a different architectural approach, and that there is no value in trying to "fit a square peg in a round hole" by trying to force a match of the functions across the two approaches. This does not invalidate either approach, but only observes that they are different. The working group has so far been clear in its intent to, where possible and consistent with its own work, re-use by reference any relevant existing material such as that developed by the MEF Forum. So far it has identified SLAs, QoS, and Billing as components that may very well be candidates for such re-use. At the moment, the working group is at a very early stage. We welcome participation by all interested parties, but in particular by service providers and service customers since they are the principal users of the YANG model under construction. Participation is open to all via the mailing list https://www.ietf.org/mailman/listinfo/l2sm. We wish you well with your January meeting. Qin Wu and Adrian Farrel L2SM Working Group Chairs Attachments: No document has been attached