Subject: [L2sm] Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Wed, 04 Apr 2018 22:48:55 -0700

Adam Roach has entered the following ballot position for
draft-ietf-l2sm-l2vpn-service-model-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-l2sm-l2vpn-service-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to everyone who worked on this document. I have a handful of comments.

---------------------------------------------------------------------------

§5:

>    +--rw sites
>    +--rw site* [site-id]
>    +--rw site-id                                string

It's possible that I don't understand the intended structure here, or that I'm
misreading the tree diagram, but it seems to me that this should be represented
as:

     +--rw sites
     |  +--rw site* [site-id]
     |     +--rw site-id                          string

---------------------------------------------------------------------------

§7:

>  Example of generated PE configuration:
>
>  !
>  bridge-domain 1
>   member Ethernet0/0 service-instance 100
>   member vsi one
>
>  !
>  l2 router-id 198.51.100.1
>  !
>
>  interface Ethernet0/0
>   no ip address
>   service instance 100 ethernet
>  encapsulation dot1q 100
>   !
>
>  !
>  router bgp 1
>   bgp log-neighbor-changes
>   neighbor 198.51.100.4 remote-as 1
>   neighbor 198.51.100.4 update-source Loopback0
>   !
>   address-family l2vpn vpls
>    neighbor 198.51.100.4 activate
>    neighbor 198.51.100.4 send-community extended
>    neighbor 198.51.100.4 suppress-signaling-protocol ldp
>   exit-address-family
>
>  !
>  interface vlan 100 <-- Associating the Attachment
>    no ip address       Circuit with the MAC-VRF at the PE
>    xconnect vsi PE1-VPLS-A
>  !
>  vlan 100
>    state active

Please update this example to use IPv6 (or a mix of IPv4 and IPv6). See
https://www.iab.org/2016/11/07/iab-statement-on-ipv6/ for guidance.

---------------------------------------------------------------------------

§8:

> feature lacp {
>   description
>     " Enables LACP capability in a VPN. ";
> }

Nit: the spacing around the description here seems odd.

> identity pwe3 {
>   base service-type;
>   description
>     "Pseudo-Wire Emulation Edge to
>      Edge(PWE3)Service type. .";
> }

Nit: the punctuation here seems odd. Add spaces around "(PWE3)", and eliminate
the trailing period.

>     leaf bum-overall-rate {
>       type uint32;
>       units "bps";
>       description
>         "overall rate for BUM.";
>     }

Given bandwidth trends, limiting this value to 4 Gbps seems to be potentially
problematic. Consider a larger integer type.

---

From: Fioccola Giuseppe <[email-masked]>
Date: Thu, 5 Apr 2018 15:23:18 +0000

Hi Adam,
Thanks for your opinion of the document.
My answers inline tagged as [GF]

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: L2sm [mailto:[email-masked]] Per conto di Adam Roach
Inviato: giovedì 5 aprile 2018 07:49
A: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Oggetto: [L2sm] Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

>    +--rw site-id                                string

It's possible that I don't understand the intended structure here, or that I'm misreading the tree diagram, but it seems to me that this should be represented
as:

     +--rw sites
     |  +--rw site* [site-id]
     |     +--rw site-id                          string

[GF]: Yes, we will fix it.
---------------------------------------------------------------------------

>    no ip address       Circuit with the MAC-VRF at the PE

Please update this example to use IPv6 (or a mix of IPv4 and IPv6). See https://www.iab.org/2016/11/07/iab-statement-on-ipv6/ for guidance.

[GF]: it makes sense. We will update this example.
---------------------------------------------------------------------------

§8:

> feature lacp {
>   description
>     " Enables LACP capability in a VPN. "; }

[GF]: Ok, We will fix it.

>      Edge(PWE3)Service type. .";

Nit: the punctuation here seems odd. Add spaces around "(PWE3)", and eliminate the trailing period.

[GF]: Ok, We will fix it.

>         "overall rate for BUM.";

Given bandwidth trends, limiting this value to 4 Gbps seems to be potentially problematic. Consider a larger integer type.

[GF]: Good suggestion, will do.

_______________________________________________
L2sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l2sm

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.