Subject: [L2tpext] L2TP Incoming Call Establishment

From: "Arul J P" <[email-masked]>
Date: Mon, 4 Mar 2002 14:44:36 +0530

Hi,

    Can the LAC start sending L2TP data packets (PPP packets)
immediately after it sends ICCN without waiting for a ACK?
 
    This question arises since the rfc states that session reaches
established state in LAC after it sends ICCN.

    If the ICCN is lost, can the forwarded PPP packets be discarded
by LNS until it receives ICCN.

Thanks,
Arul Mohan.

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: "W. Mark Townsley" <[email-masked]>
Date: Mon, 04 Mar 2002 14:37:21 +0100

> immediately after it sends ICCN without waiting for a ACK?

Yes.

> established state in LAC after it sends ICCN.

Yes, the ACK is at the transport layer. Technically, the L2TP subsystem never
knows that the ACK is actually received.

> by LNS until it receives ICCN.

Yes. The ICCN may contain information vital to the connection (e.g. for PPP,
proxy LCP information).

---

From: Jed Lau <[email-masked]>
Date: Mon, 4 Mar 2002 11:04:59 -0500 (EST)

Yes.

> established state in LAC after it sends ICCN.

Correct.

Yes.

Jed

---

From: "Arul J P" <[email-masked]>
Date: Tue, 5 Mar 2002 09:38:39 +0530

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> W. Mark Townsley
> Sent: Monday, 4 March 2002 7:07 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [L2tpext] L2TP Incoming Call Establishment
> 
> 
> 
> 
> Arul J P wrote:
> > 
> > Hi,
> > 
Does L2TP subsystem means the L2TP data plane?. In that case the
L2TP data plane has to configured only by the L2TP control plane
(transport layer). L2TP control plane can wait till ZLB ACK 
is received for the ICCN packet before it does this configuration.

---

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 05 Mar 2002 09:28:00 +0100

> is received for the ICCN packet before it does this configuration.

By "subsystem" I was referring to the L2TP state machine for session
establishment.

The ZLB ack is only a transport layer mechanism. Think of L2TP as having its own
datagram-based "TCP" of sorts for sending control packets that operates
independently of the L2TP state machine. The ZLB is simply sent in lieu of any
other packet to ack the last message received.