Subject: [L2tpext] Data Sequencing

From: kalyana <[email-masked]>
Date: Wed, 11 Aug 2004 17:31:22 +0530

Hi Mark,

In L2TPv3 for requesting data sequencing from peer one need to send two AVPs to peer
i.e. L2-Specific Sublayer(AVP-TBA-11) and Data Sequencing(AVP-TBA-12).
Why it is like that ? I did not understand reason behind this.
Can't it done by sending single AVP to make it simple.

Regards,
Kalyan

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 11 Aug 2004 09:05:51 -0400

> Can't it done by sending single AVP to make it simple.

While it is true that sequencing requires presence of the sublayer, there are 
other reasons why the sublayer may need to be present. For example, one may 
require presence of the sublayer for use by VCCV (draft-ietf-pwe3-vccv-03.txt), 
ATM (draft-ietf-l2tpext-pwe3-atm-01.txt), or fragmentation 
(draft-ietf-pwe3-fragmentation-05.txt) each of which use flags in the sublayer.

Thanks,

- Mark

>  
> Regards,
> Kalyan
>  
>  
> <mailto:[email-masked]> 
> 
> 
> ------------------------------------------------------------------------
>

---

From: kalyana <[email-masked]>
Date: Sat, 14 Aug 2004 10:53:39 +0530

Hi Mark,

I agree with you that sublayer is not only for sequencing but for other
reasons  also.
My point is can't we get rid of Data Sequencing AVP and just send
L2-Specific Sublayer AVP.
and this AVP can now carry both L2-Specific and sequencing level,  very much
simiar to data packet
where L2 specific information and sequecning number present in one sublayer.

Regards,
Kalyan