Subject: [L2tpext] draft-ietf-l2tpext-l2tp-base-14 : About mandoroty AVP s

From: Arif <[email-masked]>
Date: Wed, 11 Aug 2004 13:58:59 +0530

hi ,

in draft-ietf-l2tpext-l2tp-base-14 for  ICRQ/ICRP/ICCN 

the mandotrory AVP mentioned are 

      Message Type
      Local Session ID
      Remote Session ID
      Serial Number
      Pseudowire Type
      Circuit Status

But with this information only , how the peer know to which session this
message is for. 

say there can be multiple session , on what logic the peer can accept
this ICRQ and reply with ICRP.

Please reply,

Thanks and Regards,
Arif

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 11 Aug 2004 05:59:21 -0400

> this ICRQ and reply with ICRP.

The Remote End ID is used to correlate an ICRQ with the proper policy to reply 
with. I believe it is a mistake that this is not listed as a MUST be present for 
the ICRQ.

Thanks,

- Mark

> 
> Please reply,
> 
> Thanks and Regards,
> Arif
> 
> 
> 
> 
> ------------------------------------------------------------------------
>

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 18 Aug 2004 10:37:45 -0400

W. Mark Townsley wrote:

>> But with this information only , how the peer know to which session 
>> this message is for.
>>
> The Remote End ID is used to correlate an ICRQ with the proper policy to 
> reply with. I believe it is a mistake that this is not listed as a MUST 
> be present for the ICRQ.

Note that while the summary of AVPs that must exist in an ICRQ did not list the 
Remote End ID, this text does exist in draft-ietf-l2tpext-l2tp-base-14.txt:

Page 51-2:

    By default, the LAC-LAC cross-connect application (see section
    2.0(b)) of L2TP over an IP network MUST utilize the Router ID AVP and
    Remote End ID AVP to associate a circuit to an L2TP session. Other
    AVPs MAY be used for LCCE or circuit identification as specified in
    companion documents.

Thus, the implication is that for the LAC-LAC cross-connect application, these 
two AVPs are a MUST for an ICRQ. I'll take it as an editorial note to update the 
summary during the 48-hour review before the RFC is actually published.

- Mark