Subject: Re: [Isis-wg] Re: Inconsistent view of routers over a LAN

From: "Cheng-Yin Lee" <[email-masked]>
Date: Tue, 10 Jun 2003 16:43:12 -0400

Jeff, Tony, Acee,
Thanks for your clarification.
L2VPN WG is defining emulated LAN (and broadcast network for IP traffic)
service over IP/MPLS network and some of the mechanims being defined can
result in loss of communication among a subset of routers on the
emulated LAN (even if all the nodes in the underlying IP/MPLS transport
network are reachable).
Some of the discussions have been how tolerable are routing protocols to
this type of problem, if it is worth fixing some L2VPN WG mechanisms to
prevent this problem, how feasible are these L2VPN solutions, are these
not well-known problems ...

I hope the L2VPN WG would consider these issues and requirements in the
L2VPN solutions.
Perhaps a more detailed understanding of how things work/don't work may
help L2VPN WG develop/appreciate solutios that will work well with
routers for e.g, in case of (i) below, what would an emulated LAN user
observe in the routed network (is this predictable/unpredictable?)

Thanks
Cheng-Yin
p.s I have cced l2vpn, but pls feel free to respond only to the relevant
WG as is appropriate.

Tony Li wrote:
> 
> We should also point out that in case i) things are truly broken and
> in case ii) the DR will not form an adjacency with A and the protocols
> will be able to tell that things are broken.
> 
> Tony
> 
> |    -----Original Message-----
> |    From: Jeff Learman [mailto:[email-masked]]
> |    Sent: Tuesday, June 10, 2003 9:29 AM
> |    To: [email-masked]
> |    Cc: Mailing List; [email-masked]
> |    Subject: Re: [Isis-wg] Re: Inconsistent view of routers over a LAN
> |
> |
> |
> |    This violates the transitivity requirement stated in ISO 10589.
> |    You can't run ISIS on a subnetwork where this happens.
> |    At least, that's the theory ;)
> |
> |    At 11:52 AM 6/10/2003, Cheng-Yin Lee wrote:
> |    >Hello,
> |    >Just got some private responses, perhaps I should clarify.
> |    >This is in context of an emulated LAN, and I am not
> |    looking for a fix in
> |    >routing protocols.
> |    >
> |    >Thanks
> |    >Cheng-Yin
> |    >
> |    >Cheng-Yin Lee wrote:
> |    >>
> |    >> Hello,
> |    >> What happens if for some reason Router A can't reach
> |    Router B, but
> |    >> Router C can reach A & B (and vice-versa), when Router A,B,C are
> |    >> connected over a broadcast network or LAN.
> |    >>
> |    >> E.g. in the case for (OSPF and IS-IS) where:
> |    >> i) C is the DR
> |    >> ii) B is the DR
> |    >>
> |    >> Thanks
> |    >> Cheng-Yin

> Hi Cheng-Yin,
> 
> What I've recommended in the past for these situations is to force
> the routing protocol to view the underlying network as a P2MP
> (Point-to-Multi-Point) network. Many vendors support this. For
> example, in our implementation you'd simply configure:
> 
>    router ospf 1
>     area 0
>      interface backbone
>       network-type point-to-multipoint
>                o
>                o
>           < the rest of the OSPF config>
>                o
> 
> Good Luck,
> Acee

---

From: Naiming Shen <[email-masked]>
Date: Tue, 10 Jun 2003 14:14:20 -0700

i don't think l2vpn wg needs to do much. when use link-state igp
in those places, ALWAYS assume it's unreliable. just use p2p. period.

 ] Jeff, Tony, Acee,
 ] Thanks for your clarification.
 ] L2VPN WG is defining emulated LAN (and broadcast network for IP traffic)
 ] service over IP/MPLS network and some of the mechanims being defined can
 ] result in loss of communication among a subset of routers on the
 ] emulated LAN (even if all the nodes in the underlying IP/MPLS transport
 ] network are reachable).
 ] Some of the discussions have been how tolerable are routing protocols to
 ] this type of problem, if it is worth fixing some L2VPN WG mechanisms to
 ] prevent this problem, how feasible are these L2VPN solutions, are these
 ] not well-known problems ...
 ] 
 ] I hope the L2VPN WG would consider these issues and requirements in the
 ] L2VPN solutions.
 ] Perhaps a more detailed understanding of how things work/don't work may
 ] help L2VPN WG develop/appreciate solutios that will work well with
 ] routers for e.g, in case of (i) below, what would an emulated LAN user
 ] observe in the routed network (is this predictable/unpredictable?)
 ] 
 ] Thanks
 ] Cheng-Yin
 ] p.s I have cced l2vpn, but pls feel free to respond only to the relevant
 ] WG as is appropriate.
 ] 
 ] Tony Li wrote:
 ] > 
 ] > We should also point out that in case i) things are truly broken and
 ] > in case ii) the DR will not form an adjacency with A and the protocols
 ] > will be able to tell that things are broken.
 ] > 
 ] > Tony
 ] > 
 ] > |    -----Original Message-----
 ] > |    From: Jeff Learman [mailto:[email-masked]]
 ] > |    Sent: Tuesday, June 10, 2003 9:29 AM
 ] > |    To: [email-masked]
 ] > |    Cc: Mailing List; [email-masked]
 ] > |    Subject: Re: [Isis-wg] Re: Inconsistent view of routers over a LAN
 ] > |
 ] > |
 ] > |
 ] > |    This violates the transitivity requirement stated in ISO 10589.
 ] > |    You can't run ISIS on a subnetwork where this happens.
 ] > |    At least, that's the theory ;)
 ] > |
 ] > |    At 11:52 AM 6/10/2003, Cheng-Yin Lee wrote:
 ] > |    >Hello,
 ] > |    >Just got some private responses, perhaps I should clarify.
 ] > |    >This is in context of an emulated LAN, and I am not
 ] > |    looking for a fix in
 ] > |    >routing protocols.
 ] > |    >
 ] > |    >Thanks
 ] > |    >Cheng-Yin
 ] > |    >
 ] > |    >Cheng-Yin Lee wrote:
 ] > |    >>
 ] > |    >> Hello,
 ] > |    >> What happens if for some reason Router A can't reach
 ] > |    Router B, but
 ] > |    >> Router C can reach A & B (and vice-versa), when Router A,B,C are
 ] > |    >> connected over a broadcast network or LAN.
 ] > |    >>
 ] > |    >> E.g. in the case for (OSPF and IS-IS) where:
 ] > |    >> i) C is the DR
 ] > |    >> ii) B is the DR
 ] > |    >>
 ] > |    >> Thanks
 ] > |    >> Cheng-Yin
 ] 
 ] 
 ] > Hi Cheng-Yin,
 ] > 
 ] > What I've recommended in the past for these situations is to force
 ] > the routing protocol to view the underlying network as a P2MP
 ] > (Point-to-Multi-Point) network. Many vendors support this. For
 ] > example, in our implementation you'd simply configure:
 ] > 
 ] >    router ospf 1
 ] >     area 0
 ] >      interface backbone
 ] >       network-type point-to-multipoint
 ] >                o
 ] >                o
 ] >           < the rest of the OSPF config>
 ] >                o
 ] > 
 ] > Good Luck,
 ] > Acee
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming