Subject: RE: Updated L2VPN WG charter

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Fri, 6 Jun 2003 13:47:20 -0400

Alex,

Could you clarify the "MPLS-enabled IP network" expression
used in the charter in different places? Why not just mention
MPLS network (which implies IP anyway)? (I am not aware of
existence of MPLS-enabled non-IP network). Something in mind? 

Hamid.

>
> 1. Virtual Private LAN Service--L2 service that emulates LAN
>    across an IP and an MPLS-enabled IP network, allowing standard
>    Ethernet devices communicate with each other as if they were
>    connected to a common LAN segment.
> 
> 2. Virtual Private Wire Service--L2 service that provides L2
>    point-to-point connectivity (e.g. Frame Relay DLCI, ATM VPI/VCI,
>    point-to-point Ethernet) across an IP and an MPLS-enabled
> IP network.
>
> 3. IP-only L2 VPNs--L2 service across an IP and an MPLS-enabled
>    IP network, allowing standard IP devices to communicate with each
>    other as if they were connected to a common LAN segment or a point-
>    to-point circuit.
>
> The WG will address intra-AS scenarios only at this point (other
> scenarios will be considered for inclusion in the updated
> charter when
> the current one is completed.)
>   
> As a general rule, the WG will not create new protocols, but will
> provide functional requirements for extensions of the existing
> protocols that will be discussed in the protocol-specific WGs.
> The group will review proposed protocol extensions for L2VPNs before
> they are recommended to appropriate protocol-specific WGs.
> As a specific example, this WG will not define new encapsulation
> mechanism, but will use those defined in the PWE3 WG.
>
> The WG will work on the following items. Adding new work items
> will require rechartering.
>
> 1. Discovery of PEs participating in L2 service, and
>    topology of required connectivity
>
> 2. Signaling of pseudo-wire and service parameters
>
> 3. Solution documents (providing the framework for a specific
>    solution, should include info on how discovery, signaling,
>    and encaps work together, include security, AS as a separate
>    document)
>
> 4. MIBs
>   
> 5. L2VPN-specific OAM extensions--extensions to existing OAM
>    solutions for VPLS and VPWS.
>
> 6. Interworking of IP devices connected to an IP-only L2 VPN using
>    dissimilar attachment circuits. This topic will be explored only
>    after the basic L2VPN services (VPWS, VPLS, and IP L2VPN) are
>    defined.
>
> Where necessary, the WG will coordinate its activities with IEEE 802.1
>   
> Milestones (optimistic):
>
> JUL 2003  Submit L2 requirements to IESG for publication as
> Informational RFC
> JUL 2003  Submit L2 framework to IESG for publication as
> Informational RFC
> JUL 2003  Identify VPLS and VPWS solutions for the WG
> AUG 2003  Submit an I-D describing MIB for VPLS
> AUG 2003  Submit an I-D describing MIB for VPWS
> AUG 2003  Submit an I-D on OAM for VPLS
> AUG 2003  Submit an I-D on OAM for VPWS
> DEC 2003  Submit VPLS solution documents to IESG
> DEC 2003  Submit VPWS solution documents to IESG
> JAN 2004  Submit IP VPN solution documents to IESG
> FEB 2004  Submit MIB for VPLS to IESG
> FEB 2004  Submit MIB for VPWS to IESG
> MAR 2004  Submit OAM for VPLS to IESG
> MAR 2004  Submit OAM for VPWS to IESG
>
>

---

From: Alex Zinin <[email-masked]>
Date: Fri, 6 Jun 2003 11:05:05 -0700

Hamid,

> existence of MPLS-enabled non-IP network). Something in mind? 

"MPLS-enable IP network" is intended to mean "an IP network that
supports MPLS functionality".

The main idea behind "across an IP and an MPLS-enabled IP network" is
to say that the services should be able to work across pure-IP as well
as MPLS/IP networks.

Do you have some concerns?

Alex