Subject: RE: Updated L2VPN WG charter

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Tue, 10 Jun 2003 15:14:31 -0400

Alex, Loa,

>
> > Qustion: What is a limited number of solutions? Understanding that
> > it is not possible to give an exact number, there is nevertehless
> > a need to understand what the limitations are. A 100 is
> still liomited,
> > but so is 1 or 2.
>
> My opinion is that the _default_ mode for the WG should be one
> solution per item of the list below (VPLS, VPWS, IPL2VPN), each going
> to STD track. If the WG believes at some point that more than one is
> necessary, than (as usual) a strong case would need to be made wrt why
> one is not enough.
>

Not sure this is in fact accurate. The charter indicated
that the l2vpn services need to be provided across both
IP and MPLS-enabled IP network, and since a solution is described 
in the charter as 
 
"providing the framework for a specific solution, 
should include info on how discovery, signaling, and encaps work 
together, include security",
 
It results that we will end up, at least, with two solutions
for the same service...(that's another reason why I think
the charter should mention explicitly that one of desirable
goals is to maximize commonalities among solutions
(even between the IP and MPLS-based solutions).
 
Hamid.
 
(with no intent of respining the "single vs multiple solutions"
debate ;-)).

---

From: Loa Andersson <[email-masked]>
Date: Wed, 11 Jun 2003 00:56:58 +0200

Hamid,

lost track of the arguments. My question and Alex answer below

--------------------------------------------------------------------------

 >            Should it be read as:
 >            a. one solution for IP networks
 >            b. another for MPLS enabled networks
 >            c. or a common solutions that works in both MPLS enabled
 >            networks and in IP networks that is not MPLS enabled

The intent is to say that the WG should aspire to "c" above.

---------------------------------------------------------------------------

So I guess that we all agree - default is one solution per vpws, vpls
and ipls, that works for both ip and mpls enabled ip networks.

same == maximum commonalities!

/Loa

-- 
/Loa

mobile + 46 739 81 21 64
email: [email-masked]