Subject: RE: multi-domain VPLS question (draft-ietf-l2vpn-vpls-ldp-03)

From: "Dror Caspi" <[email-masked]>
Date: Wed, 5 May 2004 12:03:15 +0300

Thanks Marc.
 
To avoid confusion, section 11.3 should clearly state that there must be one and only one border PE-rs per domain per VPLS instance.
 
Dror
 
-----Original Message-----
From: Marc Lasserre [mailto:[email-masked]]
Sent: Tuesday, May 04, 2004 6:40 PM
To: Dror Caspi; [email-masked]
Subject: Re: multi-domain VPLS question (draft-ietf-l2vpn-vpls-ldp-03)
 
Dror,
 
A full mesh of inter-domain spokes must be created between border PE-rs's, not
between domains as implied in your example. Hence, within each domain one 
border PE-rs is selected, and a full mesh of spokes is created per VPLS instance
between these PE-rs's. Note that different border PE-rs's can be used for different 
VPLS instances.
 
Marc
----- Original Message ----- 

From: Dror Caspi <mailto:[email-masked]>  
To: [email-masked] 
Sent: May 04, 2004 16:09
Subject: multi-domain VPLS question (draft-ietf-l2vpn-vpls-ldp-03)
 
Hi,
 
Having read section 11.3 on multi-domain VPLS service, I see a problem with loop avoidance. 
 
To explain this, suppose we have 3 domains: A, B and C.   In domain A, border PE-rs named Ab connects to border PE-rs named Ba in domain B.  Likewise, we have PE-rs pairs Ac-Ca and Bc-Cb.
 
In the above example, it is easy to see that there is a potential loop.  What is not clear is how the split horizon forwarding rules in section 3 avoid those loops.
 
Suppose border PE-rs Ab received a frame from PE-rs Ac.  How would it tell whether this frame originated in domain A (from one of the CEs connected to Ac) or in domain C?
 
Or maybe I am mistaken and a border PE-rs is not allowed to serve CEs directly?  This is not stated in the draft.
 
Any comments are welcome
 
Dror

---

From: "Marc Lasserre" <[email-masked]>
Date: Wed, 5 May 2004 11:21:28 +0200

Dror,

Thanks, I will clarify section 11.3 in the next rev. of the draft.

Marc
  ----- Original Message ----- 
  From: Dror Caspi 
  To: Marc Lasserre ; [email-masked] 
  Sent: May 05, 2004 11:03
  Subject: RE: multi-domain VPLS question (draft-ietf-l2vpn-vpls-ldp-03)

  Thanks Marc.

  Dror

  -----Original Message-----
  From: Marc Lasserre [mailto:[email-masked]]
  Sent: Tuesday, May 04, 2004 6:40 PM
  To: Dror Caspi; [email-masked]
  Subject: Re: multi-domain VPLS question (draft-ietf-l2vpn-vpls-ldp-03)

  Dror,

  VPLS instances.

  Marc

  ----- Original Message ----- 

  From: Dror Caspi 

  To: [email-masked] 

  Sent: May 04, 2004 16:09

  Hi,

  Any comments are welcome

  Dror