Subject: Questions on LDP

From: "Nurit Sprecher" <[email-masked]>
Date: Tue, 11 May 2004 07:37:03 +0200

Hi,
I have some questions on LDP for establishing Tunnel-LSPs, as follows:
1.	What is the common distribution mode in LDP: DoD or DU?
2.	Is that true that in order to use DU in order distribution mode, the LSRs should be merging capable? Otherwise, what is a trigger for a P router to issue a more than label-mapping message for each neighbor?
3.	When DU and conservative retention mode are supported, a downstream node should periodically re-advertise the label binding for a re-routing case. Is that true?
4.	Is LDP a popular method for establishing Tunnel-LSPs?
Thanks,
Nurit.

---

From: [email-masked]
Date: Wed, 12 May 2004 19:27:56 +0300

"Nurit Sprecher"                                                                                                            
                      <nurit.sprecher@SeabridgeNe         To:      <[email-masked]>                                                               
                      tworks.com>                         cc:      "Nurit Sprecher" <[email-masked]>                        
                      Sent by:                            Subject: Questions on LDP                                                               
                      [email-masked]                                                                                                        

                      10/05/2004 21:25                                                                                                            

Hi Nurit,
Please find some (I'm still thinking about number Question 2 ;-)) answers
in-line.
Hope this helps.

Regards,
/Moshe

>> 1. What is the common distribution mode in LDP: DoD or DU?

See ftp://ftp.rfc-editor.org/in-notes/rfc3037.txt (LDP Applicability) for
discussion on this issue. IMHO DoD is used more (it saves memory, and is
more conservative/secure), but there are scenarios suited for each method.

>> 2. Is that true that in order to use DU in order distribution mode, the
LSRs should be merging capable?
>> Otherwise, what is a trigger for a P router to issue a more than
label-mapping message for each neighbor?

>> 3. When DU and conservative retention mode are supported, a downstream
node should periodically re-advertise the >> label binding for a re-routing
case. Is that true?

I quote from RFC3036 (wrt the combination of Downstream Unsolicited mode
and conservative label retention clause 3.5.7.1.4.): "In situations where
Ru [upstream LSR] may not know that it needs the label, Rd [downstream LSR]
is responsible for periodically readvertising the label to Ru.
For this version of LDP, the only situation where Ru knows it needs a label
for a FEC from Rd is when Rd is its next hop for the FEC, Ru does not have
a label from Rd, and the LSP for the FEC is one that can be established
with TLVs defined in this document."

So I guess the answer is yes.

>> 4. Is LDP a popular method for establishing Tunnel-LSPs?
RSVP is clearly the more popular method for establishing Tunnel-LSPs.
Moreover, RSVP-TE is the only one currently supporting explicit routes
(CR-LDP is dead-meat see RFC3468), so whenever TE is required, RSVP-TE is
there.

Of course that means you have to support both RSVP-TE and LDP for a TE
capable VPLS... (search l2vpn list's archive for my question on the need
for both LDP and RSVP-TE).

>> Nurit