Subject: RE: Question on RSTP/MSTP between CE and PE

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Thu, 12 Jan 2006 22:19:32 -0800

The short answer is to take a look at clauses 15 and 13 of 802.1ad
(rev.D6).

-Ali  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Ravindra Rathi
> Sent: Wednesday, January 11, 2006 3:28 AM
> To: [email-masked]
> Subject: Question on RSTP/MSTP between CE and PE
> 
> This is regarding following text in 
> draft-sajassi-l2vpn-vpls-bridge-interop-01.txt.
> 
> <snip>
> For example, when an Attachment Circuit is port-based, then 
> the bridge module of the PE can operate transparently with 
> respect to the CEs RSTP/MSTP protocols (and thus no C-VLAN 
> component is required for that customer UNI). However, when 
> an Attachment Circuit is VLAN-based (either VLAN mapping or 
> VLAN bundling), then the bridge module of the PE needs to 
> peer with the RSTP/MSTP protocols running on the CE (and thus 
> the C-VLAN bridge component is required).
> </snip>
> 
> Can anyone explain clearly why PE need not participate in 
> CE's RSTP/MSTP protocols if attachment circuit(AC) is port 
> based and why it should participate if AC is vlan based..?
> 
> Thanks,
> Rathi
>

---

From: Ravindra Rathi <[email-masked]>
Date: Fri, 20 Jan 2006 21:41:15 +0530

Ali,
     Thanks for replying. I took a look at both the clauses of
802.1ad spec. But I am still not able to understand clearly. Spec
just says when you need to run MSTP between the CE and PE and it
doesn't really explain why (as in why looping can happen if MSTP
is not run between CE and PE).

It will be really nice if you can answer my questions with
following example topology.

1. Why no need to run MSTP/RSTP  if AC is port based..?
    Actually, that I can understand since PEs are acting as
    a hub with respect to BPDUs and hence looping can't
    happen.

2. Why MSTP/RSTP needs to be run if AC is vlan based to avoid
    looping..?

      +------+     +------+               +------+      +------+
      |  CE  |-----|  PE  |----........---|  PE  |------| CE   |
      |dev 1 |     |dev A |               |dev B |      | dev 3|
      +------+   / +------+               +------+      +------+
         |      /
    Back |     /
    door |    /
    link |   /
      +------+
      |  CE  |
      |dev 2 |
      +------+

Thanks,
Rathi