Subject: RE: Are E-Tree requirements addressed in the VPMS requirement

From: Jiang Yuanlong <[email-masked]>
Date: Fri, 16 Jul 2010 11:18:21 +0800

Hi colleagues in L2VPN WG,

I also agree that VPMS is only a subset of E-Tree.

Considering that both root and leaf may have unicast/multicast requirement, 
and unicast should not forward in the same way as multicast, it seems 
destination address in Ethernet frame MUST be used in data forwarding in the 
genreric E-Tree.
Any comments?

Regards
Yuanlong

> Date: Thu, 15 Jul 2010 06:31:09 -0400
> From:
> Subject: RE: Are E-Tree requirements addressed in the VPMS requirement
> draft?
> To: <[email-masked]>, <[email-masked]>
> Cc: [email-masked]
> Message-ID:
> <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
>
> Agreed..
>
> Jim Uttaro
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Raymond Key
> Sent: Wednesday, July 14, 2010 4:20 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Are E-Tree requirements addressed in the VPMS requirement
> draft?
>
> Quote from IETF 77 L2VPN WG minutes -
> Shane: really would like to see review of the drafts and to see if the
> ETREE requirements are addressed in the VPMS requirements draft.
>
> I would like to share my view with the working group.
>
> The focus of VPMS (Virtual Private Multicast Service) is to provide
> point-to-multipoint connectivity.
>
> VPMS provides single coverage of receiver membership. A VPMS service
> supports single Root AC. All traffic from the Root AC will be forwarded
> to all Leaf ACs (i.e. P2MP, from Root to all Leafs). Destination address
> in Ethernet frame is not used in data forwarding. As an optional
> capability, a VPMS service may support reverse traffic from a Leaf AC to
> the Root AC (i.e. P2P, from Leaf to Root).
>
> The focus of MEF E-Tree is that a Leaf can only communicate with Roots
> but not Leafs.
>
> A generic MEF E-Tree service supports multiple Root endpoints. Whether a
> particular E-Tree service needs to support single or multiple Root
> endpoints depends on the target application.
>
> A generic MEF E-Tree service supports all the following traffic flows:
> - Ethernet Unicast bidirectional Root to/from Root
> - Etherent Unicast bidirectional Root to/from Leaf
> - Ethernet Broadcast/Multicast unidirectional Root to all Roots & Leafs
> - Ethernet Broadcast/Multicast unidirectional Leaf to all Roots.
> A particular E-Tree service may need to support all the above or only a
> subset depending on the target application.
>
> IETF's VPMS definition and MEF's E-Tree definiton are significantly
> different.
>
> Only for special case E-Tree service where
> - Single Root only
> - No Unicast traffic from Root destined for a specific Leaf (or there is
> no concern if such Unicast traffic are forwarded to all Leafs),
> VPMS will be able to meet the requirement. An exmaple is single-root
> E-Tree service for content delivery application.
>
> For generic E-Tree service, VPMS will not be able to meet the
> requirement.
>
> Thanks,
> Raymond Key
>
>
> ------------------------------

---

From: Yong Lucy <[email-masked]>
Date: Fri, 16 Jul 2010 09:29:40 -0500

Raymond analysis is very accurate. Definition of VPMS and E-Tree are very
different.

Carriers have a request to use VPLS for E-Tree service, can the WG work this
item.

Regards,
Lucy

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jiang Yuanlong
> Sent: Thursday, July 15, 2010 10:18 PM
> To: Jim; Shane Amante; [email-masked]
> Cc: [email-masked]

---

From: <[email-masked]>
Date: Mon, 19 Jul 2010 11:22:38 +0200

I would also like to thank you, Raymond, for your excellent analysis and summary. Absolutely agree to it as well. 

I also see the need to make progress on solutions, i.e. for E-Tree based on VPLS.

Thanks,
Manuel

> Yong Lucy
> Sent: Friday, July 16, 2010 4:30 PM
> To: 'Jiang Yuanlong'; 'Jim'; 'Shane Amante'; [email-masked]
> Cc: [email-masked]
> Of